[package] add libxmlrpc-c
git-svn-id: svn://svn.openwrt.org/openwrt/packages@15089 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
14a33199db
commit
b708bf225b
72
libs/xmlrpc-c/Makefile
Normal file
72
libs/xmlrpc-c/Makefile
Normal file
@ -0,0 +1,72 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2007-2009 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $ sav $
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=xmlrpc-c
|
||||||
|
PKG_REV:=1686
|
||||||
|
PKG_VERSION:=1.17.7_r$(PKG_REV)
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_SOURCE_URL:=https://xmlrpc-c.svn.sourceforge.net/svnroot/xmlrpc-c/advanced
|
||||||
|
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||||
|
PKG_SOURCE_PROTO:=svn
|
||||||
|
|
||||||
|
PKG_BUILD_DEPENDS:=libcurl libxml2
|
||||||
|
|
||||||
|
PKG_FIXUP = libtool
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/xmlrpc-c
|
||||||
|
SUBMENU:=xmlrpc-c
|
||||||
|
SECTION:=library
|
||||||
|
CATEGORY:=lib
|
||||||
|
TITLE:=xmlrpc-c library
|
||||||
|
URL:=http://xmlrpc-c.sourceforge.net/
|
||||||
|
DEPENDS:=+libcurl +libxml2
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/xmlrpc-c/description
|
||||||
|
XMLRPC-C
|
||||||
|
endef
|
||||||
|
|
||||||
|
CONFIGURE_ARGS+= \
|
||||||
|
--enable-libxml2-backend \
|
||||||
|
--disable-wininet-client \
|
||||||
|
--disable-libwww-client \
|
||||||
|
--disable-abyss-server \
|
||||||
|
--disable-cplusplus \
|
||||||
|
--disable-static \
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/InstallDev
|
||||||
|
mkdir -p $(1)/usr/include
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
|
||||||
|
mkdir -p $(1)/usr/include/xmlrpc-c
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/xmlrpc-c/*.h $(1)/usr/include/xmlrpc-c
|
||||||
|
mkdir -p $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxmlrpc*.{a,so*} $(1)/usr/lib/
|
||||||
|
mkdir -p $(1)/usr/bin
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/xmlrpc-c-config $(1)/usr/bin/
|
||||||
|
$(SED) 's,HEADERINST_DIR="/usr/include",HEADERINST_DIR="$(STAGING_DIR)/usr/include",g' $(1)/usr/bin/xmlrpc-c-config
|
||||||
|
$(SED) 's,LIBINST_DIR="/usr/lib",LIBINST_DIR="$(STAGING_DIR)/usr/lib",g' $(1)/usr/bin/xmlrpc-c-config
|
||||||
|
mkdir -p $(2)/bin
|
||||||
|
ln -sf $(STAGING_DIR)/usr/bin/xmlrpc-c-config $(2)/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/xmlrpc-c/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libxmlrpc*.so* $(1)/usr/lib/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,xmlrpc-c))
|
11
libs/xmlrpc-c/patches/001-config.mk.in.patch
Normal file
11
libs/xmlrpc-c/patches/001-config.mk.in.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/config.mk.in 2009-02-20 13:00:04.000000000 +0300
|
||||||
|
+++ b/config.mk.in 2009-02-24 15:26:52.000000000 +0300
|
||||||
|
@@ -173,7 +173,7 @@
|
||||||
|
shlibfn = $(1:%=%.$(SHLIB_SUFFIX).$(MAJ).$(MIN))
|
||||||
|
shliblefn = $(1:%=%.$(SHLIB_SUFFIX))
|
||||||
|
# SHLIB_CLIB = -lc
|
||||||
|
- LDFLAGS_SHLIB = -shared -Wl,-soname,$(SONAME) $(SHLIB_CLIB)
|
||||||
|
+ LDFLAGS_SHLIB = -shared -Wl,-soname,$(SONAME) $(SHLIB_CLIB) $(LDFLAGS)
|
||||||
|
CFLAGS_SHLIB=-fPIC
|
||||||
|
endif
|
||||||
|
|
10
libs/xmlrpc-c/patches/005-curl_transport_Makefile.patch
Normal file
10
libs/xmlrpc-c/patches/005-curl_transport_Makefile.patch
Normal file
@ -0,0 +1,10 @@
|
|||||||
|
--- a/lib/curl_transport/Makefile 2009-02-20 13:00:03.000000000 +0300
|
||||||
|
+++ b/lib/curl_transport/Makefile 2009-02-20 16:54:45.000000000 +0300
|
||||||
|
@@ -34,6 +34,7 @@
|
||||||
|
-I$(BLDDIR)/include \
|
||||||
|
-I$(SRCDIR)/include \
|
||||||
|
-I$(SRCDIR)/lib/util/include \
|
||||||
|
+ -I$(STAGING_DIR)/usr/include \
|
||||||
|
$(CURL_INCLUDES)
|
||||||
|
|
||||||
|
.PHONY: clean
|
Loading…
x
Reference in New Issue
Block a user