[packages] gpsd: update to 3.6
* add staging prefix patch for the pkg-config wrapper variables * re-enable libusb support * add a gpsd-clients package (#7879) * drop obsolete patches git-svn-id: svn://svn.openwrt.org/openwrt/packages@31853 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8b9c7748ad
commit
b8f38d75d8
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,22 +8,14 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=gpsd
|
||||
PKG_REV:=ffcc14068ada0d565f237efa56c7cd723847ca04
|
||||
PKG_VERSION:=3.5-20120414
|
||||
#PKG_VERSION:=20110917
|
||||
PKG_RELEASE:=5
|
||||
PKG_VERSION:=3.6
|
||||
PKG_RELEASE:=1
|
||||
|
||||
#PKG_SOURCE_URL:=http://download-mirror.savannah.gnu.org/releases/gpsd/
|
||||
#PKG_MD5SUM:=c01353459faa68834309109d4e868460
|
||||
|
||||
#PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=git://git.sv.gnu.org/gpsd.git
|
||||
PKG_SOURCE_PROTO:=git
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://download-mirror.savannah.gnu.org/releases/gpsd
|
||||
PKG_MD5SUM:=064a5ad75593f8c3ea3fe85010647832
|
||||
|
||||
PKG_BUILD_DEPENDS:=libncurses
|
||||
PKG_BUILD_DEPENDS:=libncurses libusb-1.0
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include $(INCLUDE_DIR)/scons.mk
|
||||
@ -60,23 +52,25 @@ define Package/gpsd/description
|
||||
This package contains the GPS daemon.
|
||||
endef
|
||||
|
||||
define Package/cgps
|
||||
define Package/gpsd-clients
|
||||
$(call Package/gpsd/Default)
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS+= +libgps +libncurses
|
||||
TITLE:=Test client for gpsd
|
||||
DEPENDS+= +libgps +libgpsd +libncurses
|
||||
TITLE:=GPS tools and clients
|
||||
endef
|
||||
|
||||
define Package/cgps/description
|
||||
define Package/gpsd-clients/description
|
||||
$(call Package/gpsd/Default/description)
|
||||
This package contains a GPS test client.
|
||||
This package contains auxiliary tools and example clients for monitoring and
|
||||
testing the GPS daemon.
|
||||
endef
|
||||
|
||||
define Package/libgps
|
||||
$(call Package/gpsd/Default)
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS+= +libcap
|
||||
TITLE:=C service library for communicating with the GPS daemon
|
||||
endef
|
||||
|
||||
@ -89,6 +83,7 @@ define Package/libgpsd
|
||||
$(call Package/gpsd/Default)
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS+= +libcap +libusb-1.0
|
||||
TITLE:=C service library for GPS applications
|
||||
endef
|
||||
|
||||
@ -113,8 +108,8 @@ SCONS_OPTIONS += \
|
||||
bluez=no \
|
||||
strip=no \
|
||||
python=no \
|
||||
usb=no \
|
||||
implicit_link=no
|
||||
implicit_link=no \
|
||||
chrpath=no
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
@ -138,9 +133,14 @@ define Package/gpsd/install
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/gpsd $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
define Package/cgps/install
|
||||
define Package/gpsd-clients/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/cgps $(1)/usr/bin/
|
||||
$(INSTALL_BIN) \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/cgps \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/gps{ctl,decode,mon,pipe} \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/gpxlogger \
|
||||
$(PKG_INSTALL_DIR)/usr/bin/lcdgps \
|
||||
$(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/libgps/install
|
||||
@ -154,6 +154,6 @@ define Package/libgpsd/install
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,gpsd))
|
||||
$(eval $(call BuildPackage,cgps))
|
||||
$(eval $(call BuildPackage,gpsd-clients))
|
||||
$(eval $(call BuildPackage,libgps))
|
||||
$(eval $(call BuildPackage,libgpsd))
|
||||
|
@ -1,35 +0,0 @@
|
||||
From c7a6bf126c17e997428ee925aad62b2fd70dc316 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Taht <dave.taht@bufferbloat.net>
|
||||
Date: Fri, 13 Apr 2012 23:14:06 -0700
|
||||
Subject: [PATCH] _XOPEN_SOURCE breaks CLOCK_REALTIME in uclibc
|
||||
|
||||
Since you can't tell what library you are using...
|
||||
until after you include features.h
|
||||
which after you would set _XOPEN_SOURCE
|
||||
and if you set _XOPEN_SOURCE you can't re-include features.h
|
||||
we have a recursive dependency.
|
||||
|
||||
I have no idea how to handle this, so I'll just carry a patch
|
||||
in openwrt.
|
||||
---
|
||||
gpsutils.c | 4 ----
|
||||
1 files changed, 0 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/gpsutils.c b/gpsutils.c
|
||||
index 60c4ae9..95ab456 100644
|
||||
--- a/gpsutils.c
|
||||
+++ b/gpsutils.c
|
||||
@@ -4,10 +4,6 @@
|
||||
* BSD terms apply: see the file COPYING in the distribution root for details.
|
||||
*/
|
||||
|
||||
-/* The strptime prototype is not provided unless explicitly requested.
|
||||
- * So add the define that POSIX says to to avoid: */
|
||||
-#define _XOPEN_SOURCE
|
||||
-
|
||||
#include <stdio.h>
|
||||
#include <time.h>
|
||||
#include <sys/time.h>
|
||||
--
|
||||
1.7.5.4
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- a/SConstruct
|
||||
+++ b/SConstruct
|
||||
@@ -199,6 +199,7 @@ import_env = (
|
||||
@@ -200,6 +200,7 @@ import_env = (
|
||||
'PATH', # Required for ccache and Coverity scan-build
|
||||
'PKG_CONFIG_PATH', # Set .pc file directory in a crossbuild
|
||||
'STAGING_PREFIX', # Required by the OpenWRT build.
|
||||
+ 'STAGING_DIR', # Required by the OpenWRT build.
|
||||
'STAGING_DIR', # Required by the OpenWRT build.
|
||||
+ 'STAGING_PREFIX', # Required by the OpenWRT build.
|
||||
)
|
||||
envs = {}
|
||||
for var in import_env:
|
@ -1,41 +0,0 @@
|
||||
--- a/SConstruct
|
||||
+++ b/SConstruct
|
||||
@@ -270,8 +270,6 @@ def installdir(dir, add_destdir=True):
|
||||
|
||||
# Honor the specified installation prefix in link paths.
|
||||
env.Prepend(LIBPATH=[installdir('libdir')])
|
||||
-if env["shared"]:
|
||||
- env.Prepend(RPATH=[installdir('libdir')])
|
||||
|
||||
# Give deheader a way to set compiler flags
|
||||
if 'MORECFLAGS' in os.environ:
|
||||
@@ -390,17 +388,6 @@ config = Configure(env, custom_tests = {
|
||||
'CheckXsltproc' : CheckXsltproc})
|
||||
|
||||
env.Prepend(LIBPATH=[os.path.realpath(os.curdir)])
|
||||
-if config.CheckExecutable('$CHRPATH -v', 'chrpath'):
|
||||
- # Tell generated binaries to look in the current directory for
|
||||
- # shared libraries so we can run tests without hassle. Should be
|
||||
- # handled sanely by scons on all systems. Not good to use '.' or
|
||||
- # a relative path here; it's a security risk. At install time we
|
||||
- # use chrpath to edit this out of RPATH.
|
||||
- if env["shared"]:
|
||||
- env.Prepend(RPATH=[os.path.realpath(os.curdir)])
|
||||
-else:
|
||||
- print "chrpath is not available, forcing static linking."
|
||||
- env["shared"] = False
|
||||
|
||||
confdefs = ["/* gpsd_config.h. Generated by scons, do not hand-hack. */\n"]
|
||||
|
||||
@@ -1147,11 +1134,6 @@ binaryinstall.append(LibraryInstall(env,
|
||||
if qt_env:
|
||||
binaryinstall.append(LibraryInstall(qt_env, installdir('libdir'), compiled_qgpsmmlib))
|
||||
|
||||
-# We don't use installdir here in order to avoid having DESTDIR affect the rpath
|
||||
-if env["shared"]:
|
||||
- env.AddPostAction(binaryinstall, '$CHRPATH -r "%s" "$TARGET"' \
|
||||
- % (installdir('libdir', False), ))
|
||||
-
|
||||
if not env['debug'] and not env['profiling'] and env['strip']:
|
||||
env.AddPostAction(binaryinstall, '$STRIP $TARGET')
|
||||
|
11
net/gpsd/patches/002-no_rpath.patch
Normal file
11
net/gpsd/patches/002-no_rpath.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/SConstruct
|
||||
+++ b/SConstruct
|
||||
@@ -269,8 +269,6 @@ def installdir(dir, add_destdir=True):
|
||||
|
||||
# Honor the specified installation prefix in link paths.
|
||||
env.Prepend(LIBPATH=[installdir('libdir')])
|
||||
-if env["shared"]:
|
||||
- env.Prepend(RPATH=[installdir('libdir')])
|
||||
|
||||
# Give deheader a way to set compiler flags
|
||||
if 'MORECFLAGS' in os.environ:
|
Loading…
x
Reference in New Issue
Block a user