port lcd4linux to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4338 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b93570ee4f
commit
b901361744
74
utils/lcd4linux/Makefile
Normal file
74
utils/lcd4linux/Makefile
Normal file
@ -0,0 +1,74 @@
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lcd4linux
|
||||
PKG_VERSION:=0.10.0+cvs20051015
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION).orig
|
||||
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION).orig.tar.gz
|
||||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/l/lcd4linux/ \
|
||||
http://ftp.de.debian.org/debian/pool/main/l/lcd4linux/
|
||||
PKG_MD5SUM:=5b5ac629be4bb5c29104fb8f6b7fa444
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/lcd4linux
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
DEPENDS:=+libncurses
|
||||
TITLE:=LCD display utility
|
||||
DESCRIPTION:=LCD display utility.\\\
|
||||
LCD4Linux is a small program that grabs information from the kernel and \\\
|
||||
some subsystems and displays it on an external liquid crystal display.
|
||||
URL:=http://lcd4linux.bulix.org/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
$(DISABLE_NLS) \
|
||||
--without-x \
|
||||
--with-drivers='all,!PNG,!RouterBoard,!X11' \
|
||||
--with-plugins=wireless \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC=$(TARGET_CC) LD=$(TARGET_CROSS)ld \
|
||||
CFLAGS="$(TARGET_CFLAGS) -Wall"
|
||||
endef
|
||||
|
||||
define Package/lcd4linux/install
|
||||
install -d -m0755 $(1)/usr/bin
|
||||
install -m0755 $(PKG_BUILD_DIR)/lcd4linux $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,lcd4linux))
|
11
utils/lcd4linux/patches/100-drv_RouterBoard.patch
Normal file
11
utils/lcd4linux/patches/100-drv_RouterBoard.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- lcd4linux-0.10.0-RC1/drv_RouterBoard.c 2004-08-30 15:20:45.000000000 +0200
|
||||
+++ lcd-patched/drv_RouterBoard.c 2005-03-19 16:03:26.849650830 +0100
|
||||
@@ -113,7 +113,7 @@
|
||||
#include <string.h>
|
||||
#include <errno.h>
|
||||
#include <unistd.h>
|
||||
-#include <sys/io.h>
|
||||
+#include <asm/io.h>
|
||||
|
||||
#include "debug.h"
|
||||
#include "cfg.h"
|
12
utils/lcd4linux/patches/110-ucdelay.patch
Normal file
12
utils/lcd4linux/patches/110-ucdelay.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -urN lcd4linux.old/udelay.h lcd4linux.dev/udelay.h
|
||||
--- lcd4linux.old/udelay.h 2005-05-08 06:32:45.000000000 +0200
|
||||
+++ lcd4linux.dev/udelay.h 2006-01-20 03:50:36.806897500 +0100
|
||||
@@ -76,7 +76,7 @@
|
||||
/* REP NOP (PAUSE) is a good thing to insert into busy-wait loops. */
|
||||
static inline void rep_nop(void)
|
||||
{
|
||||
- __asm__ __volatile__("rep; nop");
|
||||
+ __asm__ __volatile__("nop");
|
||||
}
|
||||
|
||||
|
15
utils/lcd4linux/patches/120-remove_parport_outb.patch
Normal file
15
utils/lcd4linux/patches/120-remove_parport_outb.patch
Normal file
@ -0,0 +1,15 @@
|
||||
diff -urN lcd4linux.old/drv_generic_parport.c lcd4linux.dev/drv_generic_parport.c
|
||||
--- lcd4linux.old/drv_generic_parport.c 2006-01-20 03:52:18.426419500 +0100
|
||||
+++ lcd4linux.dev/drv_generic_parport.c 2006-01-20 03:57:59.205263500 +0100
|
||||
@@ -134,6 +134,11 @@
|
||||
#define PARPORT_STATUS_BUSY 0x80
|
||||
#endif
|
||||
|
||||
+#ifndef WITH_OUTB
|
||||
+#define inb(foo) 0
|
||||
+#define outb(foo,bar) 0
|
||||
+#endif
|
||||
+
|
||||
#if !defined(WITH_OUTB) && !defined(WITH_PPDEV)
|
||||
#error neither outb() nor ppdev() possible
|
||||
#error cannot compile parallel port driver
|
Loading…
x
Reference in New Issue
Block a user