upgrade mdadm package
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26755 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a775a89c31
commit
b97a34cc77
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2008 OpenWrt.org
|
# Copyright (C) 2008-2011 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,14 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mdadm
|
PKG_NAME:=mdadm
|
||||||
PKG_VERSION:=2.6.7.2
|
PKG_VERSION:=3.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
PKG_MD5SUM:=e4badb4a8ded4344ba0fa785883955d8
|
|
||||||
|
|
||||||
PKG_SOURCE_URL:=@KERNEL/linux/utils/raid/mdadm
|
PKG_SOURCE_URL:=@KERNEL/linux/utils/raid/mdadm
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
PKG_MD5SUM:=4ac70ccead74f947bf5aa4d189a977a0
|
||||||
|
|
||||||
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -23,6 +25,11 @@ define Package/mdadm
|
|||||||
TITLE:=A tool for managing Soft RAID under Linux
|
TITLE:=A tool for managing Soft RAID under Linux
|
||||||
URL:=http://www.kernel.org/pub/linux/utils/raid/mdadm/
|
URL:=http://www.kernel.org/pub/linux/utils/raid/mdadm/
|
||||||
DEPENDS:=@!LINUX_2_4
|
DEPENDS:=@!LINUX_2_4
|
||||||
|
MAINTAINER:=Luka Perkov <openwrt@lukaperkov.net>
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/at/description
|
||||||
|
A tool for managing Linux Software RAID arrays.
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
|
@ -1,24 +1,21 @@
|
|||||||
Only in mdadm-2.6.7.2: .prepared_52c8003c1cfc25b1e96897208f1a6856
|
Index: mdadm-3.2/Makefile
|
||||||
Only in mdadm-2.6.7.2.orig/: .prepared_b70de0be5a277506820fdcd9a21e9deb
|
===================================================================
|
||||||
diff -ur mdadm-2.6.7.2.orig/Makefile mdadm-2.6.7.2/Makefile
|
--- mdadm-3.2.orig/Makefile
|
||||||
--- mdadm-2.6.7.2.orig/Makefile 2008-11-21 18:21:35.000000000 +0100
|
+++ mdadm-3.2/Makefile
|
||||||
+++ mdadm-2.6.7.2/Makefile 2008-11-21 19:13:54.000000000 +0100
|
@@ -76,7 +76,6 @@ FAILED_SLOTS_DIR = /dev/.mdadm/failed-sl
|
||||||
@@ -52,7 +52,7 @@
|
DIRFLAGS = -DMAP_DIR=\"$(MAP_DIR)\" -DMAP_FILE=\"$(MAP_FILE)\"
|
||||||
CONFFILE2 = $(SYSCONFDIR)/mdadm/mdadm.conf
|
DIRFLAGS += -DMDMON_DIR=\"$(MDMON_DIR)\"
|
||||||
MAILCMD =/usr/sbin/sendmail -t
|
DIRFLAGS += -DFAILED_SLOTS_DIR=\"$(FAILED_SLOTS_DIR)\"
|
||||||
CONFFILEFLAGS = -DCONFFILE=\"$(CONFFILE)\" -DCONFFILE2=\"$(CONFFILE2)\"
|
-CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS) $(DIRFLAGS)
|
||||||
-CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS)
|
|
||||||
+#CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS)
|
|
||||||
|
|
||||||
# If you want a static binary, you might uncomment these
|
# The glibc TLS ABI requires applications that call clone(2) to set up
|
||||||
# LDFLAGS = -static
|
# TLS data structures, use pthreads until mdmon implements this support
|
||||||
@@ -124,7 +124,7 @@
|
@@ -184,7 +183,7 @@ test_stripe : restripe.c mdadm.h
|
||||||
|
|
||||||
mdassemble : $(ASSEMBLE_SRCS) mdadm.h
|
mdassemble : $(ASSEMBLE_SRCS) $(INCL)
|
||||||
rm -f $(OBJS)
|
rm -f $(OBJS)
|
||||||
- $(DIET_GCC) $(ASSEMBLE_FLAGS) -o mdassemble $(ASSEMBLE_SRCS) $(STATICSRC)
|
- $(DIET_GCC) $(ASSEMBLE_FLAGS) -o mdassemble $(ASSEMBLE_SRCS) $(STATICSRC)
|
||||||
+ $(CC) $(ASSEMBLE_FLAGS) -o mdassemble $(ASSEMBLE_SRCS) $(STATICSRC)
|
+ $(CC) $(ASSEMBLE_FLAGS) -o mdassemble $(ASSEMBLE_SRCS) $(STATICSRC)
|
||||||
|
|
||||||
mdassemble.static : $(ASSEMBLE_SRCS) mdadm.h
|
mdassemble.static : $(ASSEMBLE_SRCS) $(INCL)
|
||||||
rm -f $(OBJS)
|
rm -f $(OBJS)
|
||||||
Only in mdadm-2.6.7.2: mdadm
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user