libimobiledevice, usbmuxd, libplist, libusbmuxd: move to github

git-svn-id: svn://svn.openwrt.org/openwrt/packages@42667 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cyrus 2014-09-26 06:47:38 +00:00
parent e154abd20d
commit bcd0b2faf8
5 changed files with 0 additions and 350 deletions

View File

@ -1,91 +0,0 @@
#
# Copyright (C) 2012-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=libimobiledevice
PKG_VERSION:=1.1.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.libimobiledevice.org/downloads
PKG_MD5SUM:=274783651e9b772774cd9fed2fc52e08
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
$(call include_mk, python-package.mk)
define Package/libimobiledevice/Default
TITLE:=A library that talks to Apple devices.
URL:=http://www.libimobiledevice.org/
endef
define Package/libimobiledevice/Default/description
libimobiledevice is a software library that talks the protocols to support
iPhone®, iPod Touch®, iPad® and Apple TV® devices.
endef
define Package/libimobiledevice
$(call Package/libimobiledevice/Default)
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libgcrypt +libgnutls $(ICONV_DEPENDS) +libplist +libtasn1 +libusbmuxd
endef
define Package/libimobiledevice/description
$(call Package/libimobiledevice/Default/description)
endef
define Package/libimobiledevice-utils
$(call Package/libimobiledevice/Default)
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+libimobiledevice
endef
define Package/libimobiledevice-utils/description
$(call Package/libimobiledevice/Default/description)
This package contains the libimobiledevice utilities.
endef
CONFIGURE_VARS += \
libusbmuxd_CFLAGS="-I$(STAGING_DIR)/usr/include" \
libusbmuxd_LIBS="-L$(STAGING_DIR)/usr/lib -lusbmuxd" \
openssl_CFLAGS=" " \
openssl_LIBS=" "
CONFIGURE_ARGS += \
--without-cython \
--disable-largefile \
--disable-openssl
TARGET_LDFLAGS += -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/libimobiledevice $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libimobiledevice.{a,la,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libimobiledevice-*.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libimobiledevice/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libimobiledevice.so.* $(1)/usr/lib/
endef
define Package/libimobiledevice-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/idevice* $(1)/usr/bin/
endef
$(eval $(call BuildPackage,libimobiledevice))
$(eval $(call BuildPackage,libimobiledevice-utils))

View File

@ -1,98 +0,0 @@
#
# Copyright (C) 2012-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=libplist
PKG_VERSION:=1.11
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.libimobiledevice.org/downloads
PKG_MD5SUM:=82de65f38cb2f0a9fd0839679b46072b
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/libplist/Default
TITLE:=Apple property list
URL:=http://www.libimobiledevice.org/
endef
define Package/libplist/Default/description
A library to handle Apple Property List format whereas it's binary or XML
endef
define Package/libplist
$(call Package/libplist/Default)
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libxml2
TITLE+= library
endef
define Package/libplist/description
$(call Package/libplist/Default/description)
endef
define Package/libplistcxx
$(call Package/libplist/Default)
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libplist +libstdcpp
TITLE+= C++ library
endef
define Package/libplistcxx/description
$(call Package/libplist/Default/description)
This package contains the libplist C++ shared library.
endef
define Package/libplist-utils
$(call Package/libplist/Default)
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+libplist
TITLE+= converter
endef
define Package/libplist-utils/description
$(call Package/libplist/Default/description)
This package contains the libplist utilities.
endef
CONFIGURE_ARGS += \
--without-cython
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/plist $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist*.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libplist*.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libplist/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist.so.* $(1)/usr/lib/
endef
define Package/libplistcxx/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libplist++.so.* $(1)/usr/lib/
endef
define Package/libplist-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/plistutil $(1)/usr/bin/
endef
$(eval $(call BuildPackage,libplist))
$(eval $(call BuildPackage,libplistcxx))
$(eval $(call BuildPackage,libplist-utils))

View File

@ -1,83 +0,0 @@
#
# Copyright (C) 2012-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=libusbmuxd
PKG_VERSION:=1.0.9
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.libimobiledevice.org/downloads
PKG_MD5SUM:=3f1d4bd0c0a1a4d7bf96219e117ec499
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
define Package/libusbmuxd/Default
TITLE:=USB multiplexing daemon
URL:=http://www.libimobiledevice.org/
endef
define Package/libusbmuxd/Default/description
This daemon is in charge of multiplexing connections over USB to an iPhone or
iPod touch. To users, it means you can sync your music, contacts, photos, etc.
over USB. To developers, it means you can connect to any listening localhost
socket on the device. usbmuxd is not used for tethering data transfer, which
uses a dedicated USB interface as a virtual network device.
endef
define Package/libusbmuxd
$(call Package/libusbmuxd/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE+= library
DEPENDS:=+libplist +libpthread +libxml2 +zlib
endef
define Package/libusbmuxd/description
$(call Package/libusbmuxd/Default/description)
This package contains the libusbmuxd shared library.
endef
define Package/libusbmuxd-utils
$(call Package/libusbmuxd/Default)
SECTION:=utils
CATEGORY:=Utilities
TITLE+= utilies
DEPENDS:=+libusbmuxd
endef
define Package/libusbmuxd-utils/description
$(call Package/libusbmuxd/Default/description)
This package contains the libusbmuxd utilities.
endef
TARGET_CFLAGS += $(FPIC)
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/*.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbmuxd.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libusbmuxd.pc $(1)/usr/lib/pkgconfig/
endef
define Package/libusbmuxd/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbmuxd.so.* $(1)/usr/lib/
endef
define Package/libusbmuxd-utils/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/iproxy $(1)/usr/bin/
endef
$(eval $(call BuildPackage,libusbmuxd))
$(eval $(call BuildPackage,libusbmuxd-utils))

View File

@ -1,46 +0,0 @@
#
# Copyright (C) 2012-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=usbmuxd
PKG_VERSION:=1.0.8
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.libimobiledevice.org/downloads
PKG_MD5SUM:=4b33cc78e479e0f9a6745f9b9a8b60a8
CMAKE_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/usbmuxd
SECTION:=utils
CATEGORY:=Utilities
TITLE:=USB multiplexing daemon
URL:=http://www.libimobiledevice.org/
DEPENDS:=+librt +libusb-1.0 +libusbmuxd
endef
define Package/usbmuxd/description
This daemon is in charge of multiplexing connections over USB to an iPhone or
iPod touch. To users, it means you can sync your music, contacts, photos, etc.
over USB. To developers, it means you can connect to any listening localhost
socket on the device. usbmuxd is not used for tethering data transfer, which
uses a dedicated USB interface as a virtual network device.
endef
TARGET_CFLAGS += $(FPIC)
define Package/usbmuxd/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/usbmuxd $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,usbmuxd))

View File

@ -1,32 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,19 +64,12 @@ endif()
add_definitions(-Wall)
-add_subdirectory (libusbmuxd)
if (WITH_USBMUXD)
add_subdirectory (daemon)
if (${CMAKE_SYSTEM_NAME} MATCHES "Linux")
add_subdirectory (udev)
endif()
endif()
-add_subdirectory (tools)
-
-# pkg-config
-configure_file("${CMAKE_CURRENT_SOURCE_DIR}/libusbmuxd.pc.in" "${CMAKE_CURRENT_BINARY_DIR}/libusbmuxd.pc")
-# install pkg-config file
-install(FILES "${CMAKE_CURRENT_BINARY_DIR}/libusbmuxd.pc" DESTINATION lib${LIB_SUFFIX}/pkgconfig/)
# add uninstall target
configure_file("${CMAKE_SOURCE_DIR}/Modules/cmake_uninstall.cmake.in" "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake" IMMEDIATE @ONLY)
--- a/daemon/CMakeLists.txt
+++ b/daemon/CMakeLists.txt
@@ -8,7 +8,6 @@ if(HAVE_PLIST)
endif()
include_directories (${CMAKE_SOURCE_DIR}/common)
include_directories (${CMAKE_SOURCE_DIR}/daemon)
-include_directories (${CMAKE_SOURCE_DIR}/libusbmuxd)
add_definitions(-DUSBMUXD_DAEMON -DUSBMUXD_VERSION="${USBMUXD_VERSION}")
add_executable(usbmuxd main.c usb-linux.c log.c ${CMAKE_SOURCE_DIR}/common/utils.c device.c client.c)