[packages] pptpd: update to v1.3.4 - patch by Edgar Soldin

git-svn-id: svn://svn.openwrt.org/openwrt/packages@19301 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2010-01-23 22:18:19 +00:00
parent 23d77fdd68
commit be11b4eccd
4 changed files with 17 additions and 43 deletions

View File

@ -8,19 +8,19 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=pptpd
PKG_VERSION:=1.3.0
PKG_VERSION:=1.3.4
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/poptop
PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67
#PKG_MD5SUM:=75d494e881f7027f4e60b114163f6b67 #1.3.0
include $(INCLUDE_DIR)/package.mk
define Package/pptpd
SECTION:=net
CATEGORY:=Network
DEPENDS:=+kmod-ppp +kmod-gre
DEPENDS:=+kmod-ppp +kmod-gre +ppp
TITLE:=PopTop pptp server
URL:=http://www.poptop.org/
SUBMENU:=VPN

View File

@ -1,7 +1,6 @@
diff -urN pptpd-1.3.0/pqueue.c.orig pptpd-1.3.0/pqueue.c
--- pptpd-1.3.0/pqueue.c.orig 2006-04-17 20:44:28.000000000 -0400
+++ pptpd-1.3.0/pqueue.c 2006-04-17 20:44:58.000000000 -0400
@@ -6,14 +6,11 @@
--- pptpd-1.3.4.orig/pqueue.c 2005-08-03 10:53:22.000000000 +0200
+++ pptpd-1.3.4/pqueue.c 2009-12-03 17:47:26.976174000 +0100
@@ -7,13 +7,11 @@
#include "pqueue.h"
#ifdef DEBUG_PQUEUE
@ -13,7 +12,6 @@ diff -urN pptpd-1.3.0/pqueue.c.orig pptpd-1.3.0/pqueue.c
#endif
-#define DEBUG_CMD(_a) if (DEBUG_ON) { _a }
-
-
#define MIN_CAPACITY 128 /* min allocated buffer for a packet */

View File

@ -0,0 +1,11 @@
--- pptpd-1.3.4.orig/plugins/Makefile 2006-08-03 04:02:01.000000000 +0200
+++ pptpd-1.3.4/plugins/Makefile 2009-12-03 21:18:09.678467590 +0100
@@ -18,7 +18,7 @@ all: $(PLUGINS)
%.so: %.c
$(CC) -o $@ $(LDFLAGS) $(CFLAGS) $^ $(LDADD)
-LIBDIR ?= $(DESTDIR)$(prefix)/lib/pptpd
+LIBDIR = $(DESTDIR)$(prefix)/lib/pptpd
install: $(PLUGINS)
$(INSTALL) -d $(LIBDIR)

View File

@ -1,35 +0,0 @@
diff -Nur pptpd-1.3.0/pptpgre.c.orig pptpd-1.3.0/pptpgre.c
--- pptpd-1.3.0/pptpgre.c.orig 2006-04-18 02:13:10.000000000 -0400
+++ pptpd-1.3.0/pptpgre.c 2006-04-18 02:14:19.000000000 -0400
@@ -46,6 +46,9 @@
#define PACKET_MAX 8196
+/* Command Line Variable Args */
+extern int pptpctrl_debug;
+
typedef int (*callback_t)(int cl, void *pack, unsigned int len);
/* test for a 32 bit counter overflow */
@@ -319,7 +322,9 @@
stats.rx_lost += head->seq - gre.seq_recv - 1;
syslog(LOG_DEBUG, "GRE: timeout waiting for %d packets", head->seq - gre.seq_recv - 1);
}
- syslog(LOG_DEBUG, "GRE: accepting #%d from queue", head->seq);
+ if (pptpctrl_debug) {
+ syslog(LOG_DEBUG, "GRE: accepting #%d from queue", head->seq);
+ }
gre.seq_recv = head->seq;
status = callback(cl, head->packet, head->packlen);
pqueue_del(head);
@@ -399,7 +404,9 @@
}
/* check for out-of-order sequence number */
if (seq_greater(seq, gre.seq_recv)) {
- syslog(LOG_DEBUG, "GRE: accepting packet #%d", seq);
+ if (pptpctrl_debug) {
+ syslog(LOG_DEBUG, "GRE: accepting packet #%d", seq);
+ }
stats.rx_accepted++;
gre.seq_recv = seq;
return cb(cl, buffer + ip_len + headersize, payload_len);