[packages] kismet: drop old atan patch, add new patch to properly link against libm, get rid of libnotimpl dependency, use a cleaner override for $(LD) (followup to r17109)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@17111 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2009-08-03 21:49:31 +00:00
parent 4617872dcc
commit be87df35a6
3 changed files with 14 additions and 14 deletions

View File

@ -95,12 +95,12 @@ CONFIGURE_VARS += \
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
LDFLAGS="$$$$LDFLAGS" \
LIBS="-nodefaultlibs -luClibc++ -lm -lgcc -lnotimpl" \
CLIENTLIBS="-nodefaultlibs -luClibc++ -lm -lgcc -lnotimpl" \
LIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
CLIENTLIBS="-nodefaultlibs -luClibc++ -lm -lgcc" \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
LD="\$$$$(CC)" \
LD="$(TARGET_CXX)" \
all
endef

View File

@ -1,11 +0,0 @@
--- a/gpsd.cc
+++ b/gpsd.cc
@@ -478,7 +478,7 @@
if (ty == 0) {
dir = 0.0;
} else {
- dir = atan(tx / ty);
+ dir = atan2(tx,ty);
}
if (!finite(dir))

View File

@ -0,0 +1,11 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -23,7 +23,7 @@
CXXLIBS = @CXXLIBS@
KSLIBS = @KSLIBS@
CFLAGS = @CPPFLAGS@
-CLIENTLIBS = @CLIENTCLIBS@
+CLIENTLIBS = @CLIENTCLIBS@ -lm
CAPLIBS = @caplibs@
CLIENTFLAGS = @CLIENTCFLAGS@
CXXFLAGS = -Wall @CXXFLAGS@