[package] update libdvbpsi to 0.1.6, move to libdvbpsi (#5392)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16533 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
aab089612f
commit
bfcbde4257
@ -7,27 +7,27 @@
|
|||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libdvbpsi4
|
PKG_NAME:=libdvbpsi5
|
||||||
PKG_VERSION:=0.1.5
|
PKG_VERSION:=0.1.6
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://download.videolan.org/pub/libdvbpsi/$(PKG_VERSION)/
|
PKG_SOURCE_URL:=http://download.videolan.org/pub/libdvbpsi/$(PKG_VERSION)/
|
||||||
PKG_MD5SUM:=407cd074b7d6eaf31b20b693ed924655
|
PKG_MD5SUM:=bd2d9861be3311e1e03c91cd9345f542
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
PKG_INSTALL=1
|
PKG_INSTALL=1
|
||||||
|
|
||||||
define Package/libdvbpsi4
|
define Package/libdvbpsi
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
TITLE:=MPEG TS and DVB PSI tables decoding and generating
|
TITLE:=MPEG TS and DVB PSI tables decoding and generating
|
||||||
URL:=http://www.videolan.org/developers/libdvbpsi.html
|
URL:=http://www.videolan.org/developers/libdvbpsi.html
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libdvbpsi4/description
|
define Package/libdvbpsi/description
|
||||||
libdvbpsi is a simple library designed for MPEG TS and DVB PSI tables
|
libdvbpsi is a simple library designed for MPEG TS and DVB PSI tables
|
||||||
decoding and generating.
|
decoding and generating.
|
||||||
endef
|
endef
|
||||||
@ -45,11 +45,11 @@ define Build/InstallDev
|
|||||||
$(1)/usr/lib/
|
$(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libdvbpsi4/install
|
define Package/libdvbpsi/install
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/libdvbpsi.so* \
|
$(PKG_INSTALL_DIR)/usr/lib/libdvbpsi.so* \
|
||||||
$(1)/usr/lib/
|
$(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libdvbpsi4))
|
$(eval $(call BuildPackage,libdvbpsi))
|
@ -1,6 +1,5 @@
|
|||||||
diff -urN libdvbpsi4-0.1.5/Makefile.am libdvbpsi4-0.1.5.new/Makefile.am
|
--- a/Makefile.am
|
||||||
--- libdvbpsi4-0.1.5/Makefile.am 2005-03-21 14:24:33.000000000 +0100
|
+++ b/Makefile.am
|
||||||
+++ libdvbpsi4-0.1.5.new/Makefile.am 2008-08-06 12:15:59.000000000 +0200
|
|
||||||
@@ -1,7 +1,7 @@
|
@@ -1,7 +1,7 @@
|
||||||
## Process this file with automake to produce Makefile.in
|
## Process this file with automake to produce Makefile.in
|
||||||
|
|
||||||
@ -11,17 +10,16 @@ diff -urN libdvbpsi4-0.1.5/Makefile.am libdvbpsi4-0.1.5.new/Makefile.am
|
|||||||
|
|
||||||
EXTRA_DIST = libdvbpsi.spec bootstrap
|
EXTRA_DIST = libdvbpsi.spec bootstrap
|
||||||
|
|
||||||
diff -urN libdvbpsi4-0.1.5/Makefile.in libdvbpsi4-0.1.5.new/Makefile.in
|
--- a/Makefile.in
|
||||||
--- libdvbpsi4-0.1.5/Makefile.in 2005-07-06 16:44:57.000000000 +0200
|
+++ b/Makefile.in
|
||||||
+++ libdvbpsi4-0.1.5.new/Makefile.in 2008-08-06 12:15:47.000000000 +0200
|
@@ -179,8 +179,8 @@ target_alias = @target_alias@
|
||||||
@@ -136,8 +136,8 @@
|
target_cpu = @target_cpu@
|
||||||
target_os = @target_os@
|
target_os = @target_os@
|
||||||
target_vendor = @target_vendor@
|
target_vendor = @target_vendor@
|
||||||
|
|
||||||
-SUBDIRS = src examples misc
|
-SUBDIRS = src examples misc
|
||||||
-DIST_SUBDIRS = $(SUBDIRS) doc debian wince
|
-DIST_SUBDIRS = $(SUBDIRS) doc debian wince
|
||||||
+SUBDIRS = src
|
+SUBDIRS = src
|
||||||
+DIST_SUBDIRS = $(SUBDIRS) debian wince
|
+DIST_SUBDIRS = $(SUBDIRS) debian wince
|
||||||
|
|
||||||
EXTRA_DIST = libdvbpsi.spec bootstrap
|
EXTRA_DIST = libdvbpsi.spec bootstrap
|
||||||
|
AUTOMAKE_OPTIONS = foreign dist-bzip2 subdir-objects
|
||||||
|
all: config.h
|
Loading…
x
Reference in New Issue
Block a user