[packages] radvd: reduce log spam introduced by v1.8, it logs every RA it emits as warning. change it to a debug level message
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27712 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
2795020220
commit
c19b4eb1f4
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
|||||||
|
|
||||||
PKG_NAME:=radvd
|
PKG_NAME:=radvd
|
||||||
PKG_VERSION:=1.8
|
PKG_VERSION:=1.8
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=3
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
|
PKG_SOURCE_URL:=http://v6web.litech.org/radvd/dist \
|
||||||
|
17
ipv6/radvd/patches/100-RS-RA-warning-to-debug.patch
Normal file
17
ipv6/radvd/patches/100-RS-RA-warning-to-debug.patch
Normal file
@ -0,0 +1,17 @@
|
|||||||
|
--- a/process.c
|
||||||
|
+++ b/process.c
|
||||||
|
@@ -132,12 +132,12 @@ process(struct Interface *ifacel, unsign
|
||||||
|
|
||||||
|
if (icmph->icmp6_type == ND_ROUTER_SOLICIT)
|
||||||
|
{
|
||||||
|
- flog(LOG_WARNING, "received RS from %s", addr_str);
|
||||||
|
+ dlog(LOG_DEBUG, 2, "received RS from %s", addr_str);
|
||||||
|
process_rs(iface, msg, len, addr);
|
||||||
|
}
|
||||||
|
else if (icmph->icmp6_type == ND_ROUTER_ADVERT)
|
||||||
|
{
|
||||||
|
- flog(LOG_WARNING, "received RA from %s", addr_str);
|
||||||
|
+ dlog(LOG_DEBUG, 2, "received RA from %s", addr_str);
|
||||||
|
process_ra(iface, msg, len, addr);
|
||||||
|
}
|
||||||
|
}
|
Loading…
x
Reference in New Issue
Block a user