removed duplicate freetype
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9148 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
1449c66c4a
commit
c2b2611a5a
@ -21,7 +21,7 @@ define Package/libXfont
|
||||
SECTION:=xorg-libraries
|
||||
CATEGORY:=Xorg
|
||||
SUBMENU:=libraries
|
||||
DEPENDS:=+xorg-headers-native +util-macros +zlib +libfontenc +fontcacheproto +fontsproto +freetype @TARGET_x86
|
||||
DEPENDS:=+xorg-headers-native +util-macros +zlib +libfontenc +fontcacheproto +fontsproto +libfreetype @TARGET_x86
|
||||
TITLE:=libXfont
|
||||
URL:=http://xorg.freedesktop.org/
|
||||
endef
|
||||
|
@ -21,7 +21,7 @@ define Package/libXrender
|
||||
SECTION:=xorg-libraries
|
||||
CATEGORY:=Xorg
|
||||
SUBMENU:=libraries
|
||||
DEPENDS:=+xorg-headers-native +util-macros +freetype +zlib +xproto +libfontenc +xtrans +fontsproto +renderproto @TARGET_x86
|
||||
DEPENDS:=+xorg-headers-native +util-macros +libfreetype +zlib +xproto +libfontenc +xtrans +fontsproto +renderproto @TARGET_x86
|
||||
TITLE:=libXrender
|
||||
URL:=http://xorg.freedesktop.org/
|
||||
endef
|
||||
|
@ -3,8 +3,8 @@ xtrans-X11R7.2-1.0.3|
|
||||
libXdmcp-X11R7.2-1.0.2|+xproto
|
||||
libX11-X11R7.2-1.1.1|+bigreqsproto+xproto+xextproto+libXau+xtrans+xcmiscproto+libXdmcp+xf86bigfontproto+kbproto+inputproto
|
||||
libfontenc-X11R7.2-1.0.4|+xproto+zlib
|
||||
libXfont-X11R7.2-1.2.7|+zlib+libfontenc+fontcacheproto+fontsproto+freetype
|
||||
libXrender-X11R7.2-0.9.2|+freetype+zlib+xproto+libfontenc+xtrans+fontsproto+renderproto
|
||||
libXfont-X11R7.2-1.2.7|+zlib+libfontenc+fontcacheproto+fontsproto+libfreetype
|
||||
libXrender-X11R7.2-0.9.2|+libfreetype+zlib+xproto+libfontenc+xtrans+fontsproto+renderproto
|
||||
libXrandr-X11R7.2-1.1.2|+libXext+libXrender+randrproto+renderproto+xextproto+libX11
|
||||
libXext-X11R7.2-1.0.2|+xproto+xextproto+libXau+libX11
|
||||
libxkbfile-X11R7.2-1.0.4|
|
||||
|
@ -1,57 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# blogic@openwrt.org
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=freetype
|
||||
PKG_VERSION:=2.1.10
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/freetype/
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/freetype
|
||||
SECTION:=xorg-misc
|
||||
CATEGORY:=Xorg
|
||||
SUBMENU:=misc
|
||||
TITLE:=Freetype font rendering library
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR)/builds/unix; \
|
||||
./configure --host=$(GNU_TARGET_NAME) ; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
AC_PROG_LIBTOOL="$(PKG_BUILD_DIR)/builds/unix/libtool"; \
|
||||
aclocal -I . );
|
||||
(cd $(PKG_BUILD_DIR)/; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
./configure --host=$(GNU_TARGET_NAME) --without-zlib);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
install
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(CP) -r $(PKG_BUILD_DIR)/include/* $(STAGING_DIR)/include/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/local/lib/libfreetype.so* $(STAGING_DIR)/usr/lib/
|
||||
$(CP) $(PKG_BUILD_DIR)/builds/unix/freetype2.pc $(STAGING_DIR)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/freetype/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/local/lib/libfreetype.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,freetype))
|
@ -1,47 +0,0 @@
|
||||
|
||||
#
|
||||
# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
|
||||
#
|
||||
|
||||
Index: freetype-2.1.8/builds/unix/configure.ac
|
||||
===================================================================
|
||||
--- freetype-2.1.8.orig/builds/unix/configure.ac 2004-04-14 04:49:11.000000000 -0400
|
||||
+++ freetype-2.1.8/builds/unix/configure.ac 2005-03-12 03:14:23.000000000 -0500
|
||||
@@ -111,8 +111,8 @@
|
||||
# Check for system zlib
|
||||
|
||||
AC_ARG_WITH([zlib],
|
||||
- dnl don't quote AS_HELP_STRING!
|
||||
- AS_HELP_STRING([--without-zlib],
|
||||
+ dnl don't quote AC_HELP_STRING!
|
||||
+ AC_HELP_STRING([--without-zlib],
|
||||
[use internal zlib instead of system-wide]))
|
||||
if test x$with_zlib != xno && test -z "$LIBZ"; then
|
||||
AC_CHECK_LIB([z], [gzsetparams], [AC_CHECK_HEADER([zlib.h], [LIBZ='-lz'])])
|
||||
@@ -127,7 +127,7 @@
|
||||
# Whether to use Mac OS resource-based fonts or not
|
||||
|
||||
AC_ARG_WITH([old-mac-fonts],
|
||||
- dnl don't quote AS_HELP_STRING!
|
||||
- AS_HELP_STRING([--with-old-mac-fonts],
|
||||
+ dnl don't quote AC_HELP_STRING!
|
||||
+ AC_HELP_STRING([--with-old-mac-fonts],
|
||||
[allow Mac resource-based fonts to be used]))
|
||||
if test x$with_old_mac_fonts = xyes; then
|
||||
Index: freetype-2.1.8/builds/unix/unix-cc.in
|
||||
===================================================================
|
||||
--- freetype-2.1.8.orig/builds/unix/unix-cc.in 2003-11-09 03:37:13.000000000 -0500
|
||||
+++ freetype-2.1.8/builds/unix/unix-cc.in 2005-03-12 18:37:24.613693760 -0500
|
||||
@@ -14,9 +14,11 @@
|
||||
|
||||
CC := @CC@
|
||||
COMPILER_SEP := $(SEP)
|
||||
+SHELL := @SHELL@
|
||||
+top_builddir := $(BUILD_DIR)
|
||||
|
||||
ifndef LIBTOOL
|
||||
- LIBTOOL := $(BUILD_DIR)/libtool
|
||||
+ LIBTOOL := @LIBTOOL@
|
||||
endif
|
||||
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- freetype-2.1.10/builds/unix/freetype-config.in.old 2006-05-01 12:39:20.000000000 +0100
|
||||
+++ freetype-2.1.10/builds/unix/freetype-config.in 2006-05-01 12:39:34.000000000 +0100
|
||||
@@ -16,7 +16,7 @@
|
||||
libdir=@libdir@
|
||||
enable_shared=@enable_shared@
|
||||
wl=@wl@
|
||||
-hardcode_libdir_flag_spec='@hardcode_libdir_flag_spec@'
|
||||
+hardcode_libdir_flag_spec=''
|
||||
|
||||
usage()
|
||||
{
|
Loading…
x
Reference in New Issue
Block a user