[package] fix zaptel compilation on non-64bits platforms, should not break x86_64

git-svn-id: svn://svn.openwrt.org/openwrt/packages@14388 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-02-03 14:11:33 +00:00
parent 0022774d5b
commit c3b2a51955

View File

@ -0,0 +1,13 @@
diff -urN zaptel-1.4.9.2/Makefile zaptel-1.4.9.2.new/Makefile
--- zaptel-1.4.9.2/Makefile 2008-02-22 01:31:47.000000000 +0100
+++ zaptel-1.4.9.2.new/Makefile 2009-02-03 14:24:25.000000000 +0100
@@ -135,9 +135,6 @@
ifneq (,$(findstring ppc,$(UNAME_M)))
CFLAGS_PPC:=-fsigned-char
endif
-ifneq (,$(findstring x86_64,$(UNAME_M)))
-CFLAGS_x86_64:=-m64
-endif
CFLAGS+=$(CFLAGS_PPC) $(CFLAGS_x86_64)
KFLAGS=-I$(KINCLUDES) -O6
KFLAGS+=-DMODULE -D__KERNEL__ -DEXPORT_SYMTAB -I$(KSRC)/drivers/net \