ulogd: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@42268 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
72c9b07a79
commit
c5118f2200
@ -1,146 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2011 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=ulogd
|
|
||||||
PKG_VERSION:=1.24
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
||||||
PKG_SOURCE_URL:=ftp://ftp.netfilter.org/pub/ulogd/ \
|
|
||||||
ftp://ftp.be.netfilter.org/pub/netfilter/ulogd/ \
|
|
||||||
ftp://ftp.de.netfilter.org/pub/netfilter/ulogd/ \
|
|
||||||
ftp://ftp.no.netfilter.org/pub/netfilter/ulogd/
|
|
||||||
PKG_MD5SUM:=05b4ed2926b9a22aaeaf642917bbf8ff
|
|
||||||
|
|
||||||
define Package/ulogd/Default
|
|
||||||
SECTION:=net
|
|
||||||
CATEGORY:=Network
|
|
||||||
URL:=http://www.netfilter.org/projects/ulogd/index.html
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ulogd
|
|
||||||
$(call Package/ulogd/Default)
|
|
||||||
DEPENDS:=+iptables-mod-ulog
|
|
||||||
TITLE:=Netfilter userspace logging daemon
|
|
||||||
MENU:=1
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ulogd/conffiles
|
|
||||||
/etc/default/ulogd
|
|
||||||
/etc/ulogd.conf
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ulogd-mod-mysql
|
|
||||||
$(call Package/ulogd/Default)
|
|
||||||
DEPENDS:=ulogd +libmysqlclient
|
|
||||||
TITLE:=Output plugin for logging to a MySQL database
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ulogd-mod-pcap
|
|
||||||
$(call Package/ulogd/Default)
|
|
||||||
DEPENDS:=ulogd +libpcap
|
|
||||||
TITLE:=Output plugin for logging in pcap format
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ulogd-mod-pgsql
|
|
||||||
$(call Package/ulogd/Default)
|
|
||||||
DEPENDS:=ulogd +libpq
|
|
||||||
TITLE:=Output plugin for logging to a PostgreSQL database
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ulogd-mod-sqlite
|
|
||||||
$(call Package/ulogd/Default)
|
|
||||||
DEPENDS:=ulogd +libsqlite3
|
|
||||||
TITLE:=Output plugin for logging to an SQLite database
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ulogd-mod-extra
|
|
||||||
$(call Package/ulogd/Default)
|
|
||||||
DEPENDS:=ulogd
|
|
||||||
TITLE:=Extra plugins
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ulogd-mod-extra/description
|
|
||||||
This package contains the LOCAL, LOGEMU, OPRINT, PWSNIFF and SYSLOG plugins.
|
|
||||||
endef
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
ifneq ($(Package/ulogd-mod-mysql),)
|
|
||||||
ULOGD_MYSQL_OPTION:= --with-mysql="$(STAGING_DIR)/usr"
|
|
||||||
endif
|
|
||||||
|
|
||||||
ifneq ($(Package/ulogd-mod-pcap),)
|
|
||||||
ULOGD_PCAP_HEADER:=yes
|
|
||||||
else
|
|
||||||
ULOGD_PCAP_HEADER:=no
|
|
||||||
endif
|
|
||||||
|
|
||||||
ifneq ($(Package/ulogd-mod-pgsql),)
|
|
||||||
ULOGD_PGSQL_OPTION:= --with-pgsql="$(STAGING_DIR)/usr"
|
|
||||||
endif
|
|
||||||
|
|
||||||
ifneq ($(Package/ulogd-mod-sqlite),)
|
|
||||||
ULOGD_SQLITE_OPTION:= --with-sqlite3="$(STAGING_DIR)/usr"
|
|
||||||
endif
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
$(call Build/Configure/Default, \
|
|
||||||
$(ULOGD_MYSQL_OPTION) \
|
|
||||||
$(ULOGD_PGSQL_OPTION) \
|
|
||||||
$(ULOGD_SQLITE_OPTION) \
|
|
||||||
, \
|
|
||||||
ac_cv_header_pcap_h=$(ULOGD_PCAP_HEADER) \
|
|
||||||
)
|
|
||||||
$(SED) 's/-lgcc_s//g' $(PKG_BUILD_DIR)/Rules.make
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
CFLAGS="$(TARGET_CFLAGS) \
|
|
||||||
-Iinclude \
|
|
||||||
-I$(PKG_BUILD_DIR)/include/ulogd \
|
|
||||||
-I$(PKG_BUILD_DIR)/include \
|
|
||||||
-I$(PKG_BUILD_DIR)/libipulog/include \
|
|
||||||
-Wl,--export-dynamic \
|
|
||||||
$(TARGET_CPPFLAGS)" \
|
|
||||||
all install
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ulogd/install
|
|
||||||
$(INSTALL_DIR) $(1)/etc
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/etc/ulogd.conf $(1)/etc/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/ulogd $(1)/usr/sbin/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/ulogd
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ulogd/ulogd_BASE.so $(1)/usr/lib/ulogd/
|
|
||||||
$(INSTALL_DIR) $(1)/etc/default
|
|
||||||
$(INSTALL_DATA) ./files/ulogd.default $(1)/etc/default/ulogd
|
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
|
||||||
$(INSTALL_BIN) ./files/ulogd.init $(1)/etc/init.d/ulogd
|
|
||||||
endef
|
|
||||||
|
|
||||||
define BuildPlugin
|
|
||||||
define Package/$(1)/install
|
|
||||||
$(INSTALL_DIR) $$(1)/usr/lib/ulogd
|
|
||||||
for m in $(2); do \
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/ulogd/ulogd_$$$$$$$${m}.so $$(1)/usr/lib/ulogd/ ; \
|
|
||||||
done
|
|
||||||
endef
|
|
||||||
|
|
||||||
$$(eval $$(call BuildPackage,$(1)))
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,ulogd))
|
|
||||||
$(eval $(call BuildPlugin,ulogd-mod-mysql,MYSQL))
|
|
||||||
$(eval $(call BuildPlugin,ulogd-mod-pcap,PCAP))
|
|
||||||
$(eval $(call BuildPlugin,ulogd-mod-pgsql,PGSQL))
|
|
||||||
$(eval $(call BuildPlugin,ulogd-mod-sqlite,SQLITE3))
|
|
||||||
$(eval $(call BuildPlugin,ulogd-mod-extra,LOCAL LOGEMU OPRINT PWSNIFF SYSLOG))
|
|
@ -1 +0,0 @@
|
|||||||
OPTIONS="-d"
|
|
@ -1,17 +0,0 @@
|
|||||||
#!/bin/sh /etc/rc.common
|
|
||||||
# Copyright (C) 2006-2011 OpenWrt.org
|
|
||||||
|
|
||||||
START=50
|
|
||||||
|
|
||||||
PROG="ulogd"
|
|
||||||
COMMAND="/usr/sbin/$PROG"
|
|
||||||
DEFAULT="/etc/default/$PROG"
|
|
||||||
|
|
||||||
start() {
|
|
||||||
[ -f $DEFAULT ] && . $DEFAULT
|
|
||||||
service_start $COMMAND $OPTIONS
|
|
||||||
}
|
|
||||||
|
|
||||||
stop() {
|
|
||||||
service_stop $COMMAND
|
|
||||||
}
|
|
@ -1,12 +0,0 @@
|
|||||||
diff -urN ulogd-1.23/pcap/Makefile.in ulogd-1.23.new/pcap/Makefile.in
|
|
||||||
--- ulogd-1.23/pcap/Makefile.in 2004-03-23 23:36:04.000000000 +0100
|
|
||||||
+++ ulogd-1.23.new/pcap/Makefile.in 2006-04-19 11:30:45.000000000 +0200
|
|
||||||
@@ -14,7 +14,7 @@
|
|
||||||
distrib:
|
|
||||||
|
|
||||||
$(SHARED_LIBS): %.so: %_sh.o
|
|
||||||
- $(LD) -shared -o $@ $< -lc -lpcap
|
|
||||||
+ $(LD) -shared -o $@ $< @LDFLAGS@ -lc -lpcap
|
|
||||||
|
|
||||||
%_sh.o: %.c
|
|
||||||
$(CC) $(SH_CFLAGS) -o $@ -c $<
|
|
@ -1,24 +0,0 @@
|
|||||||
diff -ruN ulogd-1.23-old/Rules.make.in ulogd-1.23-new/Rules.make.in
|
|
||||||
--- ulogd-1.23-old/Rules.make.in 2005-02-19 22:32:40.000000000 +0100
|
|
||||||
+++ ulogd-1.23-new/Rules.make.in 2005-05-27 07:45:18.000000000 +0200
|
|
||||||
@@ -22,7 +22,7 @@
|
|
||||||
CFLAGS+=-DULOGD_CONFIGFILE=\"$(ULOGD_CONFIGFILE)\"
|
|
||||||
# doesn't work for subdirs
|
|
||||||
#CFLAGS+=$(INCIPULOG) $(INCCONFFILE)
|
|
||||||
-CFLAGS+=-I/lib/modules/`uname -r`/build/include
|
|
||||||
+#CFLAGS+=-I/lib/modules/`uname -r`/build/include
|
|
||||||
#CFLAGS+=@DEFS@
|
|
||||||
#CFLAGS+=-g -DDEBUG -DDEBUG_MYSQL -DDEBUG_PGSQL
|
|
||||||
|
|
||||||
diff -ruN ulogd-1.23-old/libipulog/Makefile.in ulogd-1.23-new/libipulog/Makefile.in
|
|
||||||
--- ulogd-1.23-old/libipulog/Makefile.in 2004-03-23 23:36:06.000000000 +0100
|
|
||||||
+++ ulogd-1.23-new/libipulog/Makefile.in 2005-05-27 07:44:21.000000000 +0200
|
|
||||||
@@ -1,7 +1,7 @@
|
|
||||||
#
|
|
||||||
|
|
||||||
include @top_srcdir@/Rules.make
|
|
||||||
-CFLAGS+=-Iinclude -I/usr/src/linux/include
|
|
||||||
+CFLAGS+=-Iinclude
|
|
||||||
|
|
||||||
libipulog.a: libipulog.o
|
|
||||||
$(LD) -i $< -o $@
|
|
@ -1,33 +0,0 @@
|
|||||||
--- a/configure
|
|
||||||
+++ b/configure
|
|
||||||
@@ -1728,7 +1728,7 @@ else
|
|
||||||
EOF
|
|
||||||
|
|
||||||
MYSQLINCLUDES=`$d/mysql_config --include`
|
|
||||||
- MYSQLLIBS=`$d/mysql_config --libs`
|
|
||||||
+ MYSQLLIBS=`$d/mysql_config --libs | sed 's/-rdynamic//'`
|
|
||||||
|
|
||||||
DATABASE_DIR="${DATABASE_DIR} mysql"
|
|
||||||
|
|
||||||
--- a/configure.in
|
|
||||||
+++ b/configure.in
|
|
||||||
@@ -60,7 +60,7 @@ then
|
|
||||||
else
|
|
||||||
AC_DEFINE(HAVE_MYSQL)
|
|
||||||
MYSQLINCLUDES=`$d/mysql_config --include`
|
|
||||||
- MYSQLLIBS=`$d/mysql_config --libs`
|
|
||||||
+ MYSQLLIBS=`$d/mysql_config --libs | $(SED) 's/-rdynamic//'`
|
|
||||||
|
|
||||||
DATABASE_DIR="${DATABASE_DIR} mysql"
|
|
||||||
|
|
||||||
--- a/Makefile.in
|
|
||||||
+++ b/Makefile.in
|
|
||||||
@@ -63,7 +63,7 @@ recurse:
|
|
||||||
@for d in $(SUBDIRS); do if ! make -C $$d; then exit 1; fi; done
|
|
||||||
|
|
||||||
ulogd: ulogd.c $(LIBIPULOG) include/ulogd/ulogd.h conffile/conffile.o $(LIBIPULOG)/libipulog.a ulogd.conf
|
|
||||||
- $(CC) $(CFLAGS) -rdynamic $< conffile/conffile.o $(LIBIPULOG)/libipulog.a -o $@ $(LIBS)
|
|
||||||
+ $(CC) $(CFLAGS) $< conffile/conffile.o $(LIBIPULOG)/libipulog.a -o $@ $(LIBS)
|
|
||||||
|
|
||||||
edit = sed -e 's,@libdir\@,$(ULOGD_LIB_PATH),g'
|
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user