Update zabbix to 2.2.2

refresh patch (patch configure.ac instead of .in)
zabbix-agentd tested on wr1043nd
zabbix-* compile tested

zabbix-extra-wifi discovery still not working
(need an suid helper to make ubus calls)

Signed-off-by: Etienne CHAMPETIER <etienne.champetier@free.fr>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@40639 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2014-05-01 18:32:49 +00:00
parent db78659473
commit c599f49346
4 changed files with 17 additions and 17 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=zabbix
PKG_VERSION:=2.2.1
PKG_RELEASE:=2
PKG_VERSION:=2.2.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/zabbix
PKG_MD5SUM:=558497839b13a548f533eb2fc951a4e3
PKG_MD5SUM:=7f680ad3ef7145840e3de5c7a0f19b7c
PKG_INSTALL:=1

View File

@ -1,6 +1,6 @@
--- a/configure.in
+++ b/configure.in
@@ -804,25 +804,8 @@ dnl ************************************
--- a/configure.ac
+++ b/configure.ac
@@ -805,25 +805,8 @@ dnl ************************************
dnl Check for %qu format (FreeBSD 4.x)
dnl FreeBSD 4.x does not support %llu

View File

@ -1,6 +1,6 @@
--- a/configure.in
+++ b/configure.in
@@ -151,6 +151,10 @@ if test "x$found_resolv" != "xyes"; then
--- a/configure.ac
+++ b/configure.ac
@@ -152,6 +152,10 @@ if test "x$found_resolv" != "xyes"; then
AC_MSG_ERROR([Unable to do DNS lookups (libresolv check failed)])
fi
LIBS="${LIBS} ${RESOLV_LIBS}"
@ -13,15 +13,15 @@
dnl * *
--- a/src/libs/zbxsysinfo/common/net.c
+++ b/src/libs/zbxsysinfo/common/net.c
@@ -421,6 +421,7 @@ static int dns_query(AGENT_REQUEST *requ
#else /* not _WINDOWS */
res_init(); /* initialize always, settings might have changed */
@@ -424,6 +424,7 @@ static int dns_query(AGENT_REQUEST *requ
if (-1 == res_init()) /* initialize always, settings might have changed */
return SYSINFO_RET_FAIL;
+#if defined(HAVE_RES_MKQUERY) && defined(HAVE_RES_SEND)
if (-1 == (res = res_mkquery(QUERY, zone, C_IN, type, NULL, 0, NULL, buf, sizeof(buf))))
return SYSINFO_RET_FAIL;
@@ -439,6 +440,11 @@ static int dns_query(AGENT_REQUEST *requ
@@ -448,6 +449,11 @@ static int dns_query(AGENT_REQUEST *requ
_res.retry = retry;
res = res_send(buf, res, answer.buffer, sizeof(answer.buffer));
@ -31,5 +31,5 @@
+ return SYSINFO_RET_FAIL;
+#endif
hp = (HEADER *)answer.buffer;
_res.retrans = saved_retrans;
_res.retry = saved_retry;

View File

@ -48,8 +48,8 @@
-Hostname=Zabbix server
-
### Option: HostnameItem
# Item used for generating Hostname if it is undefined.
# Ignored if Hostname is defined.
# Item used for generating Hostname if it is undefined. Ignored if Hostname is defined.
# Does not support UserParameters or aliases.
@@ -240,7 +231,7 @@ Hostname=Zabbix server
# Include=