[package] update wput to 0.6.2 (#6410)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18964 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a82e9b83ad
commit
c6a38c1ef6
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=wput
|
PKG_NAME:=wput
|
||||||
PKG_VERSION:=0.6.1
|
PKG_VERSION:=0.6.2
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
|
||||||
PKG_SOURCE_URL:=@SF/wput
|
PKG_SOURCE_URL:=@SF/wput
|
||||||
PKG_MD5SUM:=92b41efed4db8eb4f3443c23bf7ceecf
|
PKG_MD5SUM:=a14c4c13d91d04d6119bdc977e8a8bdf
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/src/socketlib.c
|
--- a/src/socketlib.c
|
||||||
+++ b/src/socketlib.c
|
+++ b/src/socketlib.c
|
||||||
@@ -390,15 +390,13 @@ int socket_is_data_readable(int s, int t
|
@@ -392,17 +392,15 @@ int socket_is_data_readable(int s, int t
|
||||||
wput_socket * socket_timeout_connect(wput_socket * sock, struct sockaddr *remote_addr, size_t size, int timeout) {
|
wput_socket * socket_timeout_connect(wput_socket * sock, struct sockaddr *remote_addr, size_t size, int timeout) {
|
||||||
int c = 0;
|
int c = 0;
|
||||||
printout(vDEBUG, "initiating timeout connect (%d)\n", timeout);
|
printout(vDEBUG, "initiating timeout connect (%d)\n", timeout);
|
||||||
@ -12,7 +12,9 @@
|
|||||||
- socket_set_blocking(sock->fd, 0);
|
- socket_set_blocking(sock->fd, 0);
|
||||||
+ socket_set_blocking(sock->fd, 1);
|
+ socket_set_blocking(sock->fd, 1);
|
||||||
c = connect(sock->fd,remote_addr,size);
|
c = connect(sock->fd,remote_addr,size);
|
||||||
if(errno > 0 && errno != 115 && errno != 36) {
|
/* here was a check also for errno != 36 (FILENAMETOOLONG)
|
||||||
|
* maybe this was EINPROGRESS on another system? */
|
||||||
|
if(errno > 0 && errno != EINPROGRESS) {
|
||||||
- printout(vMORE, "[%s]", strerror(errno));
|
- printout(vMORE, "[%s]", strerror(errno));
|
||||||
+ printout(vMORE, "[%d:%s] ", errno, strerror(errno));
|
+ printout(vMORE, "[%d:%s] ", errno, strerror(errno));
|
||||||
return NULL;
|
return NULL;
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/src/wput.c
|
--- a/src/wput.c
|
||||||
+++ b/src/wput.c
|
+++ b/src/wput.c
|
||||||
@@ -582,8 +582,8 @@ void commandlineoptions(int argc, char *
|
@@ -621,8 +621,8 @@ void commandlineoptions(int argc, char *
|
||||||
{"output-file", 1, 0, 'o'},
|
{"output-file", 1, 0, 'o'},
|
||||||
{"port-mode", 0, 0, 'p'},
|
{"port-mode", 0, 0, 'p'},
|
||||||
{"proxy", 1, 0, 'Y'},
|
{"proxy", 1, 0, 'Y'},
|
||||||
@ -11,29 +11,29 @@
|
|||||||
{"quiet", 0, 0, 'q'},
|
{"quiet", 0, 0, 'q'},
|
||||||
{"random-wait", 0, 0, 0},
|
{"random-wait", 0, 0, 0},
|
||||||
{"remove-source-files", 0, 0, 'R'},
|
{"remove-source-files", 0, 0, 'R'},
|
||||||
@@ -601,7 +601,9 @@ void commandlineoptions(int argc, char *
|
@@ -642,7 +642,9 @@ void commandlineoptions(int argc, char *
|
||||||
{"version", 0, 0, 'V'}, //35
|
|
||||||
{"wait", 1, 0, 'w'},
|
|
||||||
{"waitretry", 1, 0, 0},
|
{"waitretry", 1, 0, 0},
|
||||||
- {0, 0, 0, 0}
|
{"chmod", 1, 0, 'm'},
|
||||||
+ {"proxy_host", 1, 0, 0},
|
{"disable-tls", 0, 0, 0},
|
||||||
|
- {0, 0, 0, 0} //40
|
||||||
|
+ {"proxy_host", 1, 0, 0}, //40
|
||||||
+ {"proxy_port", 1, 0, 0},
|
+ {"proxy_port", 1, 0, 0},
|
||||||
+ {0, 0, 0, 0}
|
+ {0, 0, 0, 0}
|
||||||
};
|
};
|
||||||
while (1)
|
while (1)
|
||||||
{
|
{
|
||||||
@@ -656,6 +658,10 @@ void commandlineoptions(int argc, char *
|
@@ -699,6 +701,10 @@ void commandlineoptions(int argc, char *
|
||||||
opt.basename = optarg; break;
|
|
||||||
case 37: //waitretry
|
|
||||||
opt.retry_interval = atoi(optarg); break;
|
opt.retry_interval = atoi(optarg); break;
|
||||||
+ case 38: //proxy_host
|
case 39: //disable-tls
|
||||||
|
opt.tls = 2; break;
|
||||||
|
+ case 40: //proxy_host
|
||||||
+ set_option("proxy_host", optarg); break;
|
+ set_option("proxy_host", optarg); break;
|
||||||
+ case 39: //proxy_port
|
+ case 41: //proxy_port
|
||||||
+ set_option("proxy_port", optarg); break;
|
+ set_option("proxy_port", optarg); break;
|
||||||
default:
|
default:
|
||||||
fprintf(stderr, _("Option %s should not appear here :|\n"), long_options[option_index].name);
|
fprintf(stderr, _("Option %s should not appear here :|\n"), long_options[option_index].name);
|
||||||
}
|
}
|
||||||
@@ -762,8 +768,11 @@ void commandlineoptions(int argc, char *
|
@@ -806,8 +812,10 @@ void commandlineoptions(int argc, char *
|
||||||
" -l, --limit-rate=RATE limit upload rate to RATE\n"
|
" -l, --limit-rate=RATE limit upload rate to RATE\n"
|
||||||
" -nd, --no-directories do not create any directories\n"
|
" -nd, --no-directories do not create any directories\n"
|
||||||
" -Y, --proxy=http/socks/off set proxy type or turn off\n"
|
" -Y, --proxy=http/socks/off set proxy type or turn off\n"
|
||||||
@ -43,7 +43,6 @@
|
|||||||
+" --proxy_pass=PASS set the proxy-password to PASS\n"
|
+" --proxy_pass=PASS set the proxy-password to PASS\n"
|
||||||
+" --proxy_port=PORT set the proxy port to PORT\n"
|
+" --proxy_port=PORT set the proxy port to PORT\n"
|
||||||
+" --proxy_host=HOST set the proxy host to HOST\n"
|
+" --proxy_host=HOST set the proxy host to HOST\n"
|
||||||
+
|
|
||||||
"\n"));
|
"\n"));
|
||||||
fprintf(stderr, _(
|
fprintf(stderr, _(
|
||||||
"FTP-Options:\n"
|
"FTP-Options:\n"
|
||||||
|
Loading…
x
Reference in New Issue
Block a user