confuse: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@42713 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
be8cbfacdd
commit
c70b4eeef9
@ -1,77 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2010 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=confuse
|
|
||||||
PKG_VERSION:=2.6
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=http://bzero.se/confuse
|
|
||||||
PKG_MD5SUM:=0e883d66f0f58fc33585b430c652aa30
|
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/confuse
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
TITLE:=libConfuse is a configuration file parser library
|
|
||||||
URL:=http://www.nongnu.org/confuse/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/confuse/description
|
|
||||||
libConfuse is a configuration file parser library, licensed under the
|
|
||||||
terms of the ISC license, and written in C. It supports sections and
|
|
||||||
(lists of) values (strings, integers, floats, booleans or other
|
|
||||||
sections), as well as some other features (such as single/double-quoted
|
|
||||||
strings, environment variable expansion, functions and nested include
|
|
||||||
statements). It makes it very easy to add configuration file capability
|
|
||||||
to a program using a simple API.
|
|
||||||
|
|
||||||
The goal of libConfuse is not to be the configuration file parser
|
|
||||||
library with a gazillion of features. Instead, it aims to be easy to use
|
|
||||||
and quick to integrate with your code. libConfuse was called libcfg
|
|
||||||
before, but was changed to not confuse with other similar libraries.
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--disable-rpath \
|
|
||||||
--without-libiconv-prefix \
|
|
||||||
--without-libintl-prefix \
|
|
||||||
|
|
||||||
MAKE_FLAGS += \
|
|
||||||
-C $(PKG_BUILD_DIR)/src \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
|
||||||
all install \
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/confuse.h $(1)/usr/include/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfuse.{a,so*} $(1)/usr/lib/
|
|
||||||
$(CP) $(PKG_BUILD_DIR)/*.pc $(1)/usr/lib/pkgconfig/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/UninstallDev
|
|
||||||
rm -rf \
|
|
||||||
$(STAGING_DIR)/usr/include/confuse.h \
|
|
||||||
$(STAGING_DIR)/usr/lib/libconfuse.{a,so*}
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/confuse/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libconfuse.so.* $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,confuse))
|
|
@ -1,24 +0,0 @@
|
|||||||
diff -urN confuse-2.6/src/Makefile.am confuse-2.6.new/src/Makefile.am
|
|
||||||
--- confuse-2.6/src/Makefile.am 2007-10-13 13:18:28.000000000 +0200
|
|
||||||
+++ confuse-2.6.new/src/Makefile.am 2009-06-18 18:00:02.000000000 +0200
|
|
||||||
@@ -10,7 +10,7 @@
|
|
||||||
DEFS = -DLOCALEDIR=\"$(localedir)\" @DEFS@
|
|
||||||
|
|
||||||
if cc_is_gcc
|
|
||||||
-AM_CFLAGS=-Wall -Werror
|
|
||||||
+AM_CFLAGS=-Wall
|
|
||||||
endif
|
|
||||||
|
|
||||||
LIBS = @LIBS@
|
|
||||||
diff -urN confuse-2.6/src/Makefile.in confuse-2.6.new/src/Makefile.in
|
|
||||||
--- confuse-2.6/src/Makefile.in 2007-12-29 11:56:12.000000000 +0100
|
|
||||||
+++ confuse-2.6.new/src/Makefile.in 2009-06-18 17:59:55.000000000 +0200
|
|
||||||
@@ -196,7 +196,7 @@
|
|
||||||
libconfuse_la_SOURCES = confuse.c lexer.l
|
|
||||||
libconfuse_la_LIBADD = $(LTLIBINTL)
|
|
||||||
include_HEADERS = confuse.h
|
|
||||||
-@cc_is_gcc_TRUE@AM_CFLAGS = -Wall -Werror
|
|
||||||
+@cc_is_gcc_TRUE@AM_CFLAGS = -Wall
|
|
||||||
CLEANFILES = *~ \#*\#
|
|
||||||
AM_LFLAGS = -Pcfg_yy -olex.yy.c
|
|
||||||
all: all-am
|
|
Loading…
x
Reference in New Issue
Block a user