[packages/openssh] update openssh to 6.0p1
git-svn-id: svn://svn.openwrt.org/openwrt/packages@31482 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fc2ad79ba4
commit
c789089d48
@ -8,15 +8,15 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=openssh
|
PKG_NAME:=openssh
|
||||||
PKG_VERSION:=5.9p1
|
PKG_VERSION:=6.0p1
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
|
PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
|
||||||
ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
|
ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
|
||||||
ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
|
ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
|
||||||
ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
|
ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
|
||||||
PKG_MD5SUM:=afe17eee7e98d3b8550cc349834a85d0
|
PKG_MD5SUM:=3c9347aa67862881c5da3f3b1c08da7b
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=libopenssl
|
PKG_BUILD_DEPENDS:=libopenssl
|
||||||
|
|
||||||
|
@ -1,7 +1,7 @@
|
|||||||
--- a/mac.c
|
--- a/mac.c
|
||||||
+++ b/mac.c
|
+++ b/mac.c
|
||||||
@@ -59,8 +59,10 @@ struct {
|
@@ -67,8 +67,10 @@ struct {
|
||||||
{ "hmac-sha1-96", SSH_EVP, EVP_sha1, 96, -1, -1 },
|
#endif
|
||||||
{ "hmac-md5", SSH_EVP, EVP_md5, 0, -1, -1 },
|
{ "hmac-md5", SSH_EVP, EVP_md5, 0, -1, -1 },
|
||||||
{ "hmac-md5-96", SSH_EVP, EVP_md5, 96, -1, -1 },
|
{ "hmac-md5-96", SSH_EVP, EVP_md5, 96, -1, -1 },
|
||||||
+#ifndef OPENSSL_NO_RIPEMD
|
+#ifndef OPENSSL_NO_RIPEMD
|
||||||
|
@ -1,26 +1,21 @@
|
|||||||
Index: packages/net/openssh/patches/200-enable_dscp_qos.patch
|
--- a/ssh_config 2010-01-12 01:40:27.000000000 -0700
|
||||||
===================================================================
|
+++ b/ssh_config 2011-02-09 14:35:30.000000000 -0700
|
||||||
--- packages/net/openssh/patches/200-enable_dscp_qos.patch (revision 0)
|
@@ -45,3 +45,6 @@
|
||||||
+++ packages/net/openssh/patches/200-enable_dscp_qos.patch (revision 0)
|
# PermitLocalCommand no
|
||||||
@@ -0,0 +1,21 @@
|
# VisualHostKey no
|
||||||
+--- a/ssh_config 2010-01-12 01:40:27.000000000 -0700
|
# ProxyCommand ssh -q -W %h:%p gateway.example.com
|
||||||
++++ b/ssh_config 2011-02-09 14:35:30.000000000 -0700
|
|
||||||
+@@ -45,3 +45,6 @@
|
|
||||||
+ # PermitLocalCommand no
|
|
||||||
+ # VisualHostKey no
|
|
||||||
+ # ProxyCommand ssh -q -W %h:%p gateway.example.com
|
|
||||||
++
|
|
||||||
++# enable DSCP QoS values (per RFC-4594)
|
|
||||||
++#IPQoS AF21 AF11
|
|
||||||
+--- a/sshd_config 2010-09-09 19:20:12.000000000 -0600
|
|
||||||
++++ b/sshd_config 2011-02-09 14:32:25.000000000 -0700
|
|
||||||
+@@ -108,6 +108,9 @@
|
|
||||||
+ # no default banner path
|
|
||||||
+ #Banner none
|
|
||||||
+
|
+
|
||||||
++# enable DSCP QoS values (per RFC-4594)
|
+# enable DSCP QoS values (per RFC-4594)
|
||||||
++#IPQoS AF21 AF11
|
+#IPQoS AF21 AF11
|
||||||
++
|
--- a/sshd_config 2010-09-09 19:20:12.000000000 -0600
|
||||||
+ # override default of no subsystems
|
+++ b/sshd_config 2011-02-09 14:32:25.000000000 -0700
|
||||||
+ Subsystem sftp /usr/libexec/sftp-server
|
@@ -108,6 +108,9 @@
|
||||||
|
# no default banner path
|
||||||
|
#Banner none
|
||||||
|
|
||||||
|
+# enable DSCP QoS values (per RFC-4594)
|
||||||
|
+#IPQoS AF21 AF11
|
||||||
+
|
+
|
||||||
|
# override default of no subsystems
|
||||||
|
Subsystem sftp /usr/libexec/sftp-server
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user