add mutella (thanks to olli)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8954 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2007-09-22 18:21:30 +00:00
parent 995e26c701
commit c7aa42313b
3 changed files with 96 additions and 0 deletions

69
net/mutella/Makefile Normal file
View File

@ -0,0 +1,69 @@
#
# Copyright (C) 2007 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=mutella
PKG_VERSION:=0.4.5
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
PKG_MD5SUM:=1a676eacf562e3b8de90493f99fe059c
include $(INCLUDE_DIR)/package.mk
define Package/mutella
SECTION:=net
CATEGORY:=Network
TITLE:=Gnutella client with command line and http interface
URL:=http://mutella.sourceforge.net/
DEPENDS:=+libncurses +libreadline +libpthread +uclibcxx +zlib
endef
define Package/mutella/description
Mutella supports all the functionality required to participate as
a full-featured node in the Gnutella network. "Full-featured" implies
support for file search, download and sharing. It is optimized for a
high-bandwidth connection, where it sets standards for server
performance and stability, but can also run on a modest-speed line.
.
Mutella can either be controlled via a colourful text mode interface
or via a web browser using a built in http interface.
endef
CONFIGURE_VARS += \
CXX="g++-uc+std" \
CXXFLAGS="$$$$CXXFLAGS -fno-rtti" \
define Build/Prepare
$(call Build/Prepare/Default)
$(SED) 's,-I$$$$(includedir),,g' $(PKG_BUILD_DIR)/{mutella,util}/Makefile.in
$(SED) 's,-L$$$$(libdir),,g' $(PKG_BUILD_DIR)/{mutella,util}/Makefile.in
endef
define Build/Configure
$(call Build/Configure/Default)
$(call libtool_disable_rpath)
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) all
$(call libtool_fixup_libdir,$(PKG_INSTALL_DIR))
$(MAKE) -C $(PKG_BUILD_DIR) DESTDIR="$(PKG_INSTALL_DIR)" install
endef
define Package/mutella/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/mutella{,_sio} $(1)/usr/bin/
$(INSTALL_DIR) $(1)/usr/share
$(CP) $(PKG_INSTALL_DIR)/usr/share/mutella $(1)/usr/share/
endef
$(eval $(call BuildPackage,mutella))

View File

@ -0,0 +1,15 @@
Index: mutella-0.4.5/mutella/main.cpp
===================================================================
--- mutella-0.4.5.orig/mutella/main.cpp 2007-09-22 05:48:22.000000000 +0200
+++ mutella-0.4.5/mutella/main.cpp 2007-09-22 05:48:22.000000000 +0200
@@ -45,6 +45,10 @@
#define HAVE_BACKTRACE
#endif
+#ifdef __UCLIBC__
+#undef HAVE_BACKTRACE
+#endif
+
#ifdef HAVE_BACKTRACE
#include <execinfo.h>
#endif

View File

@ -0,0 +1,12 @@
Index: mutella-0.4.5/mutella/gnushare.h
===================================================================
--- mutella-0.4.5.orig/mutella/gnushare.h 2007-09-22 05:48:21.000000000 +0200
+++ mutella-0.4.5/mutella/gnushare.h 2007-09-22 05:48:27.000000000 +0200
@@ -26,6 +26,7 @@
#include "mthread.h"
class MGnuDirector;
+class MShareThread;
class MGnuShare
{