[packages] bash: force linking against internal libreadline.a, fixes Backfire build on CentOS 5.6
git-svn-id: svn://svn.openwrt.org/openwrt/packages@30653 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c56bf4dc9b
commit
c7d9d64113
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2007-2008 OpenWrt.org
|
||||
# Copyright (C) 2007-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bash
|
||||
PKG_VERSION:=4.2
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@GNU/bash
|
||||
|
@ -1,8 +1,6 @@
|
||||
Index: bash-4.2/execute_cmd.c
|
||||
===================================================================
|
||||
--- bash-4.2.orig/execute_cmd.c 2011-07-04 11:16:23.000000000 +0200
|
||||
+++ bash-4.2/execute_cmd.c 2011-07-04 11:17:33.000000000 +0200
|
||||
@@ -2202,7 +2202,11 @@
|
||||
--- a/execute_cmd.c
|
||||
+++ b/execute_cmd.c
|
||||
@@ -2202,7 +2202,11 @@ execute_pipeline (command, asynchronous,
|
||||
/* If the `lastpipe' option is set with shopt, and job control is not
|
||||
enabled, execute the last element of non-async pipelines in the
|
||||
current shell environment. */
|
||||
|
24
utils/bash/patches/002-force-internal-readline.patch
Normal file
24
utils/bash/patches/002-force-internal-readline.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -5748,8 +5748,7 @@ _ACEOF
|
||||
# static version specified as -llibname to override the
|
||||
# dynamic version
|
||||
case "${host_os}" in
|
||||
- darwin[89]*|darwin10*) READLINE_LIB='${READLINE_LIBRARY}' ;;
|
||||
- *) READLINE_LIB=-lreadline ;;
|
||||
+ *) READLINE_LIB='${READLINE_LIBRARY}' ;;
|
||||
esac
|
||||
fi
|
||||
else
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -540,8 +540,7 @@ if test $opt_readline = yes; then
|
||||
# static version specified as -llibname to override the
|
||||
# dynamic version
|
||||
case "${host_os}" in
|
||||
- darwin[[89]]*|darwin10*) READLINE_LIB='${READLINE_LIBRARY}' ;;
|
||||
- *) READLINE_LIB=-lreadline ;;
|
||||
+ *) READLINE_LIB='${READLINE_LIBRARY}' ;;
|
||||
esac
|
||||
fi
|
||||
else
|
Loading…
x
Reference in New Issue
Block a user