Add iputils packages
This patch adds utilities ping, ping6, tracepath, ... from iputils. It creates one ipkg package per program. Signed-off-by: Ondrej Zajicek <santiago@crfreenet.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@10364 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
13445dda7a
commit
c7f386974c
178
net/iputils/Makefile
Normal file
178
net/iputils/Makefile
Normal file
@ -0,0 +1,178 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: Makefile 9050 2007-09-28 01:23:17Z nbd $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=iputils
|
||||
PKG_VERSION:=20071127
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-s$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://www.skbuff.net/iputils
|
||||
PKG_MD5SUM:=12245e9927d60ff5cf4a99d265bcb7d3
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-s$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
||||
|
||||
define Package/iputils-arping
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - arping
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
endef
|
||||
|
||||
define Package/iputils-arping/description
|
||||
Program arping from iputils.
|
||||
Sends ARP REQUEST to a neighbour host.
|
||||
endef
|
||||
|
||||
define Package/iputils-clockdiff
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - clockdiff
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
endef
|
||||
|
||||
define Package/iputils-clockdiff/description
|
||||
Program clockdiff from iputils.
|
||||
Measures clock difference between hosts.
|
||||
endef
|
||||
|
||||
define Package/iputils-ping
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - ping
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
endef
|
||||
|
||||
define Package/iputils-ping/description
|
||||
Program ping from iputils.
|
||||
Sends ICMP ECHO_REQUEST to network hosts (IPv4).
|
||||
endef
|
||||
|
||||
define Package/iputils-ping6
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - ping6
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
endef
|
||||
|
||||
define Package/iputils-ping6/description
|
||||
Program ping6 from iputils.
|
||||
Sends ICMP ECHO_REQUEST to network hosts (IPv6).
|
||||
endef
|
||||
|
||||
define Package/iputils-tftpd
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - tftpd
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
endef
|
||||
|
||||
define Package/iputils-tftpd/description
|
||||
Program tftpd from iputils
|
||||
Trivial File Transfer Protocol server.
|
||||
endef
|
||||
|
||||
define Package/iputils-tracepath
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - tracepath
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
endef
|
||||
|
||||
define Package/iputils-tracepath/description
|
||||
Program tracepath from iputils.
|
||||
Traces path to a network host discovering MTU along this path (IPv4).
|
||||
endef
|
||||
|
||||
define Package/iputils-tracepath6
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - tracepath6
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
endef
|
||||
|
||||
define Package/iputils-tracepath6/description
|
||||
Program tracepath6 from iputils.
|
||||
Traces path to a network host discovering MTU along this path (IPv6).
|
||||
endef
|
||||
|
||||
define Package/iputils-traceroute6
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
TITLE:=iputils - traceroute6
|
||||
URL:=http://www.skbuff.net/iputils
|
||||
endef
|
||||
|
||||
define Package/iputils-traceroute6/description
|
||||
Program traceroute6 from iputils.
|
||||
Traces path to a network host (IPv6).
|
||||
endef
|
||||
|
||||
|
||||
|
||||
define Package/iputils-arping/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(STRIP) $(PKG_BUILD_DIR)/arping
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/arping $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/iputils-clockdiff/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(STRIP) $(PKG_BUILD_DIR)/clockdiff
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/clockdiff $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/iputils-ping/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(STRIP) $(PKG_BUILD_DIR)/ping
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ping $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/iputils-ping6/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(STRIP) $(PKG_BUILD_DIR)/ping6
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/ping6 $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/iputils-tftpd/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(STRIP) $(PKG_BUILD_DIR)/tftpd
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tftpd $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
define Package/iputils-tracepath/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(STRIP) $(PKG_BUILD_DIR)/tracepath
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tracepath $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/iputils-tracepath6/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(STRIP) $(PKG_BUILD_DIR)/tracepath6
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/tracepath6 $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
define Package/iputils-traceroute6/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(STRIP) $(PKG_BUILD_DIR)/traceroute6
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/traceroute6 $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,iputils-arping))
|
||||
$(eval $(call BuildPackage,iputils-clockdiff))
|
||||
$(eval $(call BuildPackage,iputils-ping))
|
||||
$(eval $(call BuildPackage,iputils-ping6))
|
||||
$(eval $(call BuildPackage,iputils-tftpd))
|
||||
$(eval $(call BuildPackage,iputils-tracepath))
|
||||
$(eval $(call BuildPackage,iputils-tracepath6))
|
||||
$(eval $(call BuildPackage,iputils-traceroute6))
|
14
net/iputils/patches/iputils.patch
Normal file
14
net/iputils/patches/iputils.patch
Normal file
@ -0,0 +1,14 @@
|
||||
diff -ur iputils/Makefile iputils_new/Makefile
|
||||
--- iputils/Makefile 2002-09-20 18:23:55.000000000 +0000
|
||||
+++ iputils_new/Makefile 2007-05-17 13:59:55.000000000 +0000
|
||||
@@ -27,8 +27,8 @@
|
||||
CCOPT=-D_GNU_SOURCE -O2 -Wstrict-prototypes -Wall -g
|
||||
CFLAGS=$(CCOPT) $(GLIBCFIX) -I$(KERNEL_INCLUDE) -I../include $(DEFINES)
|
||||
|
||||
-IPV4_TARGETS=tracepath ping clockdiff rdisc arping tftpd rarpd
|
||||
-IPV6_TARGETS=tracepath6 traceroute6 ping6
|
||||
+IPV4_TARGETS=tracepath ping clockdiff arping tftpd
|
||||
+IPV6_TARGETS=tracepath6 traceroute6 ping6
|
||||
TARGETS=$(IPV4_TARGETS) $(IPV6_TARGETS)
|
||||
|
||||
all: check-kernel $(TARGETS)
|
Loading…
x
Reference in New Issue
Block a user