lttng-ust: moved to github
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@44325 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
790e17eb4d
commit
c95e44d17d
@ -1,48 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2013 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=lttng-ust
|
||||
PKG_VERSION:=2.1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)
|
||||
PKG_MD5SUM:=2032e66f3438949c51ec9922c6f8542b
|
||||
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
PKG_USE_MIPS16:=0
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/lttng-ust
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=+liburcu +libuuid +librt
|
||||
TITLE:=LTTng Userspace Tracing Library
|
||||
URL:=https://lttng.org/
|
||||
endef
|
||||
|
||||
define Package/lttng-ust/description
|
||||
LTTng Userspace Tracing Library
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/lttng* $(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.{a,so*} $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Package/lttng-ust/install
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ust*.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,lttng-ust))
|
@ -1,35 +0,0 @@
|
||||
diff -urN lttng-ust-2.1.0/Makefile.am lttng-ust-2.1.0.new/Makefile.am
|
||||
--- lttng-ust-2.1.0/Makefile.am 2012-12-10 21:29:20.000000000 +0100
|
||||
+++ lttng-ust-2.1.0.new/Makefile.am 2013-01-14 14:25:41.923661688 +0100
|
||||
@@ -5,9 +5,7 @@
|
||||
liblttng-ust-ctl \
|
||||
liblttng-ust-fork \
|
||||
liblttng-ust-libc-wrapper \
|
||||
- tools \
|
||||
- tests \
|
||||
- doc
|
||||
+ tools
|
||||
|
||||
if BUILD_JNI_INTERFACE
|
||||
SUBDIRS += liblttng-ust-java
|
||||
diff -urN lttng-ust-2.1.0/Makefile.in lttng-ust-2.1.0.new/Makefile.in
|
||||
--- lttng-ust-2.1.0/Makefile.in 2012-12-20 19:24:57.000000000 +0100
|
||||
+++ lttng-ust-2.1.0.new/Makefile.in 2013-01-14 14:25:31.247661789 +0100
|
||||
@@ -135,7 +135,7 @@
|
||||
CTAGS = ctags
|
||||
DIST_SUBDIRS = . include snprintf libringbuffer liblttng-ust-comm \
|
||||
liblttng-ust liblttng-ust-ctl liblttng-ust-fork \
|
||||
- liblttng-ust-libc-wrapper tools tests doc liblttng-ust-java
|
||||
+ liblttng-ust-libc-wrapper tools liblttng-ust-java
|
||||
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
|
||||
distdir = $(PACKAGE)-$(VERSION)
|
||||
top_distdir = $(distdir)
|
||||
@@ -307,7 +307,7 @@
|
||||
ACLOCAL_AMFLAGS = -I config
|
||||
SUBDIRS = . include snprintf libringbuffer liblttng-ust-comm \
|
||||
liblttng-ust liblttng-ust-ctl liblttng-ust-fork \
|
||||
- liblttng-ust-libc-wrapper tools tests doc $(am__append_1)
|
||||
+ liblttng-ust-libc-wrapper tools $(am__append_1)
|
||||
|
||||
#temporarily disabled
|
||||
# liblttng-ust-malloc
|
Loading…
x
Reference in New Issue
Block a user