net/nmap: update nmap to 5.35DC1
git-svn-id: svn://svn.openwrt.org/openwrt/packages@22620 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
76e639d0a7
commit
ca11757e4e
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=nmap
|
||||
PKG_VERSION:=4.20
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=5.35DC1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://download.insecure.org/nmap/dist
|
||||
PKG_MD5SUM:=ea50419f99472200c4184a304e3831ea
|
||||
PKG_MD5SUM:=5bc2f8629f26716aa78d4bfe474a5d3a
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
@ -34,13 +34,14 @@ endef
|
||||
CONFIGURE_ARGS += \
|
||||
--without-openssl \
|
||||
--without-nmapfe \
|
||||
--with-libdnet="$(STAGING_DIR)/usr" \
|
||||
--without-liblua \
|
||||
--with-libdnet=included \
|
||||
--with-libpcap="$(STAGING_DIR)/usr" \
|
||||
--with-libpcre="$(STAGING_DIR)/usr" \
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++" \
|
||||
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
|
||||
LDFLAGS="$$$$LDFLAGS -lm" \
|
||||
LIBS="-nodefaultlibs -luClibc++ $(LIBGCC_S)" \
|
||||
|
||||
define Package/nmap/install
|
||||
|
@ -1,17 +1,11 @@
|
||||
#
|
||||
# Just assume pcap version is recent enough when cross-compiling
|
||||
#
|
||||
diff -ruN nmap-4.01-old/configure nmap-4.01-new/configure
|
||||
--- nmap-4.01-old/configure 2006-02-02 03:18:42.000000000 +0100
|
||||
+++ nmap-4.01-new/configure 2006-10-23 22:08:15.000000000 +0200
|
||||
@@ -5865,8 +5865,8 @@
|
||||
echo "$as_me:$LINENO: checking if libpcap version is recent enough" >&5
|
||||
echo $ECHO_N "checking if libpcap version is recent enough... $ECHO_C" >&6
|
||||
if test "$cross_compiling" = yes; then
|
||||
- echo "$as_me:$LINENO: result: no" >&5
|
||||
-echo "${ECHO_T}no" >&6; have_libpcap=no
|
||||
+ echo "$as_me:$LINENO: result: yes" >&5
|
||||
+echo "${ECHO_T}yes" >&6; have_libpcap=yes
|
||||
else
|
||||
cat >conftest.$ac_ext <<_ACEOF
|
||||
/* confdefs.h. */
|
||||
--- a/output.cc
|
||||
+++ b/output.cc
|
||||
@@ -2240,7 +2240,7 @@ struct data_file_record {
|
||||
|
||||
/* Compares this record to another. First compare the directory names, then
|
||||
compare the file names. */
|
||||
- bool operator<(const struct data_file_record &other) {
|
||||
+ bool operator<(const struct data_file_record &other) const {
|
||||
int cmp;
|
||||
|
||||
cmp = dir.compare(other.dir);
|
||||
|
@ -1,12 +1,11 @@
|
||||
diff -urN nmap-4.01.old/Makefile.in nmap-4.01.dev/Makefile.in
|
||||
--- nmap-4.01.old/Makefile.in 2006-02-09 19:22:27.000000000 -0700
|
||||
+++ nmap-4.01.dev/Makefile.in 2006-03-29 23:14:12.000000000 -0700
|
||||
@@ -152,7 +152,7 @@
|
||||
|
||||
install-nmap: $(TARGET)
|
||||
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir)
|
||||
- $(INSTALL) -c -m 755 -s nmap $(DESTDIR)$(bindir)/nmap
|
||||
+ $(INSTALL) -c -m 755 nmap $(DESTDIR)$(bindir)/nmap
|
||||
$(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/$(TARGET).1
|
||||
$(INSTALL) -c -m 644 docs/nmap.xsl $(DESTDIR)$(nmapdatadir)/
|
||||
$(INSTALL) -c -m 644 docs/nmap.dtd $(DESTDIR)$(nmapdatadir)/
|
||||
--- a/ncat/Makefile.in
|
||||
+++ b/ncat/Makefile.in
|
||||
@@ -136,7 +136,7 @@ $(NSOCKDIR)/libnsock.a: $(NSOCKDIR)/Make
|
||||
install: $(TARGET)
|
||||
@echo Installing Ncat;
|
||||
$(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(pkgdatadir) $(DESTDIR)$(mandir)/man1
|
||||
- $(INSTALL) -c -m 755 -s ncat $(DESTDIR)$(bindir)/ncat
|
||||
+ $(INSTALL) -c -m 755 ncat $(DESTDIR)$(bindir)/ncat
|
||||
if [ -n "$(DATAFILES)" ]; then \
|
||||
$(INSTALL) -c -m 644 $(DATAFILES) $(DESTDIR)$(pkgdatadir)/; \
|
||||
fi
|
||||
|
Loading…
x
Reference in New Issue
Block a user