gnutls: Added gnutls 3.2.12

Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@40338 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2014-03-30 18:09:02 +00:00
parent 3030ce383e
commit cb8cc94c2f
2 changed files with 29 additions and 106 deletions

View File

@ -8,17 +8,16 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=gnutls PKG_NAME:=gnutls
PKG_VERSION:=2.8.6 PKG_VERSION:=3.2.12
PKG_RELEASE:=2 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/gnutls \ PKG_SOURCE_URL:=ftp://ftp.gnutls.org/gcrypt/gnutls/v3.2
ftp://ftp.mirrors.wiretapped.net/pub/security/network-security/gnutls/ PKG_MD5SUM:=f507365940de8f095e1d867c6f0842f6
PKG_MD5SUM:=eb0a6d7d3cb9ac684d971c14f9f6d3ba PKG_MAINTAINER:=Nikos Mavrogiannopoulos <nmav@gnutls.org>
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1 PKG_INSTALL:=1
PKG_LIBTOOL_PATHS:=. lib libextra PKG_LIBTOOL_PATHS:=. lib
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
@ -27,13 +26,16 @@ define Package/gnutls/Default
SECTION:=libs SECTION:=libs
CATEGORY:=Libraries CATEGORY:=Libraries
TITLE:=GNU TLS TITLE:=GNU TLS
URL:=http://www.gnu.org/software/gnutls/ URL:=http://www.gnutls.org/
endef endef
define Package/gnutls/Default/description define Package/gnutls/Default/description
GnuTLS is a project that aims to develop a library which provides a GnuTLS is a secure communications library implementing the SSL, TLS
secure layer, over a reliable transport layer. Currently the GnuTLS and DTLS protocols and technologies around them. It provides a simple
library implements the SSL 3.0, TLS 1.0, and TLS 1.1 protocols. C language application programming interface (API) to access the secure
communications protocols as well as APIs to parse and write X.509, PKCS12,
OpenPGP and other required structures. It is aimed to be portable and
efficient with focus on security and interoperability.
endef endef
@ -42,7 +44,7 @@ $(call Package/gnutls/Default)
SECTION:=utils SECTION:=utils
CATEGORY:=Utilities CATEGORY:=Utilities
TITLE+= (certool utility) TITLE+= (certool utility)
DEPENDS+= +libgnutls +libgnutls-extra +libncurses +libreadline DEPENDS+= +libgnutls
endef endef
define Package/certtool/description define Package/certtool/description
@ -56,7 +58,7 @@ $(call Package/gnutls/Default)
SECTION:=utils SECTION:=utils
CATEGORY:=Utilities CATEGORY:=Utilities
TITLE+= (utilities) TITLE+= (utilities)
DEPENDS+= +libgnutls +libgnutls-extra DEPENDS+= +libgnutls
endef endef
define Package/gnutls-utils/description define Package/gnutls-utils/description
@ -69,7 +71,7 @@ endef
define Package/libgnutls define Package/libgnutls
$(call Package/gnutls/Default) $(call Package/gnutls/Default)
TITLE+= (library) TITLE+= (library)
DEPENDS+= +zlib +libgcrypt +libgpg-error DEPENDS+= +libnettle
endef endef
define Package/libgnutls/description define Package/libgnutls/description
@ -78,18 +80,6 @@ $(call Package/gnutls/Default/description)
endef endef
define Package/libgnutls-extra
$(call Package/gnutls/Default)
TITLE+= (extra library)
DEPENDS+= +libgnutls
endef
define Package/libgnutls-extra/description
$(call Package/gnutls/Default/description)
This package contains the GnuTLS extra shared library.
endef
define Package/libgnutls-openssl define Package/libgnutls-openssl
$(call Package/gnutls/Default) $(call Package/gnutls/Default)
TITLE+= (OpenSSL compat library) TITLE+= (OpenSSL compat library)
@ -105,13 +95,17 @@ CONFIGURE_ARGS+= \
--enable-shared \ --enable-shared \
--enable-static \ --enable-static \
--disable-openpgp-authentication \ --disable-openpgp-authentication \
--disable-libdane \
--disable-guile \ --disable-guile \
--with-included-libcfg \ --disable-nls \
--without-zlib \
--with-included-libtasn1 \ --with-included-libtasn1 \
--with-libgcrypt-prefix="$(STAGING_DIR)/usr" \ --enable-local-libopts \
--with-libreadline-prefix="$(STAGING_DIR)/usr" \ --disable-doc \
--with-libz-prefix="$(STAGING_DIR)/usr" \ --disable-tests \
--without-lzo \ --disable-rsa-export \
--disable-crywrap \
--without-p11-kit \
# XXX: AM_CFLAGS duplicates with CFLAGS # XXX: AM_CFLAGS duplicates with CFLAGS
MAKE_FLAGS:= \ MAKE_FLAGS:= \
@ -132,10 +126,10 @@ define Build/InstallDev
$(PKG_INSTALL_DIR)/usr/include/gnutls \ $(PKG_INSTALL_DIR)/usr/include/gnutls \
$(1)/usr/include/ $(1)/usr/include/
$(CP) \ $(CP) \
$(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-extra,-openssl}.{a,so*} \ $(PKG_INSTALL_DIR)/usr/lib/libgnutls{,-openssl}.{a,so*} \
$(1)/usr/lib/ $(1)/usr/lib/
$(CP) \ $(CP) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls{,-extra}.pc \ $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/gnutls.pc \
$(1)/usr/lib/pkgconfig/ $(1)/usr/lib/pkgconfig/
endef endef
@ -156,6 +150,7 @@ define Package/gnutls-utils/install
$(CP) \ $(CP) \
$(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} \ $(PKG_INSTALL_DIR)/usr/bin/gnutls-{cli,serv} \
$(PKG_INSTALL_DIR)/usr/bin/psktool \ $(PKG_INSTALL_DIR)/usr/bin/psktool \
$(PKG_INSTALL_DIR)/usr/bin/ocsptool \
$(PKG_INSTALL_DIR)/usr/bin/srptool \ $(PKG_INSTALL_DIR)/usr/bin/srptool \
$(1)/usr/bin/ $(1)/usr/bin/
endef endef
@ -167,12 +162,6 @@ define Package/libgnutls/install
endef endef
define Package/libgnutls-extra/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-extra.so.* $(1)/usr/lib/
endef
define Package/libgnutls-openssl/install define Package/libgnutls-openssl/install
$(INSTALL_DIR) $(1)/usr/lib $(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-openssl.so.* $(1)/usr/lib/ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libgnutls-openssl.so.* $(1)/usr/lib/
@ -182,5 +171,4 @@ endef
$(eval $(call BuildPackage,certtool)) $(eval $(call BuildPackage,certtool))
$(eval $(call BuildPackage,gnutls-utils)) $(eval $(call BuildPackage,gnutls-utils))
$(eval $(call BuildPackage,libgnutls)) $(eval $(call BuildPackage,libgnutls))
$(eval $(call BuildPackage,libgnutls-extra))
$(eval $(call BuildPackage,libgnutls-openssl)) $(eval $(call BuildPackage,libgnutls-openssl))

View File

@ -1,65 +0,0 @@
--- a/Makefile.in
+++ b/Makefile.in
@@ -147,7 +147,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
distdir dist dist-all distcheck
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = lib libextra gl src doc tests guile
+DIST_SUBDIRS = lib libextra gl src guile
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,7 +22,7 @@
DISTCHECK_CONFIGURE_FLAGS = --enable-gtk-doc
-SUBDIRS = lib libextra gl src doc tests
+SUBDIRS = lib libextra gl src
if HAVE_GUILE
SUBDIRS += guile
--- a/lib/Makefile.in
+++ b/lib/Makefile.in
@@ -274,7 +274,7 @@ AM_RECURSIVE_TARGETS = $(RECURSIVE_TARGE
distdir dist dist-all distcheck
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = gl po includes x509 minitasn1 opencdk openpgp
+DIST_SUBDIRS = gl includes x509 minitasn1 opencdk openpgp
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
@@ -819,7 +819,7 @@ top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
ACLOCAL_AMFLAGS = -I m4 -I gl/m4
-SUBDIRS = gl po includes x509 $(am__append_1) $(am__append_2)
+SUBDIRS = gl includes x509 $(am__append_1) $(am__append_2)
AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\" -I$(srcdir)/gl \
-I$(builddir)/gl -I$(srcdir)/includes -I$(builddir)/includes \
--- a/lib/Makefile.am
+++ b/lib/Makefile.am
@@ -22,7 +22,7 @@
ACLOCAL_AMFLAGS = -I m4 -I gl/m4
-SUBDIRS = gl po includes x509
+SUBDIRS = gl includes x509
if ENABLE_MINITASN1
SUBDIRS += minitasn1
endif
--- a/lib/configure.ac
+++ b/lib/configure.ac
@@ -37,9 +37,6 @@ AC_PROG_LIBTOOL
LIBGNUTLS_HOOKS
-AM_GNU_GETTEXT([external])
-AM_GNU_GETTEXT_VERSION([0.17])
-
AC_C_BIGENDIAN
# For includes/gnutls/gnutls.h.in.