packages: curl: update to 7.29.0
Fixes CVE-2012-0036. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@35693 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c530be2644
commit
cc66fe1f88
@ -8,7 +8,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=curl
|
||||
PKG_VERSION:=7.23.1
|
||||
PKG_VERSION:=7.29.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
|
||||
ftp://ftp.planetmirror.com/pub/curl/ \
|
||||
http://www.mirrormonster.com/curl/download/ \
|
||||
http://curl.mirrors.cyberservers.net/download/
|
||||
PKG_MD5SUM:=0296d3196b4bf82c896a869b38dbc5f2
|
||||
PKG_MD5SUM:=fa5f37f38a8042020e292ce7ec5341ce
|
||||
|
||||
PKG_LICENSE:=MIT
|
||||
PKG_LICENSE_FILES:=COPYING
|
||||
@ -84,7 +84,7 @@ CONFIGURE_ARGS += \
|
||||
$(call autoconf_bool,CONFIG_IPV6,ipv6) \
|
||||
|
||||
CONFIGURE_VARS += \
|
||||
LDFLAGS="$$$$LDFLAGS -lcrypto -lssl -lz" \
|
||||
LIBS="-lcrypto -lssl -lz" \
|
||||
CC="$(filter-out ccache,$(TARGET_CC))"
|
||||
|
||||
define Build/Compile
|
||||
|
@ -1,117 +0,0 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1542,15 +1542,6 @@ if test X"$OPT_SSL" != Xno; then
|
||||
fi
|
||||
|
||||
if test "$OPENSSL_ENABLED" = "1"; then
|
||||
- if test -n "$LIB_OPENSSL"; then
|
||||
- dnl when the ssl shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
|
||||
- dnl to prevent further configure tests to fail due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $LIB_OPENSSL to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
CURL_CHECK_OPENSSL_API
|
||||
fi
|
||||
|
||||
@@ -1779,17 +1770,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
|
||||
|
||||
if test "x$USE_GNUTLS" = "xyes"; then
|
||||
AC_MSG_NOTICE([detected GnuTLS version $version])
|
||||
-
|
||||
- if test -n "$gtlslib"; then
|
||||
- dnl when shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to
|
||||
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
|
||||
- dnl due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
fi
|
||||
|
||||
fi
|
||||
@@ -1889,18 +1869,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
|
||||
|
||||
CURL_LIBS="$CURL_LIBS -lpolarssl"
|
||||
LIBS="$LIBS -lpolarssl"
|
||||
-
|
||||
- if test -n "$polarssllib"; then
|
||||
- dnl when shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to
|
||||
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
|
||||
- dnl due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$polarssllib"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $polarssllib to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
fi dnl PolarSSL not disabled
|
||||
@@ -1978,18 +1946,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
|
||||
|
||||
CURL_LIBS="$CURL_LIBS -lcyassl -lm"
|
||||
LIBS="$LIBS -lcyassl -lm"
|
||||
-
|
||||
- if test -n "$cyassllib"; then
|
||||
- dnl when shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to
|
||||
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
|
||||
- dnl due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$cyassllib"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $cyassllib to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
fi dnl CyaSSL not disabled
|
||||
@@ -2073,19 +2029,6 @@ if test "$OPENSSL_ENABLED" != "1" -a "$G
|
||||
CPPFLAGS="$CLEANCPPFLAGS"
|
||||
])
|
||||
|
||||
- if test "x$USE_NSS" = "xyes"; then
|
||||
- AC_MSG_NOTICE([detected NSS version $version])
|
||||
-
|
||||
- dnl when shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to
|
||||
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
|
||||
- dnl due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$nssprefix/lib$libsuff"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $nssprefix/lib$libsuff to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
fi dnl NSS not disabled
|
||||
@@ -2134,11 +2077,6 @@ if test "$curl_ssl_msg" = "$init_ssl_msg
|
||||
AXTLS_ENABLED=1
|
||||
USE_AXTLS="yes"
|
||||
curl_ssl_msg="enabled (axTLS)"
|
||||
-
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_AXTLS"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $LIB_AXTLS to LD_LIBRARY_PATH])
|
||||
],[
|
||||
LDFLAGS="$CLEANLDFLAGS"
|
||||
CPPFLAGS="$CLEANCPPFLAGS"
|
||||
@@ -2240,10 +2178,6 @@ if test X"$OPT_LIBSSH2" != Xno; then
|
||||
dnl libssh2_session_handshake was added in 1.2.8
|
||||
AC_CHECK_FUNCS( libssh2_version libssh2_init libssh2_exit \
|
||||
libssh2_scp_send64 libssh2_session_handshake)
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH2"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $DIR_SSH2 to LD_LIBRARY_PATH])
|
||||
fi
|
||||
else
|
||||
dnl no libssh2, revert back to clean variables
|
Loading…
x
Reference in New Issue
Block a user