port expat to buildroot-ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4154 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
17ded9508f
commit
ce9b9a1833
93
libs/expat/Makefile
Normal file
93
libs/expat/Makefile
Normal file
@ -0,0 +1,93 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=expat
|
||||
PKG_VERSION:=1.95.8
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_MD5SUM:=aff487543845a82fe262e6e2922b4c8e
|
||||
PKG_SOURCE_URL:=@SF/expat
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/libexpat
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
TITLE:=An XML parsing library
|
||||
DESCRIPTION:=A fast, non-validating, stream-oriented XML parsing library.
|
||||
URL:=http://expat.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); rm -f config.cache; \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
|
||||
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
|
||||
./configure \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--program-prefix="" \
|
||||
--program-suffix="" \
|
||||
--prefix=/usr \
|
||||
--exec-prefix=/usr \
|
||||
--bindir=/usr/bin \
|
||||
--datadir=/usr/share \
|
||||
--includedir=/usr/include \
|
||||
--infodir=/usr/share/info \
|
||||
--libdir=/usr/lib \
|
||||
--libexecdir=/usr/lib \
|
||||
--localstatedir=/var \
|
||||
--mandir=/usr/share/man \
|
||||
--sbindir=/usr/sbin \
|
||||
--sysconfdir=/etc \
|
||||
$(DISABLE_NLS) \
|
||||
$(DISABLE_LARGEFILE) \
|
||||
--enable-shared \
|
||||
--enable-static \
|
||||
);
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/libexpat/install
|
||||
install -m0755 -d $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.so.* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
mkdir -p $(STAGING_DIR)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/xmlwf $(STAGING_DIR)/usr/bin/
|
||||
mkdir -p $(STAGING_DIR)/usr/include
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/expat*.h $(STAGING_DIR)/usr/include/
|
||||
mkdir -p $(STAGING_DIR)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libexpat.{a,so*} $(STAGING_DIR)/usr/lib/
|
||||
endef
|
||||
|
||||
define Build/UninstallDev
|
||||
rm -rf \
|
||||
$(STAGING_DIR)/usr/bin/xmlwf \
|
||||
$(STAGING_DIR)/usr/include/expat*.h \
|
||||
$(STAGING_DIR)/usr/lib/libexpat.{a,so*}
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,libexpat))
|
44
libs/expat/patches/001-destdir.patch
Normal file
44
libs/expat/patches/001-destdir.patch
Normal file
@ -0,0 +1,44 @@
|
||||
diff -ruN expat-1.95.8-orig/Makefile.in expat-1.95.8-1/Makefile.in
|
||||
--- expat-1.95.8-orig/Makefile.in 2004-05-07 22:00:48.000000000 +0200
|
||||
+++ expat-1.95.8-1/Makefile.in 2005-04-04 22:53:09.000000000 +0200
|
||||
@@ -34,6 +34,8 @@
|
||||
|
||||
top_builddir = .
|
||||
|
||||
+DESTDIR =
|
||||
+
|
||||
|
||||
INSTALL = @INSTALL@
|
||||
INSTALL_PROGRAM = @INSTALL_PROGRAM@
|
||||
@@ -73,22 +75,22 @@
|
||||
tests/runtests
|
||||
|
||||
install: xmlwf/xmlwf installlib
|
||||
- $(mkinstalldirs) $(bindir) $(man1dir)
|
||||
- $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(bindir)/xmlwf
|
||||
- $(INSTALL_DATA) $(MANFILE) $(man1dir)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir)
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL_PROGRAM) xmlwf/xmlwf $(DESTDIR)$(bindir)/xmlwf
|
||||
+ $(INSTALL_DATA) $(MANFILE) $(DESTDIR)$(man1dir)
|
||||
|
||||
installlib: $(LIBRARY) $(APIHEADER)
|
||||
- $(mkinstalldirs) $(libdir) $(includedir)
|
||||
- $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(libdir)/$(LIBRARY)
|
||||
- $(INSTALL_DATA) $(APIHEADER) $(includedir)
|
||||
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(includedir)
|
||||
+ $(LIBTOOL) --mode=install $(INSTALL) $(LIBRARY) $(DESTDIR)$(libdir)/$(LIBRARY)
|
||||
+ $(INSTALL_DATA) $(APIHEADER) $(DESTDIR)$(includedir)
|
||||
|
||||
uninstall: uninstalllib
|
||||
- $(LIBTOOL) --mode=uninstall rm -f $(bindir)/xmlwf
|
||||
+ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(bindir)/xmlwf
|
||||
rm -f $(man1dir)/xmlwf.1
|
||||
|
||||
uninstalllib:
|
||||
- $(LIBTOOL) --mode=uninstall rm -f $(libdir)/$(LIBRARY)
|
||||
- rm -f $(includedir)/$(APIHEADER)
|
||||
+ $(LIBTOOL) --mode=uninstall rm -f $(DESTDIR)$(libdir)/$(LIBRARY)
|
||||
+ rm -f $(DESTDIR)$(includedir)/$(APIHEADER)
|
||||
|
||||
# for VPATH builds (invoked by configure)
|
||||
mkdir-init:
|
Loading…
x
Reference in New Issue
Block a user