[packages] drop spcaview as v4l was dropped

git-svn-id: svn://svn.openwrt.org/openwrt/packages@32110 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
blogic 2012-06-07 15:01:05 +00:00
parent 8cc4bac211
commit cef07a646b
2 changed files with 0 additions and 56 deletions

View File

@ -1,40 +0,0 @@
#
# Copyright (C) 2006-2008 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=spcaview
PKG_VERSION:=20071224
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://mxhaard.free.fr/spca50x/Download/
PKG_MD5SUM:=12e46424844b937dd55eab28f74bcd8d
include $(INCLUDE_DIR)/package.mk
define Package/spcacat
SECTION:=multimedia
CATEGORY:=Multimedia
TITLE:=SPCA5xx webcam spcacat utility
DEPENDS:=+libpthread
URL:=http://mxhaard.free.fr/spca50x
endef
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
SERVFLAGS="$(TARGET_CFLAGS) -DLINUX" \
spcacat
endef
define Package/spcacat/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_BUILD_DIR)/spcacat $(1)/usr/bin/
endef
$(eval $(call BuildPackage,spcacat))

View File

@ -1,16 +0,0 @@
diff -Naur spcaview-20061208-orig/Makefile spcaview-20061208/Makefile
--- spcaview-20061208-orig/Makefile 2005-09-24 22:57:52.000000000 +0200
+++ spcaview-20061208/Makefile 2007-09-08 23:32:25.000000000 +0200
@@ -59,10 +59,10 @@
chmod 755 $(APP_BINARY)
spcaserv: $(OBJSERVER)
- gcc $(SERVFLAGS) -o spcaserv $(OBJSERVER) $(SERVLIBS)
+ $(CC) $(SERVFLAGS) -o spcaserv $(OBJSERVER) $(SERVLIBS)
spcacat: $(OBJCAT)
- gcc $(SERVFLAGS) -o spcacat $(OBJCAT) $(SERVLIBS)
+ $(CC) $(SERVFLAGS) -o spcacat $(OBJCAT) $(SERVLIBS)
spcaview.o: spcaview.c jconfig.h dpsh.h utils.h SDL_audioin.h