Fix batman compilation by using EXTRA_CFLAGS and not overriding CFLAGS
git-svn-id: svn://svn.openwrt.org/openwrt/packages@10541 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e9854061e0
commit
cf563a1cab
@ -58,7 +58,7 @@ Kernel gateway module for B.A.T.M.A.N.
|
||||
endef
|
||||
|
||||
MAKE_ARGS += \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
EXTRA_CFLAGS="$(TARGET_CFLAGS)" \
|
||||
CCFLAGS="$(TARGET_CFLAGS)" \
|
||||
OFLAGS="$(TARGET_CFLAGS)" \
|
||||
REVISION="$(PKG_REV)" \
|
||||
|
12
net/batman/patches/001-extra_cflags.patch
Normal file
12
net/batman/patches/001-extra_cflags.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -urN batmand-r963/linux/modules/Makefile.kbuild batmand-r963.new/linux/modules/Makefile.kbuild
|
||||
--- batmand-r963/linux/modules/Makefile.kbuild 2008-01-28 08:47:35.000000000 +0100
|
||||
+++ batmand-r963.new/linux/modules/Makefile.kbuild 2008-03-02 18:24:49.000000000 +0100
|
||||
@@ -3,7 +3,7 @@
|
||||
endif
|
||||
|
||||
LINUX26:=2.6
|
||||
-CFLAGS +=-DREVISION_VERSION=\"\ rv$(REVISION)\"
|
||||
+EXTRA_CFLAGS +=-DREVISION_VERSION=\"\ rv$(REVISION)\"
|
||||
|
||||
ifeq ($(strip $(findstring $(LINUX26),$(LINUX_VERSION))),$(LINUX26))
|
||||
|
Loading…
x
Reference in New Issue
Block a user