[packages] add opensips (openser fork)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@17842 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2009-10-03 23:30:10 +00:00
parent 2a95010859
commit d0234bb70f
6 changed files with 444 additions and 0 deletions

269
net/opensips/Makefile Normal file
View File

@ -0,0 +1,269 @@
#
# Copyright (C) 2009 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=opensips
PKG_VERSION:=1.5.3
PKG_RELEASE:=1
PKG_VARIANT:=-tls
PKG_SOURCE_URL:=http://opensips.org/pub/opensips/$(PKG_VERSION)/src
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)$(PKG_VARIANT)_src.tar.gz
PKG_MD5SUM:=8a03167420c31da15405bed7630ed3e2
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)$(PKG_VARIANT)
PKG_BUILD_DEPENDS:=curl expat libxml2 mysql openldap openssl pcre postgresql radiusclient-ng
include $(INCLUDE_DIR)/package.mk
define Package/opensips/Default
SECTION:=net
CATEGORY:=Network
URL:=http://www.opensips.org/
endef
define Package/opensips
$(call Package/opensips/Default)
TITLE:=Open SIP Server
MENU:=1
endef
define Package/opensips-example
$(call Package/opensips/Default)
TITLE:=OpenSIPS example config
DEPENDS:=opensips \
+opensips-mod-acc \
+opensips-mod-maxfwd \
+opensips-mod-mi-fifo \
+opensips-mod-registrar \
+opensips-mod-rr \
+opensips-mod-signaling \
+opensips-mod-sl \
+opensips-mod-textops \
+opensips-mod-tm \
+opensips-mod-uri \
+opensips-mod-uri-db \
+opensips-mod-usrloc \
+opensips-mod-xlog
endef
define Package/opensips-example/conffiles
/etc/default/opensips
/etc/opensips/opensips.cfg
endef
define Package/opensips-tools
$(call Package/opensips/Default)
TITLE:=OpenSIPS control tools
DEPENDS:=opensips
endef
define Package/opensips-tools/conffiles
/etc/opensips/opensipsctlrc
endef
PKG_EXCL_MODULES:= \
auth_diameter \
carrierroute \
db_berkeley \
db_oracle \
db_unixodbc \
mediaproxy \
mi_xmlrpc \
mmgeoip \
osp \
perl \
perlvdb \
snmpstats \
PKG_MAKE_ARGS:= \
cfg-dir="etc/opensips/" \
bin-dir="usr/sbin/" \
data-dir="var/lib/opensips/" \
lib-dir="usr/lib/opensips/" \
modules-dir="usr/lib/opensips/modules/" \
exclude_modules="$(PKG_EXCL_MODULES)" \
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) $(PKG_MAKE_ARGS) \
prefix=/ \
extra_defs="-DUSE_PTHREAD_MUTEX " \
CC="$(TARGET_CC)" \
ARCH="$(ARCH)" \
CFLAGS="$(TARGET_CFLAGS)" \
ISSMP="no" \
LOCALBASE="$(STAGING_DIR)/usr" \
SYSBASE="$(STAGING_DIR)/usr" \
PCRECFG= \
all
$(MAKE) -C $(PKG_BUILD_DIR) $(PKG_MAKE_ARGS) \
DESTDIR="$(PKG_INSTALL_DIR)" \
install
endef
define Package/opensips/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) \
$(PKG_INSTALL_DIR)/usr/sbin/opensips \
$(1)/usr/sbin/
$(INSTALL_DIR) $(1)/usr/lib/opensips/modules
endef
define Package/opensips-example/install
$(INSTALL_DIR) $(1)/etc/opensips
$(CP) \
$(PKG_INSTALL_DIR)/etc/opensips/opensips.cfg \
$(1)/etc/opensips/
$(SED) 's,$(PKG_INSTALL_DIR),,g' \
$(1)/etc/opensips/opensips.cfg
$(INSTALL_DIR) $(1)/etc/default
$(INSTALL_DATA) ./files/opensips.default $(1)/etc/default/opensips
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/opensips.init $(1)/etc/init.d/opensips
endef
define Package/opensips-tools/install
$(INSTALL_DIR) $(1)/etc/opensips
$(CP) \
$(PKG_INSTALL_DIR)/etc/opensips/opensipsctlrc \
$(1)/etc/opensips/
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) \
$(PKG_INSTALL_DIR)/usr/sbin/opensips{ctl,dbctl,unix} \
$(1)/usr/sbin/
$(INSTALL_DIR) $(1)/usr/lib/opensips
$(CP) \
$(PKG_INSTALL_DIR)/usr/lib/opensips/opensipsctl \
$(1)/usr/lib/opensips/
$(SED) 's,/bin/bash,/bin/sh,g' \
-e 's,$(PKG_INSTALL_DIR),,g' \
$(1)/usr/sbin/opensips{ctl,dbctl}
endef
define BuildPlugin
define Package/opensips-mod-$(1)
$$(call Package/opensips/Default)
TITLE:= OpenSIPS $(3) module
DEPENDS:=opensips $$(foreach m,$(4),+opensips-mod-$$m) $(5)
endef
define Package/opensips-mod-$(1)/install
[ -z "$(2)" ] || $(INSTALL_DIR) $$(1)/usr/lib/opensips/modules/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/opensips/modules/$(2).so \
$$(1)/usr/lib/opensips/modules/ ;
endef
$$(eval $$(call BuildPackage,opensips-mod-$(1)))
endef
$(eval $(call BuildPackage,opensips))
$(eval $(call BuildPackage,opensips-example))
$(eval $(call BuildPackage,opensips-tools))
$(eval $(call BuildPlugin,acc,acc,Accounting,tm,))
$(eval $(call BuildPlugin,alias-db,alias_db,Database-backend aliases,,))
$(eval $(call BuildPlugin,auth,auth,Authentication Framework,signaling,))
$(eval $(call BuildPlugin,auth-db,auth_db,Database-backend authentication,auth,))
$(eval $(call BuildPlugin,auth-radius,auth_radius,RADIUS-backend authentication,auth,+libradiusclient-ng))
$(eval $(call BuildPlugin,avp-radius,avp_radius,RADIUS-backend for AVP loading,,+libradiusclient-ng))
$(eval $(call BuildPlugin,avpops,avpops,AVP operation,,))
$(eval $(call BuildPlugin,benchmark,benchmark,Config benchmark,,))
$(eval $(call BuildPlugin,call-control,call_control,Prepair application,dialog,))
#$(eval $(call BuildPlugin,carrierroute,carrierroute,Carrier Routing,,+libconfuse))
$(eval $(call BuildPlugin,cfgutils,cfgutils,Config utilities,,))
$(eval $(call BuildPlugin,closeddial,closeddial,PBX-like features,,))
$(eval $(call BuildPlugin,cpl-c,cpl-c,Call Processing language interpreter,tm sl usrloc,+libxml2))
#$(eval $(call BuildPlugin,db-berkeley,db_berkeley,Berkeley DB Database-backend,,))
$(eval $(call BuildPlugin,db-flatstore,db_flatstore,Fast writing-only text database-backed,,))
$(eval $(call BuildPlugin,db-mysql,db_mysql,MySQL database-backend,,+libmysqlclient))
#$(eval $(call BuildPlugin,db-oracle,db_oracle,Oracle Database-backend,,))
$(eval $(call BuildPlugin,db-postgres,db_postgres,PostgreSQL Database-backend,,+libpq))
$(eval $(call BuildPlugin,db-text,db_text,Text database-backend,,))
#$(eval $(call BuildPlugin,db-unixodbc,db_unixodbc,UnixODBC Database-backend,,))
$(eval $(call BuildPlugin,dialog,dialog,Dialog support,rr tm,))
$(eval $(call BuildPlugin,dialplan,dialplan,Dialplan management,,))
$(eval $(call BuildPlugin,dispatcher,dispatcher,Dispatcher,,))
$(eval $(call BuildPlugin,diversion,diversion,Diversion header insertion,,))
$(eval $(call BuildPlugin,domain,domain,Multi-domain support,,))
$(eval $(call BuildPlugin,domainpolicy,domainpolicy,Domain policy,,))
$(eval $(call BuildPlugin,drouting,drouting,Dynaming routing,,))
$(eval $(call BuildPlugin,enum,enum,ENUM lookup,,))
$(eval $(call BuildPlugin,exec,exec,External exec,,))
$(eval $(call BuildPlugin,gflags,gflags,Global shared flags,,))
$(eval $(call BuildPlugin,group,group,Database-backend user-groups,,))
$(eval $(call BuildPlugin,group-radius,group_radius,RADIUS-backend user-groups,,))
$(eval $(call BuildPlugin,h350,h350,H.350,ldap,+libopenldap))
$(eval $(call BuildPlugin,identity,identity,Identity,,+libopenssl))
$(eval $(call BuildPlugin,imc,imc,IM conferencing,db-mysql tm,))
$(eval $(call BuildPlugin,jabber,jabber,Jabber,tm,+libexpat))
$(eval $(call BuildPlugin,lcr,lcr,Least Cost Routing,tm,))
$(eval $(call BuildPlugin,ldap,ldap,LDAP connector,,+libopenldap))
$(eval $(call BuildPlugin,load_balancer,load_balancer,Load balancer,dialog,))
$(eval $(call BuildPlugin,localcache,localcache,Local cache,,))
$(eval $(call BuildPlugin,mangler,mangler,SIP mangler,,))
$(eval $(call BuildPlugin,maxfwd,maxfwd,Max-Forward processor,,))
$(eval $(call BuildPlugin,mi-datagram,mi_datagram,Datagram support for Management Interface,,))
$(eval $(call BuildPlugin,mi-fifo,mi_fifo,FIFO support for Management Interface,,))
#$(eval $(call BuildPlugin,mi-xmlrpc,mi_xmlrpc,XML-RPC support for Management Interface,,+xmlrpc-c))
#$(eval $(call BuildPlugin,mediaproxy,mediaproxy,NAT traversal,,+mediaproxy))
#$(eval $(call BuildPlugin,mmgeoip,mmgeoip,MaxMind GeoIP,,+libgeoip))
$(eval $(call BuildPlugin,msilo,msilo,SIP message silo,tm,))
$(eval $(call BuildPlugin,nat_traversal,nat_traversal,NAT traversal,dialog sl tm,))
$(eval $(call BuildPlugin,nathelper,nathelper,NAT traversal helper,,+rtpproxy))
$(eval $(call BuildPlugin,options,options,OPTIONS server replier,sl,))
#$(eval $(call BuildPlugin,osp,osp,OSP peering,auth rr sl tm textops,+libosp))
$(eval $(call BuildPlugin,path,path,SIP path insertion,rr,))
$(eval $(call BuildPlugin,pdt,pdt,Prefix-to-Domain translator,,))
$(eval $(call BuildPlugin,peering,peering,Perring,,+libradiusclient-ng))
#$(eval $(call BuildPlugin,perl,perl,Perl,sl,+perl))
#$(eval $(call BuildPlugin,perlvdb,perlvdb,Perl Virtual DB,perl,))
$(eval $(call BuildPlugin,permissions,permissions,Permissions control,,))
$(eval $(call BuildPlugin,pike,pike,Flood detector,,))
$(eval $(call BuildPlugin,presence,presence,Presence server,signaling,+libxml2))
$(eval $(call BuildPlugin,presence-dialoginfo,presence_dialoginfo,Dialog Event presence,presence,))
$(eval $(call BuildPlugin,presence-mwi,presence_mwi,Message Waiting Indication presence,presence,))
$(eval $(call BuildPlugin,presence-xcapdiff,presence_xcapdiff,XCAP-Diff presence,presence pua,))
$(eval $(call BuildPlugin,presence-xml,presence_xml,XCAP presence,presence xcap-client,))
$(eval $(call BuildPlugin,pua,pua,Presence User Agent,tm,+libxml2))
$(eval $(call BuildPlugin,pua-bla,pua_bla,Bridged Line Appearence PUA,presence pua usrloc,))
$(eval $(call BuildPlugin,pua-dialoginfo,pua_dialoginfo,Dialog Event PUA,dialog pua,))
$(eval $(call BuildPlugin,pua-mi,pua_mi,PUA Management Interface,pua,))
$(eval $(call BuildPlugin,pua-usrloc,pua_usrloc,PUA User Location,pua usrloc,))
$(eval $(call BuildPlugin,pua-xmpp,pua_xmpp,PUA XMPP,presence pua xmpp,))
$(eval $(call BuildPlugin,qos,qos,QoS control,dialog,))
$(eval $(call BuildPlugin,ratelimit,ratelimit,Traffic shapping,,))
$(eval $(call BuildPlugin,regex,regex,Regular Expression,,+libpcre))
$(eval $(call BuildPlugin,registrar,registrar,SIP Registrar,signaling usrloc,))
$(eval $(call BuildPlugin,rls,rls,Resource List Server,presence pua signaling tm,+libxml2))
$(eval $(call BuildPlugin,rr,rr,Record-Route and Route,,))
$(eval $(call BuildPlugin,seas,seas,SIP Express Application Server,tm,))
$(eval $(call BuildPlugin,signaling,signaling,Signaling,sl tm,))
$(eval $(call BuildPlugin,siptrace,siptrace,SIP trace,,))
$(eval $(call BuildPlugin,sl,sl,Stateless replier,,))
$(eval $(call BuildPlugin,sms,sms,SIP-to-SMS IM gateway,tm,))
#$(eval $(call BuildPlugin,snmpstats,snmpstats,SNMP,presence usrloc,+libnetsnmp))
$(eval $(call BuildPlugin,speeddial,speeddial,Per-user speed-dial controller,,))
$(eval $(call BuildPlugin,statistics,statistics,Script statistics,,))
$(eval $(call BuildPlugin,sst,sst,SIP Session Timer,dialog sl,))
$(eval $(call BuildPlugin,textops,textops,Text operations,,))
$(eval $(call BuildPlugin,tlsops,tlsops,TLS operations,,+libopenssl))
$(eval $(call BuildPlugin,tm,tm,Transaction,,))
$(eval $(call BuildPlugin,uac,uac,User Agent Client,tm,))
$(eval $(call BuildPlugin,uac-redirect,uac_redirect,User Agent Client redirection,tm,))
$(eval $(call BuildPlugin,uri,uri,Generic URI operation,,))
$(eval $(call BuildPlugin,uri-db,uri_db,Database-backend SIP URI checking,,))
$(eval $(call BuildPlugin,uri-radius,uri_radius,RADIUS-backend SIP URI checking,,+libradiusclient-ng))
$(eval $(call BuildPlugin,userblacklist,userblacklist,User blacklists,,))
$(eval $(call BuildPlugin,usrloc,usrloc,User location,,))
$(eval $(call BuildPlugin,xcap-client,xcap_client,XCAP Client,,+libcurl +libxml2))
$(eval $(call BuildPlugin,xlog,xlog,Advanced logger,,))
$(eval $(call BuildPlugin,xmpp,xmpp,SIP-to-XMPP Gateway,tm,+libexpat))

View File

@ -0,0 +1,13 @@
# OPTIONS
# -n COUNT
# Specifies the number of children processes forked per interface
# -N COUNT
# Specifies the number of children processes forked to handle tcp incoming connections
# -m SIZE
# Size of the shared memory which will be allocated (in Megabytes).
# -u UID
# Changes the user id under which
# -g GID
# Changes the group id under which
OPTIONS="-n 4 -m 4 - m 8"

View File

@ -0,0 +1,19 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2009 OpenWrt.org
START=50
BIN=opensips
DEFAULT=/etc/default/$BIN
RUN_D=/var/run
PID_F=$RUN_D/$BIN.pid
start() {
[ -f $DEFAULT ] && . $DEFAULT
mkdir -p $RUN_D
$BIN -P $PID_F $OPTIONS >/dev/null 2>&1
}
stop() {
[ -f $PID_F ] && kill $(cat $PID_F)
}

View File

@ -0,0 +1,21 @@
--- a/pvar.c.rej
+++ /dev/null
@@ -1,18 +0,0 @@
-***************
-*** 2409,2415 ****
- LM_ERR("invalid socket specification\n");
- return -1;
- }
-- si = grep_sock_info(&host, (unsigned short)port,
- (unsigned short)proto);
- if (si==NULL)
- return -1;
---- 2409,2416 ----
- LM_ERR("invalid socket specification\n");
- return -1;
- }
-+ set_sip_defaults( port, proto);
-+ si = grep_sock_info(&host, (unsigned short)port,
- (unsigned short)proto);
- if (si==NULL)
- return -1;

View File

@ -0,0 +1,20 @@
--- a/config.h
+++ b/config.h
@@ -48,7 +48,7 @@
#define MAX_LISTEN 16 /*!< maximum number of addresses on which we will listen */
-#define CHILD_NO 8 /*!< default number of child processes started */
+#define CHILD_NO 4 /*!< default number of child processes started */
#define RT_NO 100 /*!< routing tables number */
#define FAILURE_RT_NO RT_NO /*!< on_failure routing tables number */
@@ -114,7 +114,7 @@
#define SRV_MAX_PREFIX_LEN SRV_TLS_PREFIX_LEN
#define PKG_MEM_POOL_SIZE 1024*1024 /*!< Used only if PKG_MALLOC is defined*/
-#define SHM_MEM_SIZE 32 /*!< Used if SH_MEM is defined*/
+#define SHM_MEM_SIZE 8 /*!< Used if SH_MEM is defined*/
#define TIMER_TICK 1 /*!< one second */
#define UTIMER_TICK 100*1000 /*!< 100 miliseconds*/

View File

@ -0,0 +1,102 @@
--- a/modules/carrierroute/Makefile
+++ b/modules/carrierroute/Makefile
@@ -12,10 +12,8 @@ NAME=carrierroute.so
BUILDER = $(shell which confuse-config)
ifeq ($(BUILDER),)
- CONFUSEDEFS=-I$(LOCALBASE)/include -I/usr/local/include -I/opt/include \
- -I/usr/sfw/include
- CONFUSELIBS=-L$(LOCALBASE)/lib -L/usr/local/lib -L/usr/sfw/lib \
- -L/opt/lib -lconfuse
+ CONFUSEDEFS=-I$(LOCALBASE)/include
+ CONFUSELIBS=-L$(LOCALBASE)/lib
else
CONFUSEDEFS = $(shell confuse-config --cflags)
CONFUSELIBS = $(shell confuse-config --libs)
--- a/modules/h350/Makefile
+++ b/modules/h350/Makefile
@@ -9,6 +9,8 @@ include ../../Makefile.defs
auto_gen=
NAME=h350.so
-LIBS=
+
+DEFS+=-I$(LOCALBASE)/include
+LIBS=-L$(LOCALBASE)/lib -lldap
include ../../Makefile.modules
--- a/modules/identity/Makefile
+++ b/modules/identity/Makefile
@@ -9,7 +9,7 @@ include ../../Makefile.defs
auto_gen=
NAME=identity.so
-DEFS+= -I$(LOCALBASE)/ssl/include -I$(LOCALBASE)/include -I/usr/sfw/include -I/usr/local/ssl/include
-LIBS= -L$(LOCALBASE)/lib -L$(LOCALBASE)/ssl/lib -L/usr/sfw/lib -L/usr/local/ssl/lib -lssl -lcrypto
+DEFS+= -I$(LOCALBASE)/include
+LIBS= -L$(LOCALBASE)/lib -lssl -lcrypto
include ../../Makefile.modules
--- a/modules/ldap/Makefile
+++ b/modules/ldap/Makefile
@@ -12,7 +12,8 @@ include ../../Makefile.defs
auto_gen=
NAME=ldap.so
-LIBS=-lldap
+DEFS+=-I$(LOCALBASE)/include
+LIBS=-L$(LOCALBASE)/lib -lldap
ifeq ($(OS),solaris)
DEFS+=-I$(LOCALBASE)/include -I/usr/sfw/include -I/usr/local/include -I/opt/sfw/include -I/opt/csw/include
--- a/modules/pua_bla/Makefile
+++ b/modules/pua_bla/Makefile
@@ -9,8 +9,8 @@ include ../../Makefile.defs
auto_gen=
NAME=pua_bla.so
LIBS=
-DEFS+=-I/usr/include/libxml2 -I$(LOCALBASE)/include/libxml2 -I$(LOCALBASE)/include
-LIBS+=-L/usr/include/lib -L$(LOCALBASE)/lib -lxml2
+DEFS+=-I$(LOCALBASE)/include/libxml2 -I$(LOCALBASE)/include
+LIBS+=-L$(LOCALBASE)/lib -lxml2
include ../../Makefile.modules
--- a/modules/pua_xmpp/Makefile
+++ b/modules/pua_xmpp/Makefile
@@ -10,7 +10,7 @@ auto_gen=
NAME= pua_xmpp.so
LIBS=
-DEFS+=-I/usr/include/libxml2 -I$(LOCALBASE)/include/libxml2 -I$(LOCALBASE)/include
-LIBS+=-L/usr/include/lib -L$(LOCALBASE)/lib -lxml2
+DEFS+=-I$(LOCALBASE)/include/libxml2 -I$(LOCALBASE)/include
+LIBS+=-L$(LOCALBASE)/lib -lxml2
include ../../Makefile.modules
--- a/modules/regex/Makefile
+++ b/modules/regex/Makefile
@@ -20,8 +20,8 @@ ifneq ($(PCRECFG),)
else
- DEFS+=-I/usr/include -I/usr/sfw/include -I/usr/local/include -I/opt/csw/include -I$(LOCALBASE)/include
- LIBS=-I/usr/lib -I/usr/sfw/lib -I/usr/local/lib -I/opt/csw/lib -I$(LOCALBASE)/lib -lpcre
+ DEFS+=-I$(LOCALBASE)/include
+ LIBS=-L$(LOCALBASE)/lib -lpcre
endif
--- a/modules/tlsops/Makefile
+++ b/modules/tlsops/Makefile
@@ -7,8 +7,8 @@ auto_gen=
NAME=tlsops.so
LIBS=
-DEFS+= -I$(LOCALBASE)/ssl/include -I$(LOCALBASE)/include -I/usr/sfw/include -I/usr/local/ssl/include
-LIBS+= -L$(LOCALBASE)/lib -L$(LOCALBASE)/ssl/lib -L/usr/sfw/lib -L/usr/local/ssl/lib -lssl -lcrypto
+DEFS+= -I$(LOCALBASE)/include
+LIBS+= -L$(LOCALBASE)/lib -lssl -lcrypto
include ../../Makefile.modules