coreutils: update to version 8.7
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24060 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5f26543a7e
commit
d04eca5645
@ -8,12 +8,13 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=coreutils
|
PKG_NAME:=coreutils
|
||||||
PKG_VERSION:=7.2
|
PKG_VERSION:=8.7
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=@GNU/coreutils
|
PKG_SOURCE_URL:=@GNU/coreutils
|
||||||
PKG_MD5SUM:=427c2914d3eab956f317c9ec6a45e62a
|
PKG_MD5SUM:=3c1ae9531159447083ae8f25ae554b81
|
||||||
|
PKG_BUILD_DEPENDS:=libpthread
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -51,7 +52,8 @@ define Package/coreutils
|
|||||||
+coreutils-true +coreutils-truncate +coreutils-tsort +coreutils-tty \
|
+coreutils-true +coreutils-truncate +coreutils-tsort +coreutils-tty \
|
||||||
+coreutils-uname +coreutils-unexpand +coreutils-uniq \
|
+coreutils-uname +coreutils-unexpand +coreutils-uniq \
|
||||||
+coreutils-unlink +coreutils-uptime +coreutils-users +coreutils-vdir \
|
+coreutils-unlink +coreutils-uptime +coreutils-users +coreutils-vdir \
|
||||||
+coreutils-wc +coreutils-who +coreutils-whoami +coreutils-yes
|
+coreutils-wc +coreutils-who +coreutils-whoami +coreutils-yes \
|
||||||
|
+coreutils-nproc +coreutils-stdbuf
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/coreutils/description
|
define Package/coreutils/description
|
||||||
@ -63,7 +65,8 @@ endef
|
|||||||
CONFIGURE_VARS += \
|
CONFIGURE_VARS += \
|
||||||
gl_cv_func_mbrtowc_incomplete_state=yes \
|
gl_cv_func_mbrtowc_incomplete_state=yes \
|
||||||
gl_cv_func_mbrtowc_retval=yes \
|
gl_cv_func_mbrtowc_retval=yes \
|
||||||
gl_cv_func_wcrtomb_retval=yes
|
gl_cv_func_wcrtomb_retval=yes \
|
||||||
|
ac_cv_type_pthread_spinlock_t=no
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--enable-install-program=su
|
--enable-install-program=su
|
||||||
@ -925,6 +928,24 @@ define Package/coreutils-nohup/install
|
|||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/nohup $(1)/usr/bin/
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/nohup $(1)/usr/bin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/coreutils-nproc
|
||||||
|
SECTION:utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=Utility nproc from the GNU core utilites
|
||||||
|
URL:=http://www.gnu.org/software/coreutils/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/coreutils-nproc/description
|
||||||
|
Full version of standard GNU nproc utility. Normally, you would not
|
||||||
|
use this package, since the functionality in BusyBox is more than
|
||||||
|
sufficient.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/coreutils-nproc/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/nproc $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/coreutils-od
|
define Package/coreutils-od
|
||||||
SECTION:utils
|
SECTION:utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
@ -1324,6 +1345,7 @@ endef
|
|||||||
define Package/coreutils-sort
|
define Package/coreutils-sort
|
||||||
SECTION:utils
|
SECTION:utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
|
DEPENDS:=+libpthread
|
||||||
TITLE:=Utility sort from the GNU core utilites
|
TITLE:=Utility sort from the GNU core utilites
|
||||||
URL:=http://www.gnu.org/software/coreutils/
|
URL:=http://www.gnu.org/software/coreutils/
|
||||||
endef
|
endef
|
||||||
@ -1375,6 +1397,24 @@ define Package/coreutils-stat/install
|
|||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/stat $(1)/usr/bin/
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/stat $(1)/usr/bin/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
|
define Package/coreutils-stdbuf
|
||||||
|
SECTION:utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=Utility stdbuf from the GNU core utilites
|
||||||
|
URL:=http://www.gnu.org/software/coreutils/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/coreutils-stdbuf/description
|
||||||
|
Full version of standard GNU stdbuf utility. Normally, you would not
|
||||||
|
use this package, since the functionality in BusyBox is more than
|
||||||
|
sufficient.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/coreutils-stdbuf/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/stdbuf $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
define Package/coreutils-stty
|
define Package/coreutils-stty
|
||||||
SECTION:utils
|
SECTION:utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
@ -1892,6 +1932,7 @@ $(eval $(call BuildPackage,coreutils-mv))
|
|||||||
$(eval $(call BuildPackage,coreutils-nice))
|
$(eval $(call BuildPackage,coreutils-nice))
|
||||||
$(eval $(call BuildPackage,coreutils-nl))
|
$(eval $(call BuildPackage,coreutils-nl))
|
||||||
$(eval $(call BuildPackage,coreutils-nohup))
|
$(eval $(call BuildPackage,coreutils-nohup))
|
||||||
|
$(eval $(call BuildPackage,coreutils-nproc))
|
||||||
$(eval $(call BuildPackage,coreutils-od))
|
$(eval $(call BuildPackage,coreutils-od))
|
||||||
$(eval $(call BuildPackage,coreutils-paste))
|
$(eval $(call BuildPackage,coreutils-paste))
|
||||||
$(eval $(call BuildPackage,coreutils-pathchk))
|
$(eval $(call BuildPackage,coreutils-pathchk))
|
||||||
@ -1917,6 +1958,7 @@ $(eval $(call BuildPackage,coreutils-sleep))
|
|||||||
$(eval $(call BuildPackage,coreutils-sort))
|
$(eval $(call BuildPackage,coreutils-sort))
|
||||||
$(eval $(call BuildPackage,coreutils-split))
|
$(eval $(call BuildPackage,coreutils-split))
|
||||||
$(eval $(call BuildPackage,coreutils-stat))
|
$(eval $(call BuildPackage,coreutils-stat))
|
||||||
|
$(eval $(call BuildPackage,coreutils-stdbuf))
|
||||||
$(eval $(call BuildPackage,coreutils-stty))
|
$(eval $(call BuildPackage,coreutils-stty))
|
||||||
$(eval $(call BuildPackage,coreutils-su))
|
$(eval $(call BuildPackage,coreutils-su))
|
||||||
$(eval $(call BuildPackage,coreutils-sum))
|
$(eval $(call BuildPackage,coreutils-sum))
|
||||||
|
@ -1,24 +1,22 @@
|
|||||||
diff -urN coreutils-6.9/Makefile.am coreutils-6.9.new/Makefile.am
|
--- a/Makefile.am
|
||||||
--- coreutils-6.9/Makefile.am 2007-03-18 22:36:43.000000000 +0100
|
+++ b/Makefile.am
|
||||||
+++ coreutils-6.9.new/Makefile.am 2008-11-15 14:15:17.000000000 +0100
|
@@ -17,7 +17,7 @@
|
||||||
@@ -15,7 +15,7 @@
|
|
||||||
# You should have received a copy of the GNU General Public License
|
ALL_RECURSIVE_TARGETS =
|
||||||
# along with this program. If not, see <http://www.gnu.org/licenses/>.
|
|
||||||
|
|
||||||
-SUBDIRS = lib src doc man po tests gnulib-tests
|
-SUBDIRS = lib src doc man po tests gnulib-tests
|
||||||
+SUBDIRS = lib src po
|
+SUBDIRS = lib src po
|
||||||
EXTRA_DIST = cfg.mk maint.mk \
|
|
||||||
.prev-version THANKS-to-translators THANKStt.in \
|
changelog_etc = \
|
||||||
.version \
|
ChangeLog-2005 \
|
||||||
diff -urN coreutils-6.9/Makefile.in coreutils-6.9.new/Makefile.in
|
--- a/Makefile.in
|
||||||
--- coreutils-6.9/Makefile.in 2007-03-22 22:20:26.000000000 +0100
|
+++ b/Makefile.in
|
||||||
+++ coreutils-6.9.new/Makefile.in 2008-11-15 14:15:05.000000000 +0100
|
@@ -1238,7 +1238,7 @@ top_srcdir = @top_srcdir@
|
||||||
@@ -918,7 +918,7 @@
|
|
||||||
top_build_prefix = @top_build_prefix@
|
# Some tests always need root privileges, others need them only sometimes.
|
||||||
top_builddir = @top_builddir@
|
ALL_RECURSIVE_TARGETS = install-root check-root distcheck-hook
|
||||||
top_srcdir = @top_srcdir@
|
|
||||||
-SUBDIRS = lib src doc man po tests gnulib-tests
|
-SUBDIRS = lib src doc man po tests gnulib-tests
|
||||||
+SUBDIRS = lib src po
|
+SUBDIRS = lib src po
|
||||||
EXTRA_DIST = cfg.mk maint.mk \
|
changelog_etc = \
|
||||||
.prev-version THANKS-to-translators THANKStt.in \
|
ChangeLog-2005 \
|
||||||
.version \
|
ChangeLog-2006 \
|
||||||
|
Loading…
x
Reference in New Issue
Block a user