add aircrack-ptw (patch by Jens Muecke)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6898 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9e522d42f7
commit
d3b4ef6c0f
51
net/aircrack-ptw/Makefile
Normal file
51
net/aircrack-ptw/Makefile
Normal file
@ -0,0 +1,51 @@
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id: Makefile 6500 2007-03-04 04:19:46Z pavlov $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=aircrack-ptw
|
||||
PKG_VERSION:=1.0.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.cdc.informatik.tu-darmstadt.de/aircrack-ptw/download
|
||||
PKG_MD5SUM:=1d7d84d1e69189bc1397db3f565c183a
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/aircrack-ptw
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+libpcap
|
||||
TITLE:=A tool using a new method for breaking WEP Keys
|
||||
URL:=http://www.cdc.informatik.tu-darmstadt.de/aircrack-ptw/
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
rm -rf $(PKG_INSTALL_DIR)
|
||||
mkdir -p $(PKG_INSTALL_DIR)
|
||||
$(TARGET_CC) $(TARGET_CFLAGS) $(TARGET_CPPFLAGS) \
|
||||
$(TARGET_LDFLAGS) \
|
||||
-lpcap -o $(PKG_BUILD_DIR)/aircrack-ptw \
|
||||
$(PKG_BUILD_DIR)/aircrack-ptw.c \
|
||||
$(PKG_BUILD_DIR)/aircrack-ptw-lib.c
|
||||
endef
|
||||
|
||||
define Package/aircrack-ptw/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_BUILD_DIR)/aircrack-ptw $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,aircrack-ptw))
|
12
net/aircrack-ptw/patches/001-smaller.patch
Normal file
12
net/aircrack-ptw/patches/001-smaller.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -purN aircrack-ptw-1.0.0/aircrack-ptw.c aircrack-ptw-1.0.0_patch/aircrack-ptw.c
|
||||
--- aircrack-ptw-1.0.0/aircrack-ptw.c 2007-04-03 08:50:42.000000000 -0400
|
||||
+++ aircrack-ptw-1.0.0_patch/aircrack-ptw.c 2007-04-07 16:50:38.000000000 -0400
|
||||
@@ -6,7 +6,7 @@
|
||||
|
||||
#include "aircrack-ptw-lib.h"
|
||||
|
||||
-#define KEYLIMIT (1000000)
|
||||
+#define KEYLIMIT (10000)
|
||||
#define BSSIDLEN (6)
|
||||
|
||||
typedef struct {
|
Loading…
x
Reference in New Issue
Block a user