Various privoxy fixes:

* use Build/Configure/Default
 * add missing config files (closes: #1519)
 * define ipkg/configfiles
 * use pidfile in init-script
 * fix destdir patch


git-svn-id: svn://svn.openwrt.org/openwrt/packages@6705 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2007-03-26 04:23:10 +00:00
parent bd9920638a
commit d3e3236a50
3 changed files with 33 additions and 49 deletions

View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=privoxy PKG_NAME:=privoxy
PKG_VERSION:=3.0.3 PKG_VERSION:=3.0.3
PKG_RELEASE:=1 PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-stable-src.tar.gz
PKG_SOURCE_URL:=@SF/ijbswa PKG_SOURCE_URL:=@SF/ijbswa
@ -38,33 +38,12 @@ define Package/privoxy
endef endef
define Build/Configure define Build/Configure
(cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \ (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
autoheader && autoconf && \ autoheader && autoconf \
$(TARGET_CONFIGURE_OPTS) \ );
CFLAGS="$(strip $(TARGET_CFLAGS))" \ $(call Build/Configure/Default, \
CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \ --sysconfdir=/etc/privoxy \
LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \ )
./configure \
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
--program-prefix="" \
--program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
--datadir=/usr/share \
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
--libexecdir=/usr/lib \
--localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
$(DISABLE_NLS) \
--disable-static \
);
endef endef
define Build/Compile define Build/Compile
@ -76,12 +55,19 @@ define Build/Compile
install install
endef endef
define Package/privoxy/install define Package/privoxy/conffiles
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/privoxy $(1)/etc/init.d /etc/privoxy/config
/etc/privoxy/user.action
endef
define Package/privoxy/install
$(INSTALL_DIR) $(1)/usr/sbin
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/ $(CP) $(PKG_INSTALL_DIR)/usr/sbin/privoxy $(1)/usr/sbin/
$(CP) ./files/$(PKG_NAME).config $(1)/etc/privoxy/config $(INSTALL_DIR) $(1)/etc/privoxy
$(CP) $(PKG_BUILD_DIR)/default.filter $(1)/etc/privoxy/ $(CP) $(PKG_INSTALL_DIR)/etc/privoxy/* $(1)/etc/privoxy/
$(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME) $(INSTALL_CONF) ./files/privoxy.config $(1)/etc/privoxy/config
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/privoxy.init $(1)/etc/init.d/privoxy
endef endef
$(eval $(call BuildPackage,privoxy)) $(eval $(call BuildPackage,privoxy))

View File

@ -1,11 +1,15 @@
#!/bin/sh /etc/rc.common #!/bin/sh /etc/rc.common
# Copyright (C) 2006 OpenWrt.org # Copyright (C) 2006 OpenWrt.org
conf=/etc/privoxy/config
CFG_F=/etc/privoxy/config
RUN_D=/var/run
PID_F=$RUN_D/privoxy.pid
start() { start() {
/usr/sbin/privoxy $conf mkdir -p $RUN_D
/usr/sbin/privoxy --pidfile $PID_F $CFG_F
} }
stop() { stop() {
killall privoxy [ -f $PID_F ] && kill $(cat $PID_F)
} }

View File

@ -1,7 +1,7 @@
diff -Nur privoxy-3.0.3-stable/GNUmakefile.in privoxy-3.0.3-stable.patched/GNUmakefile.in diff -Nur privoxy-3.0.3-stable/GNUmakefile.in privoxy-3.0.3-stable.patched/GNUmakefile.in
--- privoxy-3.0.3-stable/GNUmakefile.in 2004-01-31 02:15:33.000000000 +0100 --- privoxy-3.0.3-stable/GNUmakefile.in 2004-01-31 02:15:33.000000000 +0100
+++ privoxy-3.0.3-stable.patched/GNUmakefile.in 2006-03-13 21:39:29.000000000 +0100 +++ privoxy-3.0.3-stable.patched/GNUmakefile.in 2006-03-13 21:39:29.000000000 +0100
@@ -55,17 +55,17 @@ @@ -55,15 +55,15 @@
USER = @USER@ USER = @USER@
GROUP = @GROUP@ GROUP = @GROUP@
@ -10,23 +10,17 @@ diff -Nur privoxy-3.0.3-stable/GNUmakefile.in privoxy-3.0.3-stable.patched/GNUma
-CONF_BASE = @sysconfdir@ -CONF_BASE = @sysconfdir@
-SBIN_DEST = @sbindir@ -SBIN_DEST = @sbindir@
-MAN_DIR = @mandir@ -MAN_DIR = @mandir@
-MAN_DEST = $(MAN_DIR)/man1
-SHARE_DEST = @datadir@
-DOC_DEST = $(SHARE_DEST)/doc/privoxy
-VAR_DEST = @localstatedir@
-LOGS_DEST = $(VAR_DEST)/log/privoxy
-PIDS_DEST = $(VAR_DEST)/run
+prefix = $(DESTDIR)@prefix@ +prefix = $(DESTDIR)@prefix@
+exec_prefix = $(DESTDIR)@exec_prefix@ +exec_prefix = $(DESTDIR)@exec_prefix@
+CONF_BASE = $(DESTDIR)@sysconfdir@ +CONF_BASE = $(DESTDIR)@sysconfdir@
+SBIN_DEST = $(DESTDIR)@sbindir@ +SBIN_DEST = $(DESTDIR)@sbindir@
+MAN_DIR = $(DESTDIR)@mandir@ +MAN_DIR = $(DESTDIR)@mandir@
+MAN_DEST = $(DESTDIR)$(MAN_DIR)/man1 MAN_DEST = $(MAN_DIR)/man1
-SHARE_DEST = @datadir@
+SHARE_DEST = $(DESTDIR)@datadir@ +SHARE_DEST = $(DESTDIR)@datadir@
+DOC_DEST = $(DESTDIR)$(SHARE_DEST)/doc/privoxy DOC_DEST = $(SHARE_DEST)/doc/privoxy
-VAR_DEST = @localstatedir@
+VAR_DEST = $(DESTDIR)@localstatedir@ +VAR_DEST = $(DESTDIR)@localstatedir@
+LOGS_DEST = $(DESTDIR)$(VAR_DEST)/log/privoxy LOGS_DEST = $(VAR_DEST)/log/privoxy
+PIDS_DEST = $(DESTDIR)$(VAR_DEST)/run PIDS_DEST = $(VAR_DEST)/run
# if $prefix = /usr/local then the default CONFDEST change from
# CONF_DEST = $(CONF_BASE) to CONF_DEST = $(CONF_BASE)/privoxy