Port ndisc to -ng
git-svn-id: svn://svn.openwrt.org/openwrt/packages@4477 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9ea60e575f
commit
d498ac940c
76
ipv6/ndisc/Makefile
Normal file
76
ipv6/ndisc/Makefile
Normal file
@ -0,0 +1,76 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2006 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
# $Id$
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=ndisc6
|
||||||
|
PKG_VERSION:=0.5.1
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_MD5SUM:=33487fe5505b195eb31468d88ba9ab56
|
||||||
|
|
||||||
|
PKG_SOURCE_URL:=http://people.via.ecp.fr/~rem/ndisc6/
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_CAT:=bzcat
|
||||||
|
|
||||||
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/ndisc
|
||||||
|
SECTION:=ipv6
|
||||||
|
CATEGORY:=IPv6
|
||||||
|
SUBMENU:=IPv6 discovery tools
|
||||||
|
TITLE:=IPv6 discovery tools
|
||||||
|
DESCRIPTION:=IPv6 discovery tools
|
||||||
|
URL:=http://people.via.ecp.fr/~rem/ndisc6/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/ndisc6
|
||||||
|
$(call Package/ndisc)
|
||||||
|
TITLE:=An ICMPv6 neighbour discovery tool
|
||||||
|
DESCRIPTION:=An ICMPv6 neighbour discovery tools
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/rdisc6
|
||||||
|
$(call Package/ndisc)
|
||||||
|
TITLE:=An ICMPv6 router discovery tool
|
||||||
|
DESCRIPTION:=An ICMPv6 router discovery tool
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/tcptraceroute6
|
||||||
|
$(call Package/ndisc)
|
||||||
|
TITLE:=A TCP/IPv6-based traceroute implementation
|
||||||
|
DESCRIPTION:=A TCP/IPv6-based traceroute implementation
|
||||||
|
endef
|
||||||
|
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
$(TARGET_CONFIGURE_OPTS) \
|
||||||
|
CFLAGS="$(TARGET_CFLAGS)" \
|
||||||
|
all
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/ndisc6/install
|
||||||
|
install -d -m0755 $(1)/usr/bin
|
||||||
|
install -m0755 $(PKG_BUILD_DIR)/ndisc6 $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/rdisc6/install
|
||||||
|
install -d -m0755 $(1)/usr/bin
|
||||||
|
install -m0755 $(PKG_BUILD_DIR)/rdisc6 $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/tcptraceroute6/install
|
||||||
|
install -d -m0755 $(1)/usr/bin
|
||||||
|
install -m0755 $(PKG_BUILD_DIR)/tcptraceroute6 $(1)/usr/bin/
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,ndisc6))
|
||||||
|
$(eval $(call BuildPackage,rdisc6))
|
||||||
|
$(eval $(call BuildPackage,tcptraceroute6))
|
22
ipv6/ndisc/patches/100-license.patch
Normal file
22
ipv6/ndisc/patches/100-license.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
diff -urN ndisc6.old/Makefile ndisc6.dev/Makefile
|
||||||
|
--- ndisc6.old/Makefile 2005-12-01 15:34:08.000000000 +0100
|
||||||
|
+++ ndisc6.dev/Makefile 2006-03-23 13:44:32.000000000 +0100
|
||||||
|
@@ -31,7 +31,7 @@
|
||||||
|
|
||||||
|
sbin_PROGRAMS = ndisc6 rdisc6 traceroute6
|
||||||
|
man8_MANS = $(sbin_PROGRAMS:%=%.8)
|
||||||
|
-DOC = COPYING INSTALL NEWS README
|
||||||
|
+DOC = INSTALL NEWS README
|
||||||
|
|
||||||
|
AM_CPPFLAGS = -DPACKAGE_VERSION=\"$(VERSION)\" $(CPPFLAGS)
|
||||||
|
ndisc6_CPPFLAGS = $(AM_CPPFLAGS)
|
||||||
|
@@ -52,9 +52,6 @@
|
||||||
|
tcptraceroute6: traceroute6
|
||||||
|
ln -sf traceroute6 $@
|
||||||
|
|
||||||
|
-COPYING: /usr/share/common-licenses/GPL-2
|
||||||
|
- ln -s $< $@
|
||||||
|
-
|
||||||
|
install: all install-man install-links
|
||||||
|
mkdir -p $(DESTDIR)$(bindir)
|
||||||
|
@for f in $(sbin_PROGRAMS); do \
|
Loading…
x
Reference in New Issue
Block a user