[package] remove libdb since there are no users of it and prefer libdb47
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18492 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
95ebc986e1
commit
d4e8e328af
@ -1,97 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2006-2009 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=db
|
|
||||||
PKG_VERSION:=4.2.52
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/db-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE:=db-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=ftp://ftp.sleepycat.com/releases/ \
|
|
||||||
http://downloads.sleepycat.com/
|
|
||||||
PKG_MD5SUM:=8b5cff6eb83972afdd8e0b821703c33c
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/libdb
|
|
||||||
SECTION:=libs
|
|
||||||
CATEGORY:=Libraries
|
|
||||||
DEPENDS:=+libxml2
|
|
||||||
TITLE:=Berkeley DB library
|
|
||||||
URL:=http://www.sleepycat.com/products/db.shtml
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libdb/description
|
|
||||||
Berkeley DB library.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
(cd $(PKG_BUILD_DIR)/build_unix; rm -f config.cache; \
|
|
||||||
$(TARGET_CONFIGURE_OPTS) \
|
|
||||||
CFLAGS="$(TARGET_CFLAGS)" \
|
|
||||||
CPPFLAGS="$(TARGET_CPPFLAGS)" \
|
|
||||||
LDFLAGS="$(TARGET_LDFLAGS)" \
|
|
||||||
../dist/configure \
|
|
||||||
--target=$(GNU_TARGET_NAME) \
|
|
||||||
--host=$(GNU_TARGET_NAME) \
|
|
||||||
--build=$(GNU_HOST_NAME) \
|
|
||||||
--program-prefix="" \
|
|
||||||
--program-suffix="" \
|
|
||||||
--prefix=/usr \
|
|
||||||
--exec-prefix=/usr \
|
|
||||||
--bindir=/usr/bin \
|
|
||||||
--datadir=/usr/share \
|
|
||||||
--includedir=/usr/include \
|
|
||||||
--infodir=/usr/share/info \
|
|
||||||
--libdir=/usr/lib \
|
|
||||||
--libexecdir=/usr/lib \
|
|
||||||
--localstatedir=/var \
|
|
||||||
--mandir=/usr/share/man \
|
|
||||||
--sbindir=/usr/sbin \
|
|
||||||
--sysconfdir=/etc \
|
|
||||||
$(DISABLE_NLS) \
|
|
||||||
$(DISABLE_LARGEFILE) \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--disable-java \
|
|
||||||
--enable-cxx \
|
|
||||||
--disable-posixmutexes \
|
|
||||||
--disable-uimutexes \
|
|
||||||
--disable-tcl \
|
|
||||||
--disable-rpc \
|
|
||||||
--enable-compat185 \
|
|
||||||
--enable-debug \
|
|
||||||
--enable-statistics \
|
|
||||||
--enable-replication \
|
|
||||||
--enable-cryptography \
|
|
||||||
);
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
|
||||||
|
|
||||||
define Build/Compile
|
|
||||||
rm -rf $(PKG_INSTALL_DIR)
|
|
||||||
mkdir -p $(PKG_INSTALL_DIR)
|
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR)/build_unix \
|
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" install
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/libdb/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb-*.so $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
mkdir -p $(1)/usr/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/db.h $(1)/usr/include/
|
|
||||||
mkdir -p $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libdb*.{a,so} $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,libdb))
|
|
@ -1,20 +0,0 @@
|
|||||||
--- db-4.2.52/dist/config.sub 2008-05-08 22:06:23.000000000 +0200
|
|
||||||
+++ db-4.2.52/dist/config.sub 2008-05-08 22:07:05.000000000 +0200
|
|
||||||
@@ -229,7 +229,7 @@
|
|
||||||
| alpha | alphaev[4-8] | alphaev56 | alphaev6[78] | alphapca5[67] \
|
|
||||||
| alpha64 | alpha64ev[4-8] | alpha64ev56 | alpha64ev6[78] | alpha64pca5[67] \
|
|
||||||
| am33_2.0 \
|
|
||||||
- | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr \
|
|
||||||
+ | arc | arm | arm[bl]e | arme[lb] | armv[2345] | armv[345][lb] | avr | avr32 \
|
|
||||||
| c4x | clipper \
|
|
||||||
| d10v | d30v | dlx | dsp16xx \
|
|
||||||
| fr30 | frv \
|
|
||||||
@@ -295,7 +295,7 @@
|
|
||||||
| alpha64-* | alpha64ev[4-8]-* | alpha64ev56-* | alpha64ev6[78]-* \
|
|
||||||
| alphapca5[67]-* | alpha64pca5[67]-* | arc-* \
|
|
||||||
| arm-* | armbe-* | armle-* | armeb-* | armv*-* \
|
|
||||||
- | avr-* \
|
|
||||||
+ | avr-* | avr32-* \
|
|
||||||
| bs2000-* \
|
|
||||||
| c[123]* | c30-* | [cjt]90-* | c4x-* | c54x-* | c55x-* | c6x-* \
|
|
||||||
| clipper-* | cydra-* \
|
|
Loading…
x
Reference in New Issue
Block a user