[packages] add darkice (closes: #8186, thanks to Artur Wronowski)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@28506 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
db8ef8033e
commit
d4fbfd2e0c
53
multimedia/darkice/Makefile
Normal file
53
multimedia/darkice/Makefile
Normal file
@ -0,0 +1,53 @@
|
||||
#
|
||||
# Copyright (C) 2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=darkice
|
||||
PKG_VERSION:=1.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://darkice.googlecode.com/files/
|
||||
PKG_MD5SUM:= 1804e63d42a9703d01fe378c9a77c473
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/darkice
|
||||
SECTION:=multimedia
|
||||
CATEGORY:=Multimedia
|
||||
SUBMENU:=Streaming
|
||||
TITLE:=DarkIce is a live audio streamer
|
||||
DEPENDS:=+lame +alsa-lib +libpthread +libstdcpp
|
||||
MAINTAINER:=Artur Wronowski <arteqw@gmail.com>
|
||||
endef
|
||||
|
||||
define Package/darkice/description
|
||||
DarkIce is a live audio streamer. It records audio from an audio interface (e.g. sound card), encodes it and sends it to a streaming server.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--with-lame \
|
||||
--without-aacplus \
|
||||
--without-alsa \
|
||||
--without-faac \
|
||||
--without-jack \
|
||||
--without-samplerate \
|
||||
--without-twolame \
|
||||
--without-vorbis \
|
||||
|
||||
define Package/darkice/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/darkice $(1)/usr/sbin/
|
||||
$(INSTALL_DIR) $(1)/etc
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/darkice.cfg $(1)/etc/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,darkice))
|
15
multimedia/darkice/patches/001-upstream_svn_r494.patch
Normal file
15
multimedia/darkice/patches/001-upstream_svn_r494.patch
Normal file
@ -0,0 +1,15 @@
|
||||
--- a/src/SerialUlaw.cpp
|
||||
+++ b/src/SerialUlaw.cpp
|
||||
@@ -40,6 +40,12 @@
|
||||
#include "config.h"
|
||||
#endif
|
||||
|
||||
+#ifdef HAVE_STDIO_H
|
||||
+#include <stdio.h>
|
||||
+#else
|
||||
+#error need stdio.h
|
||||
+#endif
|
||||
+
|
||||
#ifdef HAVE_UNISTD_H
|
||||
#include <unistd.h>
|
||||
#else
|
Loading…
x
Reference in New Issue
Block a user