[packages] mdnsresponder: update to 379.37
Signed-off-by: Markus Stenberg <markus.stenberg@iki.fi> git-svn-id: svn://svn.openwrt.org/openwrt/packages@38771 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
371ed13efd
commit
d6c307c854
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mDNSResponder
|
PKG_NAME:=mDNSResponder
|
||||||
PKG_VERSION:=214.3.2
|
PKG_VERSION:=379.37
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=mDNSResponder-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://opensource.apple.com/tarballs/mDNSResponder/
|
PKG_SOURCE_URL:=http://opensource.apple.com/tarballs/mDNSResponder/
|
||||||
PKG_MD5SUM:=05d39f40767ccece4b740c5afad14a23
|
PKG_MD5SUM:=dd557e1058b51ac2f29cd01d67be0145
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/mDNSResponder-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/mDNSResponder-$(PKG_VERSION)
|
||||||
|
|
||||||
|
@ -1,7 +1,6 @@
|
|||||||
diff -u --recursive mDNSResponder-214.3.2-vanilla/Clients/Makefile mDNSResponder-214.3.2/Clients/Makefile
|
--- a/Clients/Makefile
|
||||||
--- mDNSResponder-214.3.2-vanilla/Clients/Makefile 2010-10-15 08:38:44.817282399 -0500
|
+++ b/Clients/Makefile
|
||||||
+++ mDNSResponder-214.3.2/Clients/Makefile 2010-10-15 08:40:09.696672081 -0500
|
@@ -23,6 +23,8 @@
|
||||||
@@ -62,6 +62,8 @@
|
|
||||||
|
|
||||||
#############################################################################
|
#############################################################################
|
||||||
|
|
||||||
@ -10,7 +9,7 @@ diff -u --recursive mDNSResponder-214.3.2-vanilla/Clients/Makefile mDNSResponder
|
|||||||
# On OS X the dns_sd library functions are included in libSystem, which is implicitly linked with every executable
|
# On OS X the dns_sd library functions are included in libSystem, which is implicitly linked with every executable
|
||||||
# If /usr/lib/libSystem.dylib exists, then we're on OS X, so we don't need also to link the "dns_sd" shared library
|
# If /usr/lib/libSystem.dylib exists, then we're on OS X, so we don't need also to link the "dns_sd" shared library
|
||||||
ifneq "$(wildcard /usr/lib/libSystem.dylib)" ""
|
ifneq "$(wildcard /usr/lib/libSystem.dylib)" ""
|
||||||
@@ -81,10 +83,10 @@
|
@@ -42,10 +44,10 @@ build:
|
||||||
mkdir build
|
mkdir build
|
||||||
|
|
||||||
build/dns-sd: build dns-sd.c ClientCommon.c
|
build/dns-sd: build dns-sd.c ClientCommon.c
|
||||||
@ -23,10 +22,9 @@ diff -u --recursive mDNSResponder-214.3.2-vanilla/Clients/Makefile mDNSResponder
|
|||||||
|
|
||||||
# Note, we can make a 'fat' version of dns-sd using 'lipo', as shown below, but we
|
# Note, we can make a 'fat' version of dns-sd using 'lipo', as shown below, but we
|
||||||
# don't, because we don't want or need a 'fat' version of dns-sd, because it will
|
# don't, because we don't want or need a 'fat' version of dns-sd, because it will
|
||||||
diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSResponder-214.3.2/mDNSPosix/Makefile
|
--- a/mDNSPosix/Makefile
|
||||||
--- mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile 2010-10-15 08:38:44.798283212 -0500
|
+++ b/mDNSPosix/Makefile
|
||||||
+++ mDNSResponder-214.3.2/mDNSPosix/Makefile 2010-10-15 08:46:28.739548087 -0500
|
@@ -54,10 +54,11 @@ COREDIR = ../mDNSCore
|
||||||
@@ -316,10 +316,11 @@
|
|
||||||
SHAREDDIR ?= ../mDNSShared
|
SHAREDDIR ?= ../mDNSShared
|
||||||
JDK = /usr/jdk
|
JDK = /usr/jdk
|
||||||
|
|
||||||
@ -40,7 +38,7 @@ diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSRespond
|
|||||||
CP = cp
|
CP = cp
|
||||||
RM = rm
|
RM = rm
|
||||||
LN = ln -s -f
|
LN = ln -s -f
|
||||||
@@ -344,7 +345,7 @@
|
@@ -82,7 +83,7 @@ else
|
||||||
CFLAGS_DEBUG = -Os -DMDNS_DEBUGMSGS=0
|
CFLAGS_DEBUG = -Os -DMDNS_DEBUGMSGS=0
|
||||||
OBJDIR ?= objects/prod
|
OBJDIR ?= objects/prod
|
||||||
BUILDDIR ?= build/prod
|
BUILDDIR ?= build/prod
|
||||||
@ -49,7 +47,7 @@ diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSRespond
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
# Configure per-OS peculiarities
|
# Configure per-OS peculiarities
|
||||||
@@ -353,7 +354,7 @@
|
@@ -91,7 +92,7 @@ CFLAGS_DEBUG = -O0 -DMDNS_DEBUGMSGS=0
|
||||||
CFLAGS_OS = -DNOT_HAVE_DAEMON -DNOT_HAVE_SA_LEN -DNOT_HAVE_SOCKLEN_T -DNOT_HAVE_IF_NAMETOINDEX \
|
CFLAGS_OS = -DNOT_HAVE_DAEMON -DNOT_HAVE_SA_LEN -DNOT_HAVE_SOCKLEN_T -DNOT_HAVE_IF_NAMETOINDEX \
|
||||||
-DLOG_PERROR=0 -D_XPG4_2 -D__EXTENSIONS__ -DHAVE_BROKEN_RECVIF_NAME -DTARGET_OS_SOLARIS
|
-DLOG_PERROR=0 -D_XPG4_2 -D__EXTENSIONS__ -DHAVE_BROKEN_RECVIF_NAME -DTARGET_OS_SOLARIS
|
||||||
CC = gcc
|
CC = gcc
|
||||||
@ -58,17 +56,17 @@ diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSRespond
|
|||||||
LINKOPTS = -lsocket -lnsl -lresolv
|
LINKOPTS = -lsocket -lnsl -lresolv
|
||||||
JAVACFLAGS_OS += -I$(JDK)/include/solaris
|
JAVACFLAGS_OS += -I$(JDK)/include/solaris
|
||||||
ifneq ($(DEBUG),1)
|
ifneq ($(DEBUG),1)
|
||||||
@@ -404,7 +405,8 @@
|
@@ -147,7 +148,8 @@ CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp
|
||||||
CFLAGS_OS = -DHAVE_IPV6 -no-cpp-precomp -Werror -Wdeclaration-after-statement \
|
-D__MAC_OS_X_VERSION_MIN_REQUIRED=__MAC_OS_X_VERSION_10_4 \
|
||||||
-D__MAC_OS_X_VERSION_MIN_REQUIRED=__MAC_OS_X_VERSION_10_4 #-Wunreachable-code
|
-D__APPLE_USE_RFC_2292 #-Wunreachable-code
|
||||||
CC = @gcc-4.0
|
CC = gcc
|
||||||
-LD = $(CC) -dynamiclib
|
-LD = $(CC) -dynamiclib
|
||||||
+LD = $(CC)
|
+LD = $(CC)
|
||||||
+SOOPTS = -dynamiclib
|
+SOOPTS= -dynamiclib
|
||||||
LINKOPTS = -lSystem
|
LINKOPTS = -lSystem
|
||||||
LDSUFFIX = dylib
|
LDSUFFIX = dylib
|
||||||
JDK = /System/Library/Frameworks/JavaVM.framework/Home
|
JDK = /System/Library/Frameworks/JavaVM.framework/Home
|
||||||
@@ -426,8 +428,9 @@
|
@@ -169,8 +171,9 @@ NSSLIBFILE := $(NSSLIBNAME)-$(NSSVERSIO
|
||||||
NSSLINKNAME := $(NSSLIBNAME).so.2
|
NSSLINKNAME := $(NSSLIBNAME).so.2
|
||||||
NSSINSTPATH := /lib
|
NSSINSTPATH := /lib
|
||||||
|
|
||||||
@ -79,7 +77,7 @@ diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSRespond
|
|||||||
INSTBASE?=/usr
|
INSTBASE?=/usr
|
||||||
STARTUPSCRIPTNAME?=mdns
|
STARTUPSCRIPTNAME?=mdns
|
||||||
|
|
||||||
@@ -511,7 +514,7 @@
|
@@ -256,7 +259,7 @@ libdns_sd: setup $(BUILDDIR)/libdns_sd.$
|
||||||
CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o
|
CLIENTLIBOBJS = $(OBJDIR)/dnssd_clientlib.c.so.o $(OBJDIR)/dnssd_clientstub.c.so.o $(OBJDIR)/dnssd_ipc.c.so.o
|
||||||
|
|
||||||
$(BUILDDIR)/libdns_sd.$(LDSUFFIX): $(CLIENTLIBOBJS)
|
$(BUILDDIR)/libdns_sd.$(LDSUFFIX): $(CLIENTLIBOBJS)
|
||||||
@ -88,7 +86,7 @@ diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSRespond
|
|||||||
@$(STRIP) $@
|
@$(STRIP) $@
|
||||||
|
|
||||||
Clients: setup libdns_sd ../Clients/build/dns-sd
|
Clients: setup libdns_sd ../Clients/build/dns-sd
|
||||||
@@ -546,7 +549,7 @@
|
@@ -291,7 +294,7 @@ InstalledManPages: $(MANPATH)/man8/mdnsd
|
||||||
InstalledClients: $(INSTBASE)/bin/dns-sd
|
InstalledClients: $(INSTBASE)/bin/dns-sd
|
||||||
@echo $+ " installed"
|
@echo $+ " installed"
|
||||||
|
|
||||||
@ -97,7 +95,7 @@ diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSRespond
|
|||||||
@echo $+ " installed"
|
@echo $+ " installed"
|
||||||
|
|
||||||
# Note: If daemon already installed, we make sure it's stopped before overwriting it
|
# Note: If daemon already installed, we make sure it's stopped before overwriting it
|
||||||
@@ -601,19 +604,21 @@
|
@@ -346,19 +349,21 @@ $(INSTBASE)/bin/dns-sd: ../Clients/build
|
||||||
|
|
||||||
$(NSSINSTPATH)/$(NSSLINKNAME): $(NSSINSTPATH)/$(NSSLIBFILE)
|
$(NSSINSTPATH)/$(NSSLINKNAME): $(NSSINSTPATH)/$(NSSLIBFILE)
|
||||||
$(LN) $< $@
|
$(LN) $< $@
|
||||||
|
29
net/mdnsresponder/patches/002-newer-bison.patch
Normal file
29
net/mdnsresponder/patches/002-newer-bison.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- a/mDNSShared/dnsextd_parser.y
|
||||||
|
+++ b/mDNSShared/dnsextd_parser.y
|
||||||
|
@@ -15,6 +15,8 @@
|
||||||
|
* limitations under the License.
|
||||||
|
*/
|
||||||
|
|
||||||
|
+%parse-param { void *context }
|
||||||
|
+
|
||||||
|
%{
|
||||||
|
#include <stdio.h>
|
||||||
|
#include <stdlib.h>
|
||||||
|
@@ -23,7 +25,7 @@
|
||||||
|
#include "DebugServices.h"
|
||||||
|
#include "dnsextd.h"
|
||||||
|
|
||||||
|
-void yyerror( const char* error );
|
||||||
|
+void yyerror( void *context, const char* error );
|
||||||
|
int yylex(void);
|
||||||
|
|
||||||
|
|
||||||
|
@@ -378,7 +380,7 @@ int yywrap(void);
|
||||||
|
|
||||||
|
extern int yylineno;
|
||||||
|
|
||||||
|
-void yyerror( const char *str )
|
||||||
|
+void yyerror( void *context, const char *str )
|
||||||
|
{
|
||||||
|
fprintf( stderr,"%s:%d: error: %s\n", g_filename, yylineno, str );
|
||||||
|
}
|
@ -1,21 +0,0 @@
|
|||||||
diff -u --recursive mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile mDNSResponder-214.3.2/mDNSPosix/Makefile
|
|
||||||
--- mDNSResponder-214.3.2-vanilla/mDNSPosix/Makefile 2010-10-15 08:38:44.798283212 -0500
|
|
||||||
+++ mDNSResponder-214.3.2/mDNSPosix/Makefile 2010-10-15 08:48:27.334503432 -0500
|
|
||||||
@@ -361,12 +361,16 @@
|
|
||||||
endif
|
|
||||||
else
|
|
||||||
|
|
||||||
-ifeq ($(os),linux)
|
|
||||||
+# Any variant containing linux:
|
|
||||||
+ifeq ($(findstring linux,$(os)),linux)
|
|
||||||
CFLAGS_OS = -DNOT_HAVE_SA_LEN -DUSES_NETLINK -DHAVE_LINUX -DTARGET_OS_LINUX
|
|
||||||
FLEXFLAGS_OS = -l
|
|
||||||
JAVACFLAGS_OS += -I$(JDK)/include/linux
|
|
||||||
+# uClibc does not provide NSS, do not compile nss_mdns:
|
|
||||||
+ifneq ($(os),linux-uclibc)
|
|
||||||
OPTIONALTARG = nss_mdns
|
|
||||||
OPTINSTALL = InstalledNSS
|
|
||||||
+endif
|
|
||||||
else
|
|
||||||
|
|
||||||
ifeq ($(os),netbsd)
|
|
Loading…
x
Reference in New Issue
Block a user