libftdi: moved to github

git-svn-id: svn://svn.openwrt.org/openwrt/packages@41105 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
cyrus 2014-06-11 08:57:39 +00:00
parent 8f74f7cec7
commit d755e822d0
2 changed files with 0 additions and 63 deletions

View File

@ -1,52 +0,0 @@
#
# Copyright (C) 2011-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=libftdi
PKG_VERSION:=0.19
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.intra2net.com/en/developer/libftdi/download/
PKG_MD5SUM:=e6e25f33b4327b1b7aa1156947da45f3
PKG_INSTALL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
define Package/libftdi
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=+libusb-compat
TITLE:=library to talk to FTDI chips
URL:=http://www.intra2net.com/en/developer/libftdi/
endef
define Package/libftdi/description
libFTDI - FTDI USB driver with bitbang mode
libFTDI is an open source library to talk to FTDI chips: FT232BM, FT245BM, FT2232C, FT2232H, FT4232H, FT2232D and FT245R, including the popular bitbang mode.
The library is linked with your program in userspace, no kernel driver required.
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/include/libftdi/ftdi.h $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libftdi.{a,so} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libftdi.so* $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libftdi.pc $(1)/usr/lib/pkgconfig/libftdi.pc
endef
define Package/libftdi/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libftdi.so.* $(1)/usr/lib/
endef
$(eval $(call BuildPackage,libftdi))

View File

@ -1,11 +0,0 @@
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -43,7 +43,7 @@ IF(CMAKE_SIZEOF_VOID_P EQUAL 4)
SET(LIB_SUFFIX "")
SET(PACK_ARCH "")
ELSE(CMAKE_SIZEOF_VOID_P EQUAL 8)
- SET(LIB_SUFFIX 64)
+ SET(LIB_SUFFIX "")
SET(PACK_ARCH .x86_64)
endif(CMAKE_SIZEOF_VOID_P EQUAL 4)