[package] update keepalived to 1.1.17 (#5415)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16571 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ccd909f9b3
commit
d7a9de2b41
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=keepalived
|
PKG_NAME:=keepalived
|
||||||
PKG_VERSION:=1.1.15
|
PKG_VERSION:=1.1.17
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:= http://www.keepalived.org/software
|
PKG_SOURCE_URL:= http://www.keepalived.org/software
|
||||||
PKG_MD5SUM:=4c93f5d8b6bfabe84b02828a5bbb7aa0
|
PKG_MD5SUM:=324ef61a9eed389679f0a05edd1d1323
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
@ -60,11 +60,11 @@ endef
|
|||||||
|
|
||||||
define Package/keepalived/install
|
define Package/keepalived/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/keepalived $(1)/usr/sbin/
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/genhash $(1)/usr/bin/
|
||||||
$(INSTALL_DIR) $(1)/etc/keepalived
|
$(INSTALL_DIR) $(1)/etc/keepalived
|
||||||
$(CP) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/keepalived.conf
|
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/keepalived/keepalived.conf $(1)/etc/keepalived/
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
$(INSTALL_BIN) ./files/keepalived.init $(1)/etc/init.d/keepalived
|
$(INSTALL_BIN) ./files/keepalived.init $(1)/etc/init.d/keepalived
|
||||||
endef
|
endef
|
||||||
|
@ -1,12 +0,0 @@
|
|||||||
diff -ur keepalived-1.1.15/configure keepalived-1.1.15.mod/configure
|
|
||||||
--- keepalived-1.1.15/configure 2006-10-10 05:20:35.000000000 -0400
|
|
||||||
+++ keepalived-1.1.15.mod/configure 2009-05-08 04:52:13.000000000 -0400
|
|
||||||
@@ -3928,7 +3928,7 @@
|
|
||||||
|
|
||||||
|
|
||||||
|
|
||||||
-VRRP_SUPPORT="_WITHOUT_VRRP_"
|
|
||||||
+VRRP_SUPPORT="_WITH_VRRP_"
|
|
||||||
if test "$enable_vrrp" != "no"; then
|
|
||||||
echo "$as_me:$LINENO: checking for kernel netlink support" >&5
|
|
||||||
echo $ECHO_N "checking for kernel netlink support... $ECHO_C" >&6
|
|
Loading…
x
Reference in New Issue
Block a user