[packages] sox: Bump revision
git-svn-id: svn://svn.openwrt.org/openwrt/packages@33379 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
706c091e76
commit
d959899848
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sox
|
||||
PKG_VERSION:=14.0.1
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=14.4.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/sox
|
||||
PKG_MD5SUM:=6c95af60b20b9655531bf3162c0be937
|
||||
PKG_MD5SUM:=813807c6d6fcd4b0af5c995e61f46687
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
|
||||
@ -30,7 +30,7 @@ TARGET_LDFLAGS+= \
|
||||
define Package/sox
|
||||
SECTION:=sound
|
||||
CATEGORY:=Sound
|
||||
DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag +libvorbis +libvorbisidec +libgsm +alsa-lib +libsndfile
|
||||
DEPENDS:=+BUILD_PATENTED:lame-lib +BUILD_PATENTED:libmad +BUILD_PATENTED:libid3tag +libvorbis +libvorbisidec +libgsm +alsa-lib +libsndfile +libflac +ffmpeg +libmagic +libpng
|
||||
TITLE:=Sox is a general purpose sound converter/player/recorder
|
||||
URL:=http://sox.sourceforge.net/
|
||||
endef
|
||||
@ -51,8 +51,8 @@ define Build/Configure
|
||||
--disable-libao \
|
||||
--without-libltdl \
|
||||
--with-ogg \
|
||||
--without-flac \
|
||||
--without-ffmpeg \
|
||||
--with-flac \
|
||||
--with-ffmpeg \
|
||||
--without-amr-wb \
|
||||
--without-amr-nb \
|
||||
--without-samplerate \
|
||||
@ -63,11 +63,25 @@ define Build/Configure
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/InstallDev
|
||||
$(INSTALL_DIR) $(1)/usr/include
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/include \
|
||||
$(1)/usr/include/
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(CP) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/libsox.{a,so*,la} \
|
||||
$(1)/usr/lib/
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
|
||||
$(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
define Package/sox/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_DIR) $(1)/usr/lib
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/{play,rec,sox} $(1)/usr/bin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/{libsfx.so*,libsox.so*} $(1)/usr/lib/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libsox.so* $(1)/usr/lib/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,sox))
|
||||
|
@ -1,30 +1,22 @@
|
||||
diff -urN sox-14.0.1/src/Makefile.am sox-14.0.1.new/src/Makefile.am
|
||||
--- sox-14.0.1/src/Makefile.am 2008-01-14 04:40:59.000000000 +0100
|
||||
+++ sox-14.0.1.new/src/Makefile.am 2008-07-14 14:14:37.000000000 +0200
|
||||
@@ -288,10 +288,9 @@
|
||||
--- a/src/Makefile.am
|
||||
+++ b/src/Makefile.am
|
||||
@@ -144,7 +144,7 @@ EXTRA_DIST = monkey.wav optional-fmts.am
|
||||
CMakeLists.txt soxconfig.h.cmake \
|
||||
tests.sh testall.sh tests.bat testall.bat test-comments
|
||||
|
||||
EXTRA_DIST = tests.sh testall.sh tests.bat testall.bat monkey.au monkey.wav sox_sample_test.c amr-wb-test CMakeLists.txt soxstdint.h.cmake soxconfig.h.cmake example1.c
|
||||
|
||||
-all: sox$(EXEEXT) play rec sox_sample_test$(EXEEXT) example1$(EXEEXT)
|
||||
-all: sox$(EXEEXT) play rec soxi sox_sample_test$(EXEEXT) example0$(EXEEXT) example1$(EXEEXT) example2$(EXEEXT) example3$(EXEEXT) example4$(EXEEXT) example5$(EXEEXT)
|
||||
+all: sox$(EXEEXT) play rec
|
||||
|
||||
play rec: sox$(EXEEXT)
|
||||
- ./sox --help > /dev/null
|
||||
test -f .libs/lt-sox && ( $(RM) $@ && $(LN_S) .libs/lt-sox $@ ) || $(LN_S) sox$(EXEEXT) $@
|
||||
|
||||
install-exec-hook:
|
||||
diff -urN sox-14.0.1/src/Makefile.in sox-14.0.1.new/src/Makefile.in
|
||||
--- sox-14.0.1/src/Makefile.in 2008-01-28 23:47:49.000000000 +0100
|
||||
+++ sox-14.0.1.new/src/Makefile.in 2008-07-14 14:15:12.000000000 +0200
|
||||
@@ -2426,10 +2426,9 @@
|
||||
uninstall-libLTLIBRARIES uninstall-pkglibLTLIBRARIES
|
||||
if test "$(PLAYRECLINKS)" = "yes"; then \
|
||||
--- a/src/Makefile.in
|
||||
+++ b/src/Makefile.in
|
||||
@@ -2849,7 +2849,7 @@ uninstall-am: uninstall-binPROGRAMS unin
|
||||
uninstall-pkglibLTLIBRARIES
|
||||
|
||||
|
||||
-all: sox$(EXEEXT) play rec sox_sample_test$(EXEEXT) example1$(EXEEXT)
|
||||
+all: sox$(EXEEXT) play rec
|
||||
-all: sox$(EXEEXT) play rec soxi sox_sample_test$(EXEEXT) example0$(EXEEXT) example1$(EXEEXT) example2$(EXEEXT) example3$(EXEEXT) example4$(EXEEXT) example5$(EXEEXT)
|
||||
+all: sox$(EXEEXT) play rec
|
||||
|
||||
play rec: sox$(EXEEXT)
|
||||
- ./sox --help > /dev/null
|
||||
test -f .libs/lt-sox && ( $(RM) $@ && $(LN_S) .libs/lt-sox $@ ) || $(LN_S) sox$(EXEEXT) $@
|
||||
|
||||
install-exec-hook:
|
||||
if test "$(PLAYRECLINKS)" = "yes"; then \
|
||||
|
@ -1,26 +0,0 @@
|
||||
diff -ruN sox-14.0.1.orig/src/sox.c sox-14.0.1/src/sox.c
|
||||
--- sox-14.0.1.orig/src/sox.c 2008-01-28 17:47:19.000000000 -0500
|
||||
+++ sox-14.0.1/src/sox.c 2008-12-01 05:49:29.000000000 -0500
|
||||
@@ -62,6 +62,7 @@
|
||||
#define TIME_FRAC 1e3
|
||||
#endif
|
||||
|
||||
+#include <linux/version.h>
|
||||
|
||||
/* argv[0] options */
|
||||
|
||||
@@ -377,7 +378,13 @@
|
||||
if (sox_find_format("ossdsp", sox_false))
|
||||
{
|
||||
f->filetype = "ossdsp";
|
||||
+
|
||||
+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0)
|
||||
+ f->filename = xstrdup("/dev/sound/dsp");
|
||||
+#else
|
||||
f->filename = xstrdup("/dev/dsp");
|
||||
+#endif
|
||||
+
|
||||
return;
|
||||
}
|
||||
#endif
|
||||
|
20
sound/sox/patches/010-fix_uclibc_build_issue.patch
Normal file
20
sound/sox/patches/010-fix_uclibc_build_issue.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- a/src/formats.c
|
||||
+++ b/src/formats.c
|
||||
@@ -408,7 +408,7 @@ static void UNUSED rewind_pipe(FILE * fp
|
||||
#if defined _FSTDIO || defined _NEWLIB_VERSION || defined __APPLE__
|
||||
fp->_p -= AUTO_DETECT_SIZE;
|
||||
fp->_r += AUTO_DETECT_SIZE;
|
||||
-#elif defined __GLIBC__
|
||||
+#elif defined __GLIBC__ && ! defined __UCLIBC__
|
||||
fp->_IO_read_ptr = fp->_IO_read_base;
|
||||
#elif defined _MSC_VER || defined __MINGW_H || defined _ISO_STDIO_ISO_H
|
||||
fp->_ptr = fp->_base;
|
||||
@@ -416,7 +416,7 @@ static void UNUSED rewind_pipe(FILE * fp
|
||||
/* To fix this #error, either simply remove the #error line and live without
|
||||
* file-type detection with pipes, or add support for your compiler in the
|
||||
* lines above. Test with cat monkey.au | ./sox --info - */
|
||||
- #error FIX NEEDED HERE
|
||||
+/* #error FIX NEEDED HERE */
|
||||
#define NO_REWIND_PIPE
|
||||
(void)fp;
|
||||
#endif
|
Loading…
x
Reference in New Issue
Block a user