[package] update btrfs-progs to 0.19, patch by Benjamin Cama

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20313 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2010-03-20 10:29:31 +00:00
parent 5d5bd183a8
commit d959e9b5ff
3 changed files with 20 additions and 10 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=btrfs-progs
PKG_VERSION:=0.18
PKG_VERSION:=0.19
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.kernel.org/pub/linux/kernel/people/mason/btrfs/
PKG_MD5SUM:=1dfe59152a558eb2f79a4c398de6c4ef
PKG_MD5SUM:=69e29ecd922e3f9dcb74a3a8f80b4f68
include $(INCLUDE_DIR)/package.mk
@ -32,8 +32,7 @@ define Package/btrfs-progs/description
GPL and open for contribution from anyone.
endef
progs = btrfsctl btrfsck mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol \
btrfstune btrfs-image
progs = btrfsctl mkfs.btrfs btrfs-debug-tree btrfs-show btrfs-vol btrfsck
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
@ -48,6 +47,8 @@ endef
define Package/btrfs-progs/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(addprefix $(PKG_INSTALL_DIR)/usr/bin/, $(progs)) $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/btrfs-scan.init $(1)/etc/init.d/btrfs-scan
endef
$(eval $(call BuildPackage,btrfs-progs))

View File

@ -0,0 +1,9 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2009 OpenWrt.org
START=19
start() {
grep -q btrfs /proc/modules && /usr/bin/btrfsctl -a
}

View File

@ -1,5 +1,5 @@
diff --git a/Makefile b/Makefile
index 3349079..cf5392f 100644
index 8097b5a..63a734b 100644
--- a/Makefile
+++ b/Makefile
@@ -36,37 +36,37 @@ version:
@ -17,9 +17,9 @@ index 3349079..cf5392f 100644
- gcc $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
+ $(CC) $(CFLAGS) -o btrfs-show btrfs-show.o $(objects) $(LDFLAGS) $(LIBS)
btrfsck: $(objects) btrfsck.o bit-radix.o
- gcc $(CFLAGS) -o btrfsck btrfsck.o $(objects) bit-radix.o $(LDFLAGS) $(LIBS)
+ $(CC) $(CFLAGS) -o btrfsck btrfsck.o $(objects) bit-radix.o $(LDFLAGS) $(LIBS)
btrfsck: $(objects) btrfsck.o
- gcc $(CFLAGS) -o btrfsck btrfsck.o $(objects) $(LDFLAGS) $(LIBS)
+ $(CC) $(CFLAGS) -o btrfsck btrfsck.o $(objects) $(LDFLAGS) $(LIBS)
mkfs.btrfs: $(objects) mkfs.o
- gcc $(CFLAGS) -o mkfs.btrfs $(objects) mkfs.o $(LDFLAGS) $(LIBS)
@ -49,5 +49,5 @@ index 3349079..cf5392f 100644
- gcc $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
+ $(CC) $(CFLAGS) -o btrfs-convert $(objects) convert.o -lext2fs $(LDFLAGS) $(LIBS)
clean :
rm -f $(progs) cscope.out *.o .*.d btrfs-convert
manpages:
cd man; make