[packages] fix endianess issue in netcat

git-svn-id: svn://svn.openwrt.org/openwrt/packages@14427 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2009-02-07 02:33:24 +00:00
parent 4ab3a8d0a6
commit d9b0b29261
2 changed files with 23 additions and 1 deletions

View File

@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=netcat
PKG_VERSION:=0.7.1
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/$(PKG_NAME)

View File

@ -0,0 +1,22 @@
Index: netcat-0.7.1/src/flagset.c
===================================================================
--- netcat-0.7.1.orig/src/flagset.c 2009-02-06 19:56:01.000000000 +0100
+++ netcat-0.7.1/src/flagset.c 2009-02-06 19:56:13.000000000 +0100
@@ -134,7 +134,7 @@
int netcat_flag_count(void)
{
- register char c;
+ register unsigned char c;
register int i;
int ret = 0;
@@ -154,7 +154,7 @@
Assumed that the bit number 1 is the sign, and that we will shift the
bit 1 (or the bit that takes its place later) until the the most right,
WHY it has to keep the wrong sign? */
- ret -= (c >> 7);
+ ret += (c >> 7);
c <<= 1;
}
}