[packages] luaexpat: fix compile error triggered by cs toolchain
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18192 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
0a06c868ed
commit
d9d754c950
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=luaexpat
|
||||
PKG_VERSION:=1.1
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://luaforge.net/frs/download.php/2469
|
||||
@ -41,7 +41,7 @@ define Build/Compile
|
||||
LUA_LIBDIR="$(STAGING_DIR)/usr/lib/" \
|
||||
COMPAT_DIR="$(PKG_BUILD_DIR)/compat-5.1r5" \
|
||||
LIB_OPTION="-shared $(TARGET_LDFLAGS)" \
|
||||
CC="$(TARGET_CC) $(TARGET_CFLAGS)" \
|
||||
CC="$(TARGET_CC) $(TARGET_CFLAGS) -std=c99" \
|
||||
LD="$(TARGET_CROSS)ld -shared"
|
||||
endef
|
||||
|
||||
|
10
lang/luaexpat/patches/001-compile-fix.patch
Normal file
10
lang/luaexpat/patches/001-compile-fix.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/config
|
||||
+++ b/config
|
||||
@@ -31,6 +31,6 @@
|
||||
-Wshadow \
|
||||
-Wwrite-strings
|
||||
|
||||
-CFLAGS = $(CWARNS) -ansi -O2 -I$(LUA_INC) \
|
||||
+CFLAGS = $(CWARNS) -O2 -I$(LUA_INC) \
|
||||
-I$(COMPAT_DIR) -I$(EXPAT_INC)
|
||||
CC = gcc
|
Loading…
x
Reference in New Issue
Block a user