add pymysql (MySQL-Python) (closes: #2230)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@9045 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
104fdbff08
commit
da092e1e3a
45
lang/pymysql/Makefile
Normal file
45
lang/pymysql/Makefile
Normal file
@ -0,0 +1,45 @@
|
||||
#
|
||||
# Copyright (C) 2007 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=MySQL-python
|
||||
PKG_VERSION:=1.2.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/mysql-python
|
||||
PKG_MD5SUM:=532268f02870bea18c1d465e88afff30
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
include ../python/python-package.mk
|
||||
|
||||
define PyPackage/pymysql
|
||||
TITLE:=MySQL database adapter for Python
|
||||
URL=http://mysql-python.sourceforge.net/
|
||||
DEPENDS+= +libmysqlclient
|
||||
endef
|
||||
|
||||
define PyPackage/pymysql/description
|
||||
MySQLdb is an thread-compatible interface to the popular MySQL database
|
||||
server that provides the Python database API.
|
||||
endef
|
||||
|
||||
define PyPackage/pymysql/filespec
|
||||
+|$(PYTHON_PKG_DIR)/_mysql.so
|
||||
+|$(PYTHON_PKG_DIR)/_mysql_exceptions.py*
|
||||
+|$(PYTHON_PKG_DIR)/MySQLdb
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/PyMod,., \
|
||||
install --prefix="$(PKG_INSTALL_DIR)/usr", \
|
||||
)
|
||||
endef
|
||||
|
||||
$(eval $(call PyPackage,pymysql))
|
12
lang/pymysql/patches/000-setup.patch
Normal file
12
lang/pymysql/patches/000-setup.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- MySQL-python-1.2.2/setup.py 2007-02-25 04:37:12.000000000 +0100
|
||||
+++ MySQL-python-1.2.2/setup.py 2007-08-15 12:23:18.000000000 +0200
|
||||
@@ -2,8 +2,7 @@
|
||||
|
||||
import os
|
||||
import sys
|
||||
-import ez_setup; ez_setup.use_setuptools()
|
||||
-from setuptools import setup, Extension
|
||||
+from distutils.core import setup, Extension
|
||||
|
||||
if sys.version_info < (2, 3):
|
||||
raise Error, "Python-2.3 or newer is required"
|
11
lang/pymysql/patches/010-threadsafe.patch
Normal file
11
lang/pymysql/patches/010-threadsafe.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- MySQL-python-1.2.2/site_orig.cfg 2007-08-15 12:58:40.000000000 +0200
|
||||
+++ MySQL-python-1.2.2/site.cfg 2007-08-15 12:58:49.000000000 +0200
|
||||
@@ -4,7 +4,7 @@
|
||||
# static: link against a static library (probably required for embedded)
|
||||
|
||||
embedded = False
|
||||
-threadsafe = True
|
||||
+threadsafe = False
|
||||
static = False
|
||||
|
||||
# The path to mysql_config.
|
Loading…
x
Reference in New Issue
Block a user