update freeradius to 1.0.6 (closes: #1331), rename patches to match our naming convention, available dictionnaries are now handled from the Makefile (no need for a dict patch anymore)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@6996 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
nico 2007-04-18 01:06:04 +00:00
parent 01108f8d7c
commit dac55c4f05
11 changed files with 6318 additions and 2445 deletions

View File

@ -9,14 +9,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=freeradius
PKG_VERSION:=1.1.2
PKG_VERSION:=1.1.6
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.freeradius.org/pub/radius/ \
http://freeradius.portal-to-web.de/ \
ftp://ftp.uk.freeradius.org/pub/radius/
PKG_MD5SUM:=6649ac5f9666b4a8cd55a837068ca61e
PKG_MD5SUM:=
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
@ -191,12 +191,10 @@ define Package/freeradius-utils
TITLE:=Misc. client utilities
endef
PKG_CONFIGURE_OPTIONS:= \
PKG_CONFIGURE_ARGS:= \
--enable-shared \
--disable-static \
--disable-ltdl-install \
--with-ltdl-include="$(STAGING_DIR)/usr/include" \
--with-ltdl-lib="$(STAGING_DIR)/usr/lib" \
--disable-developer \
--with-openssl-includes="$(STAGING_DIR)/usr/include" \
--with-openssl-libraries="$(STAGING_DIR)/usr/lib" \
--enable-strict-dependencies \
@ -221,8 +219,10 @@ PKG_CONFIGURE_OPTIONS:= \
--without-rlm_smb \
--with-rlm_sql \
--with-rlm_sqlcounter \
--without-rlm_sqlhpwippool \
--without-rlm_sqlippool \
--without-rlm_sql_db2 \
--without-rlm_sql_firebird \
--without-rlm_sql_freetds \
--without-rlm_sql_iodbc \
--without-rlm_sql_oracle \
@ -234,63 +234,63 @@ PKG_CONFIGURE_OPTIONS:= \
PKG_DICTIONARIES:= \
freeradius freeradius.internal \
rfc2865 rfc2866 rfc2867 rfc2868 rfc2869 rfc3162 rfc3576 rfc3580 \
rfc4372 rfc4675 rfc4679 \
microsoft \
wispr \
ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-ldap),)
PKG_CONFIGURE_LIBS+= -lcrypto -lssl
PKG_CONFIGURE_OPTIONS+= \
PKG_CONFIGURE_ARGS+= \
--with-rlm_ldap-include-dir="$(STAGING_DIR)/usr/include" \
--with-rlm_ldap-lib-dir="$(STAGING_DIR)/usr/lib"
PKG_CONFIGURE_LIBS+= -lcrypto -lssl
else
PKG_CONFIGURE_OPTIONS+= --without-rlm_ldap
PKG_CONFIGURE_ARGS+= --without-rlm_ldap
endif
ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-sql-mysql),)
PKG_CONFIGURE_LIBS+= -lz
PKG_CONFIGURE_OPTIONS+= \
PKG_CONFIGURE_ARGS+= \
--with-mysql-include-dir="$(STAGING_DIR)/usr/include" \
--with-mysql-lib-dir="$(STAGING_DIR)/usr/lib/mysql" \
--without-threads
PKG_CONFIGURE_LIBS+= -lz
else
PKG_CONFIGURE_OPTIONS+= --without-rlm_sql_mysql
PKG_CONFIGURE_ARGS+= --without-rlm_sql_mysql
endif
ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-sql-pgsql),)
PKG_CONFIGURE_OPTIONS+= \
PKG_CONFIGURE_ARGS+= \
--with-rlm_sql_postgresql-include-dir="$(STAGING_DIR)/usr/include" \
--with-rlm_sql_postgresql-lib-dir="$(STAGING_DIR)/usr/lib"
else
PKG_CONFIGURE_OPTIONS+= --without-rlm_sql_postgresql
PKG_CONFIGURE_ARGS+= --without-rlm_sql_postgresql
endif
ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-eap-peap),)
PKG_CONFIGURE_OPTIONS+= --with-rlm_eap_peap
PKG_CONFIGURE_ARGS+= --with-rlm_eap_peap
else
PKG_CONFIGURE_OPTIONS+= --without-rlm_eap_peap
PKG_CONFIGURE_ARGS+= --without-rlm_eap_peap
endif
ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-eap-tls),)
PKG_CONFIGURE_OPTIONS+= --with-rlm_eap_tls
PKG_CONFIGURE_ARGS+= --with-rlm_eap_tls
else
PKG_CONFIGURE_OPTIONS+= --without-rlm_eap_tls
PKG_CONFIGURE_ARGS+= --without-rlm_eap_tls
endif
ifneq ($(SDK)$(CONFIG_PACKAGE_freeradius-mod-eap-ttls),)
PKG_CONFIGURE_OPTIONS+= --with-rlm_eap_ttls
PKG_CONFIGURE_ARGS+= --with-rlm_eap_ttls
else
PKG_CONFIGURE_OPTIONS+= --without-rlm_eap_ttls
PKG_CONFIGURE_ARGS+= --without-rlm_eap_ttls
endif
define Build/Configure
$(call Build/Configure/Default, \
--libdir=/usr/lib/freeradius \
--libexecdir=/usr/lib/freeradius \
$(PKG_CONFIGURE_OPTIONS) \
$(PKG_CONFIGURE_ARGS) \
, \
LDFLAGS="$$$$LDFLAGS -L$(PKG_INSTALL_DIR)/usr/lib/freeradius" \
LIBS="$(PKG_CONFIGURE_LIBS)" \
sys_lib_search_path_spec="$(STAGING_DIR)/usr/lib $(STAGING_DIR)/lib" \
MYSQL_CONFIG="no" \
)
endef
@ -309,8 +309,10 @@ define Package/freeradius/install
done
$(INSTALL_DIR) $(1)/usr/share/freeradius
$(CP) $(PKG_INSTALL_DIR)/usr/share/freeradius/dictionary $(1)/usr/share/freeradius/
$(SED) "s,^\(\$$$$INCLUDE\),#\1,g" $(1)/usr/share/freeradius/dictionary
for f in $(PKG_DICTIONARIES); do \
$(CP) $(PKG_INSTALL_DIR)/usr/share/freeradius/dictionary.$$$${f} $(1)/usr/share/freeradius/ ; \
$(SED) "s,^#\(\$$$$INCLUDE dictionary\.$$$${f}\),\1,g" $(1)/usr/share/freeradius/dictionary ; \
done
$(INSTALL_DIR) $(1)/usr/lib/freeradius
$(CP) $(PKG_INSTALL_DIR)/usr/lib/freeradius/libradius{,-*}.so $(1)/usr/lib/

View File

@ -8,8 +8,8 @@ PID_F=$RUN_D/radiusd.pid
start() {
[ -f $DEFAULT ] && . $DEFAULT
[ -d $LOG_D ] || mkdir -p $LOG_D
[ -d $RUN_D ] || mkdir -p $RUN_D
mkdir -p $LOG_D
mkdir -p $RUN_D
radiusd $OPTIONS
}

View File

@ -1,151 +0,0 @@
diff -ruN freeradius-1.1.2-old/share/dictionary freeradius-1.1.2-new/share/dictionary
--- freeradius-1.1.2-old/share/dictionary 2006-05-10 18:53:15.000000000 +0200
+++ freeradius-1.1.2-new/share/dictionary 2006-06-02 00:39:45.000000000 +0200
@@ -52,7 +52,7 @@
# this directive to the end of this file if you want to see the
# old names in the logfiles, INSTEAD OF the new names.
#
-$INCLUDE dictionary.compat
+#$INCLUDE dictionary.compat
#
# Include the RFC dictionaries next.
@@ -73,76 +73,76 @@
#
# Include vendor dictionaries after the standard ones.
#
-$INCLUDE dictionary.3com
-$INCLUDE dictionary.3gpp
-$INCLUDE dictionary.3gpp2
-$INCLUDE dictionary.acc
-$INCLUDE dictionary.airespace
-$INCLUDE dictionary.alcatel
-$INCLUDE dictionary.alteon
-$INCLUDE dictionary.aruba
-$INCLUDE dictionary.ascend
-$INCLUDE dictionary.bay
-$INCLUDE dictionary.bintec
-$INCLUDE dictionary.cablelabs
-$INCLUDE dictionary.cabletron
-$INCLUDE dictionary.cisco
+#$INCLUDE dictionary.3com
+#$INCLUDE dictionary.3gpp
+#$INCLUDE dictionary.3gpp2
+#$INCLUDE dictionary.acc
+#$INCLUDE dictionary.airespace
+#$INCLUDE dictionary.alcatel
+#$INCLUDE dictionary.alteon
+#$INCLUDE dictionary.aruba
+#$INCLUDE dictionary.ascend
+#$INCLUDE dictionary.bay
+#$INCLUDE dictionary.bintec
+#$INCLUDE dictionary.cablelabs
+#$INCLUDE dictionary.cabletron
+#$INCLUDE dictionary.cisco
#
# The Cisco VPN300 dictionary is the same as the altiga one.
# You shouldn't use both at the same time.
#
#$INCLUDE dictionary.cisco.vpn3000
-$INCLUDE dictionary.cisco.vpn5000
-$INCLUDE dictionary.cisco.bbsm
-$INCLUDE dictionary.colubris
-$INCLUDE dictionary.cosine
-$INCLUDE dictionary.digium
-$INCLUDE dictionary.epygi
-$INCLUDE dictionary.erx
-$INCLUDE dictionary.ericsson
-$INCLUDE dictionary.extreme
+#$INCLUDE dictionary.cisco.vpn5000
+#$INCLUDE dictionary.cisco.bbsm
+#$INCLUDE dictionary.colubris
+#$INCLUDE dictionary.cosine
+#$INCLUDE dictionary.digium
+#$INCLUDE dictionary.epygi
+#$INCLUDE dictionary.erx
+#$INCLUDE dictionary.ericsson
+#$INCLUDE dictionary.extreme
$INCLUDE dictionary.freeradius
-$INCLUDE dictionary.fortinet
-$INCLUDE dictionary.foundry
-$INCLUDE dictionary.gandalf
-$INCLUDE dictionary.gemtek
-$INCLUDE dictionary.issanni
-$INCLUDE dictionary.itk
-$INCLUDE dictionary.ipunplugged
-$INCLUDE dictionary.juniper
-$INCLUDE dictionary.karlnet
-$INCLUDE dictionary.livingston
-$INCLUDE dictionary.localweb
-$INCLUDE dictionary.lucent
-$INCLUDE dictionary.hp
+#$INCLUDE dictionary.fortinet
+#$INCLUDE dictionary.foundry
+#$INCLUDE dictionary.gandalf
+#$INCLUDE dictionary.gemtek
+#$INCLUDE dictionary.issanni
+#$INCLUDE dictionary.itk
+#$INCLUDE dictionary.ipunplugged
+#$INCLUDE dictionary.juniper
+#$INCLUDE dictionary.karlnet
+#$INCLUDE dictionary.livingston
+#$INCLUDE dictionary.localweb
+#$INCLUDE dictionary.lucent
+#$INCLUDE dictionary.hp
$INCLUDE dictionary.microsoft
-$INCLUDE dictionary.mikrotik
-$INCLUDE dictionary.navini
-$INCLUDE dictionary.netscreen
-$INCLUDE dictionary.ntua
-$INCLUDE dictionary.nomadix
-$INCLUDE dictionary.nortel
-$INCLUDE dictionary.packeteer
-$INCLUDE dictionary.propel
-$INCLUDE dictionary.quintum
-$INCLUDE dictionary.redback
-$INCLUDE dictionary.redcreek
-$INCLUDE dictionary.roaringpenguin
-$INCLUDE dictionary.shasta
-$INCLUDE dictionary.shiva
-$INCLUDE dictionary.sonicwall
-$INCLUDE dictionary.springtide
-$INCLUDE dictionary.starent
-$INCLUDE dictionary.telebit
-$INCLUDE dictionary.trapeze
-$INCLUDE dictionary.t_systems_nova
-$INCLUDE dictionary.usr
-$INCLUDE dictionary.valemount
-$INCLUDE dictionary.versanet
-$INCLUDE dictionary.waverider
+#$INCLUDE dictionary.mikrotik
+#$INCLUDE dictionary.navini
+#$INCLUDE dictionary.netscreen
+#$INCLUDE dictionary.ntua
+#$INCLUDE dictionary.nomadix
+#$INCLUDE dictionary.nortel
+#$INCLUDE dictionary.packeteer
+#$INCLUDE dictionary.propel
+#$INCLUDE dictionary.quintum
+#$INCLUDE dictionary.redback
+#$INCLUDE dictionary.redcreek
+#$INCLUDE dictionary.roaringpenguin
+#$INCLUDE dictionary.shasta
+#$INCLUDE dictionary.shiva
+#$INCLUDE dictionary.sonicwall
+#$INCLUDE dictionary.springtide
+#$INCLUDE dictionary.starent
+#$INCLUDE dictionary.telebit
+#$INCLUDE dictionary.trapeze
+#$INCLUDE dictionary.t_systems_nova
+#$INCLUDE dictionary.usr
+#$INCLUDE dictionary.valemount
+#$INCLUDE dictionary.versanet
+#$INCLUDE dictionary.waverider
$INCLUDE dictionary.wispr
-$INCLUDE dictionary.xedia
-$INCLUDE dictionary.xylan
+#$INCLUDE dictionary.xedia
+#$INCLUDE dictionary.xylan
#
# And finally the server internal attributes.

View File

@ -1,576 +0,0 @@
diff -ruN freeradius-1.1.1-old/src/modules/rlm_ldap/configure freeradius-1.1.1-new/src/modules/rlm_ldap/configure
--- freeradius-1.1.1-old/src/modules/rlm_ldap/configure 2005-12-08 20:32:53.000000000 +0100
+++ freeradius-1.1.1-new/src/modules/rlm_ldap/configure 2006-05-21 19:54:07.000000000 +0200
@@ -929,13 +929,311 @@
fi
smart_try_dir=$rlm_ldap_lib_dir
+
+
+
+sm_lib_safe=`echo "sasl" | sed 'y%./+-%__p_%'`
+sm_func_safe=`echo "sasl_encode" | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for sasl_encode in -lsasl""... $ac_c" 1>&6
+echo "configure:939: checking for sasl_encode in -lsasl" >&5
+
+old_LIBS="$LIBS"
+smart_lib=
+smart_lib_dir=
+
+if test "x$smart_try_dir" != "x"; then
+ for try in $smart_try_dir; do
+ LIBS="-L$try -lsasl $old_LIBS"
+ cat > conftest.$ac_ext <<EOF
+#line 949 "configure"
+#include "confdefs.h"
+extern char sasl_encode();
+int main() {
+ sasl_encode()
+; return 0; }
+EOF
+if { (eval echo configure:956: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+ smart_lib="-L$try -lsasl"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+fi
+rm -f conftest*
+ if test "x$smart_lib" != "x"; then
+ break;
+ fi
+ done
+ LIBS="$old_LIBS"
+fi
+
+if test "x$smart_lib" = "x"; then
+ LIBS="-lsasl $old_LIBS"
+ cat > conftest.$ac_ext <<EOF
+#line 974 "configure"
+#include "confdefs.h"
+extern char sasl_encode();
+int main() {
+ sasl_encode()
+; return 0; }
+EOF
+if { (eval echo configure:981: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+ smart_lib="-lsasl"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+fi
+rm -f conftest*
+ LIBS="$old_LIBS"
+fi
+
+if test "x$smart_lib" = "x"; then
+
+
+if test "x$LOCATE" != "x"; then
+ DIRS=
+ file=libsasl${libltdl_cv_shlibext}
+
+ for x in `${LOCATE} $file 2>/dev/null`; do
+ base=`echo $x | sed "s%/${file}%%"`
+ if test "x$x" = "x$base"; then
+ continue;
+ fi
+
+ dir=`${DIRNAME} $x 2>/dev/null`
+ exclude=`echo ${dir} | ${GREP} /home`
+ if test "x$exclude" != "x"; then
+ continue
+ fi
+
+ already=`echo \$smart_lib_dir ${DIRS} | ${GREP} ${dir}`
+ if test "x$already" = "x"; then
+ DIRS="$DIRS $dir"
+ fi
+ done
+fi
+
+eval "smart_lib_dir=\"\$smart_lib_dir $DIRS\""
+
+
+
+if test "x$LOCATE" != "x"; then
+ DIRS=
+ file=libsasl.a
+
+ for x in `${LOCATE} $file 2>/dev/null`; do
+ base=`echo $x | sed "s%/${file}%%"`
+ if test "x$x" = "x$base"; then
+ continue;
+ fi
+
+ dir=`${DIRNAME} $x 2>/dev/null`
+ exclude=`echo ${dir} | ${GREP} /home`
+ if test "x$exclude" != "x"; then
+ continue
+ fi
+
+ already=`echo \$smart_lib_dir ${DIRS} | ${GREP} ${dir}`
+ if test "x$already" = "x"; then
+ DIRS="$DIRS $dir"
+ fi
+ done
+fi
+
+eval "smart_lib_dir=\"\$smart_lib_dir $DIRS\""
+
+
+ for try in $smart_lib_dir /usr/local/lib /opt/lib; do
+ LIBS="-L$try -lsasl $old_LIBS"
+ cat > conftest.$ac_ext <<EOF
+#line 1051 "configure"
+#include "confdefs.h"
+extern char sasl_encode();
+int main() {
+ sasl_encode()
+; return 0; }
+EOF
+if { (eval echo configure:1058: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+ smart_lib="-L$try -lsasl"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+fi
+rm -f conftest*
+ if test "x$smart_lib" != "x"; then
+ break;
+ fi
+ done
+ LIBS="$old_LIBS"
+fi
+
+if test "x$smart_lib" != "x"; then
+ echo "$ac_t""yes" 1>&6
+ eval "ac_cv_lib_${sm_lib_safe}_${sm_func_safe}=yes"
+ LIBS="$smart_lib $old_LIBS"
+ SMART_LIBS="$smart_lib $SMART_LIBS"
+else
+ echo "$ac_t""no" 1>&6
+fi
+
+
+
+sm_lib_safe=`echo "lber" | sed 'y%./+-%__p_%'`
+sm_func_safe=`echo "ber_init" | sed 'y%./+-%__p_%'`
+echo $ac_n "checking for ber_init in -llber""... $ac_c" 1>&6
+echo "configure:1087: checking for ber_init in -llber" >&5
+
+old_LIBS="$LIBS"
+smart_lib=
+smart_lib_dir=
+
+if test "x$smart_try_dir" != "x"; then
+ for try in $smart_try_dir; do
+ LIBS="-L$try -llber $old_LIBS"
+ cat > conftest.$ac_ext <<EOF
+#line 1097 "configure"
+#include "confdefs.h"
+extern char ber_init();
+int main() {
+ ber_init()
+; return 0; }
+EOF
+if { (eval echo configure:1104: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+ smart_lib="-L$try -llber"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+fi
+rm -f conftest*
+ if test "x$smart_lib" != "x"; then
+ break;
+ fi
+ done
+ LIBS="$old_LIBS"
+fi
+
+if test "x$smart_lib" = "x"; then
+ LIBS="-llber $old_LIBS"
+ cat > conftest.$ac_ext <<EOF
+#line 1122 "configure"
+#include "confdefs.h"
+extern char ber_init();
+int main() {
+ ber_init()
+; return 0; }
+EOF
+if { (eval echo configure:1129: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+ smart_lib="-llber"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+fi
+rm -f conftest*
+ LIBS="$old_LIBS"
+fi
+
+if test "x$smart_lib" = "x"; then
+
+
+if test "x$LOCATE" != "x"; then
+ DIRS=
+ file=liblber${libltdl_cv_shlibext}
+
+ for x in `${LOCATE} $file 2>/dev/null`; do
+ base=`echo $x | sed "s%/${file}%%"`
+ if test "x$x" = "x$base"; then
+ continue;
+ fi
+
+ dir=`${DIRNAME} $x 2>/dev/null`
+ exclude=`echo ${dir} | ${GREP} /home`
+ if test "x$exclude" != "x"; then
+ continue
+ fi
+
+ already=`echo \$smart_lib_dir ${DIRS} | ${GREP} ${dir}`
+ if test "x$already" = "x"; then
+ DIRS="$DIRS $dir"
+ fi
+ done
+fi
+
+eval "smart_lib_dir=\"\$smart_lib_dir $DIRS\""
+
+
+
+if test "x$LOCATE" != "x"; then
+ DIRS=
+ file=liblber.a
+
+ for x in `${LOCATE} $file 2>/dev/null`; do
+ base=`echo $x | sed "s%/${file}%%"`
+ if test "x$x" = "x$base"; then
+ continue;
+ fi
+
+ dir=`${DIRNAME} $x 2>/dev/null`
+ exclude=`echo ${dir} | ${GREP} /home`
+ if test "x$exclude" != "x"; then
+ continue
+ fi
+
+ already=`echo \$smart_lib_dir ${DIRS} | ${GREP} ${dir}`
+ if test "x$already" = "x"; then
+ DIRS="$DIRS $dir"
+ fi
+ done
+fi
+
+eval "smart_lib_dir=\"\$smart_lib_dir $DIRS\""
+
+
+ for try in $smart_lib_dir /usr/local/lib /opt/lib; do
+ LIBS="-L$try -llber $old_LIBS"
+ cat > conftest.$ac_ext <<EOF
+#line 1199 "configure"
+#include "confdefs.h"
+extern char ber_init();
+int main() {
+ ber_init()
+; return 0; }
+EOF
+if { (eval echo configure:1206: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+ rm -rf conftest*
+ smart_lib="-L$try -llber"
+else
+ echo "configure: failed program was:" >&5
+ cat conftest.$ac_ext >&5
+fi
+rm -f conftest*
+ if test "x$smart_lib" != "x"; then
+ break;
+ fi
+ done
+ LIBS="$old_LIBS"
+fi
+
+if test "x$smart_lib" != "x"; then
+ echo "$ac_t""yes" 1>&6
+ eval "ac_cv_lib_${sm_lib_safe}_${sm_func_safe}=yes"
+ LIBS="$smart_lib $old_LIBS"
+ SMART_LIBS="$smart_lib $SMART_LIBS"
+else
+ echo "$ac_t""no" 1>&6
+fi
+
+
if test "x$rlm_ldap_with_threads" = "xyes"; then
sm_lib_safe=`echo "ldap_r" | sed 'y%./+-%__p_%'`
sm_func_safe=`echo "ldap_init" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for ldap_init in -lldap_r""... $ac_c" 1>&6
-echo "configure:939: checking for ldap_init in -lldap_r" >&5
+echo "configure:1237: checking for ldap_init in -lldap_r" >&5
old_LIBS="$LIBS"
smart_lib=
@@ -945,14 +1243,14 @@
for try in $smart_try_dir; do
LIBS="-L$try -lldap_r $old_LIBS"
cat > conftest.$ac_ext <<EOF
-#line 949 "configure"
+#line 1247 "configure"
#include "confdefs.h"
extern char ldap_init();
int main() {
ldap_init()
; return 0; }
EOF
-if { (eval echo configure:956: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1254: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
smart_lib="-L$try -lldap_r"
else
@@ -970,14 +1268,14 @@
if test "x$smart_lib" = "x"; then
LIBS="-lldap_r $old_LIBS"
cat > conftest.$ac_ext <<EOF
-#line 974 "configure"
+#line 1272 "configure"
#include "confdefs.h"
extern char ldap_init();
int main() {
ldap_init()
; return 0; }
EOF
-if { (eval echo configure:981: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1279: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
smart_lib="-lldap_r"
else
@@ -1047,14 +1345,14 @@
for try in $smart_lib_dir /usr/local/lib /opt/lib; do
LIBS="-L$try -lldap_r $old_LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1051 "configure"
+#line 1349 "configure"
#include "confdefs.h"
extern char ldap_init();
int main() {
ldap_init()
; return 0; }
EOF
-if { (eval echo configure:1058: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1356: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
smart_lib="-L$try -lldap_r"
else
@@ -1087,7 +1385,7 @@
sm_lib_safe=`echo "ldap" | sed 'y%./+-%__p_%'`
sm_func_safe=`echo "ldap_init" | sed 'y%./+-%__p_%'`
echo $ac_n "checking for ldap_init in -lldap""... $ac_c" 1>&6
-echo "configure:1091: checking for ldap_init in -lldap" >&5
+echo "configure:1389: checking for ldap_init in -lldap" >&5
old_LIBS="$LIBS"
smart_lib=
@@ -1097,14 +1395,14 @@
for try in $smart_try_dir; do
LIBS="-L$try -lldap $old_LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1101 "configure"
+#line 1399 "configure"
#include "confdefs.h"
extern char ldap_init();
int main() {
ldap_init()
; return 0; }
EOF
-if { (eval echo configure:1108: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1406: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
smart_lib="-L$try -lldap"
else
@@ -1122,14 +1420,14 @@
if test "x$smart_lib" = "x"; then
LIBS="-lldap $old_LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1126 "configure"
+#line 1424 "configure"
#include "confdefs.h"
extern char ldap_init();
int main() {
ldap_init()
; return 0; }
EOF
-if { (eval echo configure:1133: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1431: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
smart_lib="-lldap"
else
@@ -1199,14 +1497,14 @@
for try in $smart_lib_dir /usr/local/lib /opt/lib; do
LIBS="-L$try -lldap $old_LIBS"
cat > conftest.$ac_ext <<EOF
-#line 1203 "configure"
+#line 1501 "configure"
#include "confdefs.h"
extern char ldap_init();
int main() {
ldap_init()
; return 0; }
EOF
-if { (eval echo configure:1210: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1508: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
smart_lib="-L$try -lldap"
else
@@ -1241,7 +1539,7 @@
ac_safe=`echo "ldap.h" | sed 'y%./+-%__pm%'`
echo $ac_n "checking for ldap.h""... $ac_c" 1>&6
-echo "configure:1245: checking for ldap.h" >&5
+echo "configure:1543: checking for ldap.h" >&5
old_CFLAGS="$CFLAGS"
smart_include=
@@ -1251,7 +1549,7 @@
for try in $smart_try_dir; do
CFLAGS="$old_CFLAGS -I$try"
cat > conftest.$ac_ext <<EOF
-#line 1255 "configure"
+#line 1553 "configure"
#include "confdefs.h"
#include <ldap.h>
@@ -1259,7 +1557,7 @@
int a = 1;
; return 0; }
EOF
-if { (eval echo configure:1263: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1561: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
smart_include="-I$try"
else
@@ -1278,7 +1576,7 @@
if test "x$smart_include" = "x"; then
cat > conftest.$ac_ext <<EOF
-#line 1282 "configure"
+#line 1580 "configure"
#include "confdefs.h"
#include <ldap.h>
@@ -1286,7 +1584,7 @@
int a = 1;
; return 0; }
EOF
-if { (eval echo configure:1290: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1588: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
smart_include=" "
else
@@ -1330,7 +1628,7 @@
for try in $smart_include_dir /usr/local/include /opt/include; do
CFLAGS="$old_CFLAGS -I$try"
cat > conftest.$ac_ext <<EOF
-#line 1334 "configure"
+#line 1632 "configure"
#include "confdefs.h"
#include <ldap.h>
@@ -1338,7 +1636,7 @@
int a = 1;
; return 0; }
EOF
-if { (eval echo configure:1342: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
+if { (eval echo configure:1640: \"$ac_compile\") 1>&5; (eval $ac_compile) 2>&5; }; then
rm -rf conftest*
smart_include="-I$try"
else
@@ -1371,12 +1669,12 @@
if test "x$fail" = "x"; then
echo $ac_n "checking for ldap_start_tls_s""... $ac_c" 1>&6
-echo "configure:1375: checking for ldap_start_tls_s" >&5
+echo "configure:1673: checking for ldap_start_tls_s" >&5
if eval "test \"`echo '$''{'ac_cv_func_ldap_start_tls_s'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1380 "configure"
+#line 1678 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char ldap_start_tls_s(); below. */
@@ -1399,7 +1697,7 @@
; return 0; }
EOF
-if { (eval echo configure:1403: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1701: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_ldap_start_tls_s=yes"
else
@@ -1419,12 +1717,12 @@
fi
echo $ac_n "checking for ldap_initialize""... $ac_c" 1>&6
-echo "configure:1423: checking for ldap_initialize" >&5
+echo "configure:1721: checking for ldap_initialize" >&5
if eval "test \"`echo '$''{'ac_cv_func_ldap_initialize'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1428 "configure"
+#line 1726 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char ldap_initialize(); below. */
@@ -1447,7 +1745,7 @@
; return 0; }
EOF
-if { (eval echo configure:1451: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1749: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_ldap_initialize=yes"
else
@@ -1467,12 +1765,12 @@
fi
echo $ac_n "checking for ldap_int_tls_config""... $ac_c" 1>&6
-echo "configure:1471: checking for ldap_int_tls_config" >&5
+echo "configure:1769: checking for ldap_int_tls_config" >&5
if eval "test \"`echo '$''{'ac_cv_func_ldap_int_tls_config'+set}'`\" = set"; then
echo $ac_n "(cached) $ac_c" 1>&6
else
cat > conftest.$ac_ext <<EOF
-#line 1476 "configure"
+#line 1774 "configure"
#include "confdefs.h"
/* System header to define __stub macros and hopefully few prototypes,
which can conflict with char ldap_int_tls_config(); below. */
@@ -1495,7 +1793,7 @@
; return 0; }
EOF
-if { (eval echo configure:1499: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
+if { (eval echo configure:1797: \"$ac_link\") 1>&5; (eval $ac_link) 2>&5; } && test -s conftest${ac_exeext}; then
rm -rf conftest*
eval "ac_cv_func_ldap_int_tls_config=yes"
else
diff -ruN freeradius-1.1.1-old/src/modules/rlm_ldap/configure.in freeradius-1.1.1-new/src/modules/rlm_ldap/configure.in
--- freeradius-1.1.1-old/src/modules/rlm_ldap/configure.in 2005-08-22 16:50:46.000000000 +0200
+++ freeradius-1.1.1-new/src/modules/rlm_ldap/configure.in 2006-05-21 19:51:25.000000000 +0200
@@ -90,6 +90,10 @@
dnl Static linking will probably not work, but nobody ever
dnl complained about it.
smart_try_dir=$rlm_ldap_lib_dir
+
+ AC_SMART_CHECK_LIB(sasl, sasl_encode)
+ AC_SMART_CHECK_LIB(lber, ber_init)
+
if test "x$rlm_ldap_with_threads" = "xyes"; then
AC_SMART_CHECK_LIB(ldap_r, ldap_init)
if test "x$ac_cv_lib_ldap_r_ldap_init" != "xyes"; then

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,15 @@
--- freeradius-1.1.6-old/src/modules/rules.mak 2006-07-06 18:42:57.000000000 +0200
+++ freeradius-1.1.6-new/src/modules/rules.mak 2007-04-13 03:17:33.000000000 +0200
@@ -62,10 +62,10 @@
#
#######################################################################
%.lo: %.c
- $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(RLM_CFLAGS) -c $<
+ $(LIBTOOL) --mode=compile $(CC) $(CFLAGS) $(CPPFLAGS) $(RLM_CFLAGS) -c $<
%.lo: %.cpp
- $(LIBTOOL) --mode=compile $(CXX) $(CFLAGS) $(RLM_CFLAGS) -c $<
+ $(LIBTOOL) --mode=compile $(CXX) $(CFLAGS) $(CPPFLAGS) $(RLM_CFLAGS) -c $<
ifneq ($(TARGET),)
#######################################################################

View File

@ -0,0 +1,12 @@
diff -ruN freeradius-1.1.6-old/src/main/Makefile.in freeradius-1.1.6-new/src/main/Makefile.in
--- freeradius-1.1.6-old/src/main/Makefile.in 2007-02-14 16:44:23.000000000 +0100
+++ freeradius-1.1.6-new/src/main/Makefile.in 2007-04-13 05:08:11.000000000 +0200
@@ -61,7 +61,7 @@
radiusd: $(SERVER_OBJS) $(MODULE_OBJS) ../lib/libradius.la
$(LIBTOOL) --mode=link $(CC) -export-dynamic -dlopen self \
- $(LDFLAGS) -pie $(LINK_MODE) -o $@ $(SERVER_OBJS) \
+ $(LDFLAGS) $(LINK_MODE) -o $@ $(SERVER_OBJS) \
$(MODULE_LIBS) $(LIBS) $(SNMP_LIBS) $(PTHREADLIB) \
$(LIBLTDL) $(OPENSSL_LIBS)