[package] asterisk-chan-sccp-b: update to revision 3004, cleanup Makefile
Patch from Hans Zandbelt. git-svn-id: svn://svn.openwrt.org/openwrt/packages@28647 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a9f8432212
commit
dae1e13e47
@ -8,21 +8,16 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=asterisk18-chan-sccp-b
|
||||
# associated with asterisk version
|
||||
PKG_VERSION:=1.8.4.4
|
||||
# chan-sccp-b version
|
||||
PKG_RELEASE:=V4.0.0
|
||||
PKG_REV=3004
|
||||
PKG_VERSION:=r$(PKG_REV)
|
||||
PKG_RELEASE:=1
|
||||
|
||||
# SVN
|
||||
PKG_REV=2797
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=https://chan-sccp-b.svn.sourceforge.net/svnroot/chan-sccp-b/trunk
|
||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_SOURCE_VERSION:=$(PKG_REV)
|
||||
PKG_SOURCE_PROTO:=svn
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/asterisk18-chan-sccp-b
|
||||
@ -31,7 +26,7 @@ define Package/asterisk18-chan-sccp-b
|
||||
CATEGORY:=Network
|
||||
TITLE:=SCCP channel provider for asterisk
|
||||
URL:=http://chan-sccp-b.net.sourceforge.net/
|
||||
MAINTAINER:=Diederik de Groot <ddegroot@users.sourceforge.net>
|
||||
MAINTAINER:=Hans Zandbelt <hans.zandbelt@gmail.com>
|
||||
DEPENDS:=+asterisk18
|
||||
endef
|
||||
|
||||
@ -40,29 +35,25 @@ define Package/asterisk18-chan-sccp-b/description
|
||||
by asterisk by default.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
$(TARGET_CONFIGURE_OPTS) \
|
||||
./configure \
|
||||
--prefix=/usr \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
--host=$(GNU_TARGET_NAME) \
|
||||
--build=$(GNU_HOST_NAME) \
|
||||
--with-asterisk="$(PKG_BUILD_DIR)/../asterisk-${PKG_VERSION}/" \
|
||||
);
|
||||
endef
|
||||
CONFIGURE_ARGS += \
|
||||
--with-asterisk=$(STAGING_DIR)/usr/include/asterisk-1.8
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS)
|
||||
mkdir -p $(PKG_INSTALL_DIR)/usr/lib/modules/asterisk
|
||||
mkdir -p $(PKG_INSTALL_DIR)/etc/astisk
|
||||
$(MAKE) -C "$(PKG_BUILD_DIR)" \
|
||||
CFLAGS="$(CFLAGS) -DLOW_MEMORY" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
all install
|
||||
endef
|
||||
|
||||
define Package/asterisk18-chan-sccp-b/conffiles
|
||||
/etc/asterisk/sccp.conf
|
||||
endef
|
||||
|
||||
define Package/asterisk18-chan-sccp-b/install
|
||||
$(INSTALL_DIR) $(1)/etc/asterisk
|
||||
$(INSTALL_BIN) ./files/sccp.openwrt.conf $(1)/etc/asterisk/sccp.conf
|
||||
$(INSTALL_DIR) $(1)/usr/lib/asterisk/modules
|
||||
$(CP) $(PKG_BUILD_DIR)/src/.libs/chan_sccp.so $(1)/usr/lib/asterisk/modules/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/asterisk/modules/chan_sccp.so $(1)/usr/lib/asterisk/modules/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,asterisk18-chan-sccp-b))
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/src/chan_sccp.h
|
||||
+++ b/src/chan_sccp.h
|
||||
@@ -172,15 +172,7 @@
|
||||
@@ -127,15 +127,7 @@ extern "C" {
|
||||
# define CHECK_LEAKS()
|
||||
# endif
|
||||
|
||||
|
10
net/asterisk-chan-sccp-b/patches/300-stdarg.patch
Normal file
10
net/asterisk-chan-sccp-b/patches/300-stdarg.patch
Normal file
@ -0,0 +1,10 @@
|
||||
--- a/src/chan_sccp.h
|
||||
+++ b/src/chan_sccp.h
|
||||
@@ -32,6 +32,7 @@ extern "C" {
|
||||
#include "common.h"
|
||||
#include <poll.h>
|
||||
#include "asterisk/compiler.h"
|
||||
+#include <stdarg.h>
|
||||
#include "asterisk/lock.h"
|
||||
#include "asterisk/abstract_jb.h"
|
||||
|
Loading…
x
Reference in New Issue
Block a user