[package] upgrade mc to 4.7.5.1
Signed-off-by: Luka Perkov < openwrt ->-to->- lukaperkov.net > git-svn-id: svn://svn.openwrt.org/openwrt/packages@26347 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
b5f1d5b071
commit
daeb348e3b
@ -8,19 +8,20 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=mc
|
PKG_NAME:=mc
|
||||||
PKG_VERSION:=4.6.2
|
PKG_VERSION:=4.7.5.1
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.midnight-commander.org/downloads/
|
PKG_SOURCE_URL:=http://www.midnight-commander.org/downloads/
|
||||||
PKG_MD5SUM:=ec92966f4d0c8b50c344fe901859ae2a
|
PKG_MD5SUM:=e673b7ec0191e4061b5d8b69368aa113
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
include $(INCLUDE_DIR)/nls.mk
|
||||||
|
|
||||||
define Package/mc
|
define Package/mc
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
DEPENDS:=+glib1 +libncurses
|
DEPENDS:=+glib2 +libncurses +libiconv
|
||||||
TITLE:=midnight commander - a powerful file manager
|
TITLE:=midnight commander - a powerful file manager
|
||||||
URL:=http://www.midnight-commander.org/
|
URL:=http://www.midnight-commander.org/
|
||||||
SUBMENU:=filemanager
|
SUBMENU:=filemanager
|
||||||
@ -37,32 +38,12 @@ define Package/mc/description
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
CONFIGURE_ARGS += \
|
||||||
--with-included-gettext \
|
--without-edit \
|
||||||
--with-ncurses \
|
|
||||||
--without-sco \
|
|
||||||
--without-sunos-curses \
|
|
||||||
--without-osf1-curses \
|
|
||||||
--without-vcurses \
|
|
||||||
--without-gpm-mouse \
|
--without-gpm-mouse \
|
||||||
--without-hsc \
|
|
||||||
--without-termnet \
|
|
||||||
--without-debug \
|
|
||||||
--without-efence \
|
|
||||||
--without-terminfo \
|
|
||||||
--without-termcap \
|
|
||||||
--without-slang \
|
|
||||||
--without-vfs \
|
|
||||||
--without-netrc \
|
|
||||||
--without-ext2undel \
|
|
||||||
--without-catgets \
|
|
||||||
--without-x \
|
|
||||||
--without-tk \
|
|
||||||
--without-xview \
|
|
||||||
--without-subshell \
|
--without-subshell \
|
||||||
--disable-glibtest \
|
--without-x \
|
||||||
--with-glib12 \
|
--disable-vfs \
|
||||||
--with-glib-prefix="$(STAGING_DIR)/usr" \
|
--with-screen=ncurses
|
||||||
|
|
||||||
|
|
||||||
AM_HOST=$(firstword $(wildcard $(STAGING_DIR_HOST)/share/automake-*))
|
AM_HOST=$(firstword $(wildcard $(STAGING_DIR_HOST)/share/automake-*))
|
||||||
|
|
||||||
@ -77,7 +58,6 @@ endef
|
|||||||
define Package/mc/install
|
define Package/mc/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin/
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/mc $(1)/usr/bin/
|
||||||
ln -nsf mc $(1)/usr/bin/mcedit
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,mc))
|
$(eval $(call BuildPackage,mc))
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
--- a/edit/syntax.c
|
|
||||||
+++ b/edit/syntax.c
|
|
||||||
@@ -1193,10 +1193,7 @@ edit_load_syntax (WEdit *edit, char ***p
|
|
||||||
r = edit_read_syntax_file (edit, pnames, f, edit ? edit->filename : 0,
|
|
||||||
get_first_editor_line (edit), type);
|
|
||||||
if (r == -1) {
|
|
||||||
- edit_free_syntax_rules (edit);
|
|
||||||
- message (D_ERROR, _(" Load syntax file "),
|
|
||||||
- _(" Cannot open file %s \n %s "), f,
|
|
||||||
- unix_error_string (errno));
|
|
||||||
+ /* missing syntax file */
|
|
||||||
} else if (r) {
|
|
||||||
edit_free_syntax_rules (edit);
|
|
||||||
message (D_ERROR, _(" Load syntax file "),
|
|
Loading…
x
Reference in New Issue
Block a user