[packages] alsa-utils: update to 1.0.24.2 (thanks Acinonyx)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@26035 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3eac0af243
commit
dafb469a62
@ -8,13 +8,13 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=alsa-utils
|
||||
PKG_VERSION:=1.0.23
|
||||
PKG_VERSION:=1.0.24.2
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.alsa-project.org/pub/utils/ \
|
||||
http://alsa.cybermirror.org/utils/
|
||||
PKG_MD5SUM:=cb0cf46029ac9549cf3a31bff6a4f4e1
|
||||
PKG_MD5SUM:=8238cd57cb301d1c36bcf0ecb59ce6b2
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
25
utils/alsa-utils/patches/100-uClibc-compat.patch
Normal file
25
utils/alsa-utils/patches/100-uClibc-compat.patch
Normal file
@ -0,0 +1,25 @@
|
||||
Index: alsa-utils-1.0.24.2/alsamixer/volume_mapping.c
|
||||
===================================================================
|
||||
--- alsa-utils-1.0.24.2.orig/alsamixer/volume_mapping.c 2011-03-11 13:26:29.000000000 +0100
|
||||
+++ alsa-utils-1.0.24.2/alsamixer/volume_mapping.c 2011-03-11 13:27:58.000000000 +0100
|
||||
@@ -109,9 +109,9 @@
|
||||
if (use_linear_dB_scale(min, max))
|
||||
return (value - min) / (double)(max - min);
|
||||
|
||||
- normalized = exp10((value - max) / 6000.0);
|
||||
+ normalized = pow(10, (value - max) / 6000.0);
|
||||
if (min != SND_CTL_TLV_DB_GAIN_MUTE) {
|
||||
- min_norm = exp10((min - max) / 6000.0);
|
||||
+ min_norm = pow(10, (min - max) / 6000.0);
|
||||
normalized = (normalized - min_norm) / (1 - min_norm);
|
||||
}
|
||||
|
||||
@@ -144,7 +144,7 @@
|
||||
}
|
||||
|
||||
if (min != SND_CTL_TLV_DB_GAIN_MUTE) {
|
||||
- min_norm = exp10((min - max) / 6000.0);
|
||||
+ min_norm = pow(10, (min - max) / 6000.0);
|
||||
volume = volume * (1 - min_norm) + min_norm;
|
||||
}
|
||||
value = lrint_dir(6000.0 * log10(volume), dir) + max;
|
Loading…
x
Reference in New Issue
Block a user