[package] update rtorrent to r1189
This patch upgrades libtorrent and rtorrent to svn version 1189. Signed-off-by: Luka Perkov < openwrt ->-to->- lukaperkov.net > git-svn-id: svn://svn.openwrt.org/openwrt/packages@24174 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
10f42f7b22
commit
db94c2728b
@ -9,9 +9,9 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=rtorrent
|
PKG_NAME:=rtorrent
|
||||||
PKG_REV:=1165
|
PKG_REV:=1189
|
||||||
PKG_VERSION:=0.8.6_r$(PKG_REV)
|
PKG_VERSION:=0.8.6_r$(PKG_REV)
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/rtorrent
|
PKG_SOURCE_URL:=svn://rakshasa.no/libtorrent/trunk/rtorrent
|
||||||
|
@ -1,3 +1,5 @@
|
|||||||
|
diff --git a/rak/allocators.h b/rak/allocators.h
|
||||||
|
index 0a1b711..2d7b98e 100644
|
||||||
--- a/rak/allocators.h
|
--- a/rak/allocators.h
|
||||||
+++ b/rak/allocators.h
|
+++ b/rak/allocators.h
|
||||||
@@ -42,6 +42,7 @@
|
@@ -42,6 +42,7 @@
|
||||||
@ -25,11 +27,11 @@
|
|||||||
|
|
||||||
void construct (pointer p, const T& value) { new((void*)p)T(value); }
|
void construct (pointer p, const T& value) { new((void*)p)T(value); }
|
||||||
void destroy (pointer p) { p->~T(); }
|
void destroy (pointer p) { p->~T(); }
|
||||||
- void deallocate (pointer p, size_type num) { ::operator delete((void*)p); }
|
- void deallocate (pointer p, size_type num) { free((void*)p); }
|
||||||
};
|
};
|
||||||
|
|
||||||
|
|
||||||
@@ -98,6 +95,36 @@ bool operator!= (const cacheline_allocat
|
@@ -98,6 +95,36 @@ bool operator!= (const cacheline_allocator<T1>&, const cacheline_allocator<T2>&)
|
||||||
return false;
|
return false;
|
||||||
}
|
}
|
||||||
|
|
||||||
|
Loading…
x
Reference in New Issue
Block a user