[package] opennhrp: update to 0.12.3

Signed-off-by: Artem Makhutov <artem@makhutov.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@28324 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2011-09-30 12:49:00 +00:00
parent aa63ffdfbe
commit dc07bbe002
2 changed files with 3 additions and 16 deletions

View File

@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=opennhrp
PKG_VERSION:=0.11.3
PKG_VERSION:=0.12.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=@SF/opennhrp
PKG_MD5SUM:=6f6f8571ccc0a9f97e52c6240fe9002a
PKG_MD5SUM:=4d0ec7c0282e181ecca4d78e52067da3
PKG_FIXUP:=libtool
PKG_BUILD_PARALLEL:=1
@ -49,6 +49,7 @@ define Package/opennhrp/install
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp.conf $(1)/etc/opennhrp/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/opennhrp-script $(1)/etc/opennhrp/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1down.sh $(1)/etc/opennhrp/
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/etc/opennhrp/racoon-ph1dead.sh $(1)/etc/opennhrp/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/opennhrp.init $(1)/etc/init.d/opennhrp
endef

View File

@ -1,14 +0,0 @@
---
nhrp/sysdep_netlink.c | 1 +
1 file changed, 1 insertion(+)
--- opennhrp-0.11.3.orig/nhrp/sysdep_netlink.c
+++ opennhrp-0.11.3/nhrp/sysdep_netlink.c
@@ -26,6 +26,7 @@
#include <asm/types.h>
#include <linux/netlink.h>
#include <linux/rtnetlink.h>
+#include <linux/in6.h>
#include <linux/ip.h>
#include <linux/if_arp.h>
#include <linux/if_tunnel.h>