[packages] curl: make it cross compile safe again, remove configure time detection of openssl and gnutls paths
git-svn-id: svn://svn.openwrt.org/openwrt/packages@24666 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f03a24add6
commit
dcab670d6f
87
libs/curl/patches/100-cross_compile.patch
Normal file
87
libs/curl/patches/100-cross_compile.patch
Normal file
@ -0,0 +1,87 @@
|
||||
--- a/configure
|
||||
+++ b/configure
|
||||
@@ -19785,17 +19785,6 @@ $as_echo "no" >&6; }
|
||||
fi
|
||||
rm -f core conftest.err conftest.$ac_objext conftest.$ac_ext
|
||||
fi
|
||||
-
|
||||
- if test "$OPENSSL_ENABLED" = "1"; then
|
||||
- if test -n "$LIB_OPENSSL"; then
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
|
||||
- export LD_LIBRARY_PATH
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&5
|
||||
-$as_echo "$as_me: Added $LIB_OPENSSL to LD_LIBRARY_PATH" >&6;}
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
|
||||
@@ -20251,21 +20240,6 @@ else
|
||||
CPPFLAGS="$CLEANCPPFLAGS"
|
||||
|
||||
fi
|
||||
-
|
||||
-
|
||||
- if test "x$USE_GNUTLS" = "xyes"; then
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: detected GnuTLS version $version" >&5
|
||||
-$as_echo "$as_me: detected GnuTLS version $version" >&6;}
|
||||
-
|
||||
- if test -n "$gtlslib"; then
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
|
||||
- export LD_LIBRARY_PATH
|
||||
- { $as_echo "$as_me:${as_lineno-$LINENO}: Added $gtlslib to LD_LIBRARY_PATH" >&5
|
||||
-$as_echo "$as_me: Added $gtlslib to LD_LIBRARY_PATH" >&6;}
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
fi
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1494,19 +1494,6 @@ if test X"$OPT_SSL" != Xno; then
|
||||
AC_MSG_RESULT([no])
|
||||
])
|
||||
fi
|
||||
-
|
||||
- if test "$OPENSSL_ENABLED" = "1"; then
|
||||
- if test -n "$LIB_OPENSSL"; then
|
||||
- dnl when the ssl shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
|
||||
- dnl to prevent further configure tests to fail due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $LIB_OPENSSL to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
dnl **********************************************************************
|
||||
@@ -1714,22 +1701,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
|
||||
LIBS="$CLEANLIBS"
|
||||
CPPFLAGS="$CLEANCPPFLAGS"
|
||||
])
|
||||
-
|
||||
- if test "x$USE_GNUTLS" = "xyes"; then
|
||||
- AC_MSG_NOTICE([detected GnuTLS version $version])
|
||||
-
|
||||
- if test -n "$gtlslib"; then
|
||||
- dnl when shared libs were found in a path that the run-time
|
||||
- dnl linker doesn't search through, we need to add it to
|
||||
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
|
||||
- dnl due to this
|
||||
-
|
||||
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
|
||||
- export LD_LIBRARY_PATH
|
||||
- AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
|
||||
- fi
|
||||
- fi
|
||||
-
|
||||
fi
|
||||
|
||||
fi dnl GNUTLS not disabled
|
Loading…
x
Reference in New Issue
Block a user