[packages] collectd: fix olsrd plugin statistics. Recent olsr-mod-txtinfo versions require the client to send "/all" to report all stats
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29435 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
4c5b3ffd43
commit
dd40e5c039
@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=collectd
|
||||
PKG_VERSION:=4.10.2
|
||||
PKG_RELEASE:=4
|
||||
PKG_RELEASE:=5
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://collectd.org/files/
|
||||
|
11
utils/collectd/patches/400-fix-olsrd-get-all.patch
Normal file
11
utils/collectd/patches/400-fix-olsrd-get-all.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/src/olsrd.c
|
||||
+++ b/src/olsrd.c
|
||||
@@ -653,7 +653,7 @@ static int olsrd_read (void) /* {{{ */
|
||||
if (fh == NULL)
|
||||
return (-1);
|
||||
|
||||
- fputs ("\r\n", fh);
|
||||
+ fputs ("/all \r\n", fh);
|
||||
fflush (fh);
|
||||
|
||||
while (fgets (buffer, sizeof (buffer), fh) != NULL)
|
Loading…
x
Reference in New Issue
Block a user