fix strace for eabi and newer kernel versions
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14082 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c86cbc10c1
commit
dee94b1f9b
@ -11,21 +11,14 @@ include $(TOPDIR)/rules.mk
|
||||
PKG_NAME:=strace
|
||||
PKG_RELEASE:=2
|
||||
|
||||
ifneq ($(CONFIG_LINUX_2_6_27),y)
|
||||
OLD_KERNEL=$(findstring y,$(foreach v,23 24 25 26,$(CONFIG_LINUX_2_6_$(v))))
|
||||
ifneq ($(OLD_KERNEL),)
|
||||
PKG_VERSION:=4.5.16
|
||||
PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
|
||||
endif
|
||||
|
||||
ifeq ($(CONFIG_TARGET_uml),y)
|
||||
PATCH_DIR:=patches-4.5.16
|
||||
else
|
||||
PKG_VERSION:=4.5.18
|
||||
PKG_MD5SUM:=e9449fcee97e6a8ed73934c883c870e0
|
||||
PATCH_DIR:=./none
|
||||
endif
|
||||
|
||||
ifeq ($(CONFIG_LINUX_2_6_27)$(CONFIG_LINUX_2_6_28),y)
|
||||
PKG_VERSION:=4.5.18
|
||||
PKG_MD5SUM:=e9449fcee97e6a8ed73934c883c870e0
|
||||
PATCH_DIR:=./none
|
||||
endif
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
|
33
utils/strace/patches/100-eabi.patch
Normal file
33
utils/strace/patches/100-eabi.patch
Normal file
@ -0,0 +1,33 @@
|
||||
--- a/linux/arm/syscallent.h
|
||||
+++ b/linux/arm/syscallent.h
|
||||
@@ -431,7 +431,7 @@
|
||||
{ 5, 0, printargs, "SYS_398" }, /* 398 */
|
||||
{ 5, 0, printargs, "SYS_399" }, /* 399 */
|
||||
|
||||
-#if SYS_socket_subcall != 400
|
||||
+#if defined(SYS_socket_subcall) && (SYS_socket_subcall != 400)
|
||||
#error fix me
|
||||
#endif
|
||||
{ 8, 0, printargs, "socket_subcall"}, /* 400 */
|
||||
@@ -453,7 +453,7 @@
|
||||
{ 5, TN, sys_sendmsg, "sendmsg" }, /* 416 */
|
||||
{ 5, TN, sys_recvmsg, "recvmsg" }, /* 417 */
|
||||
|
||||
-#if SYS_ipc_subcall != 418
|
||||
+#if defined(SYS_ipc_subcall) && (SYS_ipc_subcall != 418)
|
||||
#error fix me
|
||||
#endif
|
||||
{ 4, 0, printargs, "ipc_subcall" }, /* 418 */
|
||||
--- a/system.c
|
||||
+++ b/system.c
|
||||
@@ -70,10 +70,6 @@
|
||||
#include <linux/capability.h>
|
||||
#endif
|
||||
|
||||
-#ifdef SYS_cacheflush
|
||||
-#include <asm/cachectl.h>
|
||||
-#endif
|
||||
-
|
||||
#ifdef HAVE_LINUX_USTNAME_H
|
||||
#include <linux/utsname.h>
|
||||
#endif
|
Loading…
x
Reference in New Issue
Block a user